AC ON Causes VERY LOUD ENGINE [Archive] - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum

: AC ON Causes VERY LOUD ENGINE


nelfort
05-31-2007, 09:12 AM
Hey guys

About 3 months ago I replaced my fan clutch and all was running great.Now as the heat is here and I turn on my AC my engine's noise is exact same when my fan clutch was gone, that loud revving sound if I was driving a dump truck in first gear.
Is this my fan clutch going again?any suggestions or comments are great appreciated

Thanks in advance

Wut_is_pewter
05-31-2007, 09:19 AM
mine does that every once in a while when i first start it, sounds like the dan is on or somethin like that i dont really know what it is, but it goes away after a while. but thats with or without the A/C on it juss kinda does that occasionally like when its warm and i first start the truck...

BTW i have an I6 so we aren' texactly the same but same idea

GusMan
06-01-2007, 02:02 PM
Did you replace it or did you have the dealer do it? From what I recall, in some cases you need to have the PCM reflashed after the fan clutch is replaced.

MrNorthFace
06-13-2007, 11:14 PM
So do you have to have the PCM reflashed? I just had my fan clutch & other items replaced AGAIN (5th time for the fan clutch!...under warranty again )
Now it makes that same loud sound as you described....just like you were in low gear & in first gear....just sounds labored. It doesn't always do that....but if I need to have the PCM reflashed.......I have the pcmforless computer in there....don't want it to get messed up.

Suggestions?

RayVoy
06-14-2007, 04:40 PM
Hey guys

About 3 months ago I replaced my fan clutch and all was running great.Now as the heat is here and I turn on my AC my engine's noise is exact same when my fan clutch was gone, that loud revving sound if I was driving a dump truck in first gear.
Is this my fan clutch going again?any suggestions or comments are great appreciated

Thanks in advance I am thinking, that if it's hot in your neighbourhood, the engine fan will be on more than off. The ac will induce extra engine load and toss extra heat into the rad. The fan must run more to keep it cool. That is good!!!! But, should it be making that much noise when it runs???

ssilicon
06-15-2007, 01:20 PM
Mine makes a real loud sound too when I first start it sometimes. It usually goes away before long. I just figured it was normal operation? Does it indicate a problem? I'm not getting any over heating or trouble of any kind else-wise.

I should add that this can happen regardless if AC is on or not. In fact the times I remember it I wasn't running AC.

turbomike
06-15-2007, 04:12 PM
The updated fan clutch (on vehicles built after Jun 05) will engage for about 2minutes after startup. This is to keep compressor from cycling on high head pressure until the fan clutch can respond from a engage command from the PCM.

jgiglio
07-03-2007, 08:22 PM
Still don't understand, is the fan noise a problem with the fan clutch or a programing problem? I have an 03 TB, LT 5.3 with 105k km, and the same problem has started over the last few months. This is the first time since new, noise is not right away on cold start-up but seems to be after driving, parking for a while (5-20min), then restart. I have search the forums and others seem to be having the same problem, but no sure solution....except efans.
FYI, for those having the problem in the winter and/or summer. If you have auto climate control, your A/C compressor will come on all year.

On a related issue of noises under the hood...I am hearing what sounds to be a vacuum leak. On slight tip of throttle there is a woosh/sucking sound. Listened and can't isolate where from. I had this problem while still under warranty a few years ago and the dealer solved the problem but I can't find my original work order, for the solution. Any ideas.

Thanks in advance

nelfort
07-12-2007, 10:19 AM
I am thinking, that if it's hot in your neighbourhood, the engine fan will be on more than off. The ac will induce extra engine load and toss extra heat into the rad. The fan must run more to keep it cool. That is good!!!! But, should it be making that much noise when it runs???

Fan clutch has been coming on constant lately and even got engine light every so often so looked under hood and the plug that is attached to shroud was not clipped in all the way so I guess was causing the issue. Clipped in properly and all working great now.

Thanks