which is BANK 1 oxygen sensor? [Archive] - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum

: which is BANK 1 oxygen sensor?


vault
06-22-2009, 06:20 PM
there are two oxygen sensors. Does anyone know which one is BANK 1 sensor? (forward or aft sensor)?

jackedupcanyon
06-22-2009, 08:44 PM
Are you getting a code of some sorts? Bank 1 / 2 refers to each side in a V8 engine - not front or rear. The I6 only has bank 1.

http://www.obd-codes.com/faq/what-is-bank-1-and-bank-2.php

Boricua SS
06-22-2009, 08:56 PM
Are you getting a code of some sorts? Bank 1 / 2 refers to each side in a V8 engine - not front or rear. The I6 only has bank 1.

http://www.obd-codes.com/faq/what-is-bank-1-and-bank-2.php

:iagree: i have 4 in my TBSS.. and Bank 1 is driverside pre catalytic converter

vault
06-22-2009, 09:20 PM
Yes, i have a code, its been a while since i scanned it so i can't quite recall what it is...maybe p0172 ...something like that i think. anyway...i had take the TB in to have something else scanned and the mech. confirmed that the O2 sensor has a fault and said it is BANK 1. I asked which one that is and he didn't know.
The TB has two O2 sensors, one right at the start of the exhaust off the engine and the other is aft of the cat. so this is why i am asking this question "fwd or aft".

Now, the check engine indication for the O2 sensor is intermitant and has been gone for quite a while and is now back again. so would like to tackle this soon.

so if anyone has a clearification of this, it would be greatly appreciated

jackedupcanyon
06-22-2009, 10:02 PM
Take it to a local auto parts store and have the code scanned again (for free). The I6 only has 1 bank. Sensor 1 would be the front and sensor 2 would be the rear.

http://www.obd-codes.com/trouble_codes/
# P0130 02 Sensor Circuit Malfunction (Bank I Sensor 1)
# P0131 02 Sensor Circuit Low Voltage (Bank I Sensor I)
# P0132 02 Sensor Circuit High Voltage (Bank I Sensor 1)
# P0133 02 Sensor Circuit Slow Response (Bank 1 Sensor 1)
# P0134 02 Sensor Circuit No Activity Detected (Bank I Sensor 1)
# P0135 02 Sensor Heater Circuit Malfunction (Bank 1 Sensor 1)
# P0136 02 Sensor Circuit Malfunction (Bank I Sensor 2)
# P0137 02 Sensor Circuit Low Voltage (Bank I Sensor 2)
# P0138 02 Sensor Circuit High Voltage (Bank I Sensor 2)
# P0139 02 Sensor Circuit Slow Response (Bank 1 Sensor 2)
# P0140 02 Sensor Circuit No Activity Detected (Bank 1 Sensor 2)
# P0141 02 Sensor Heater Circuit Malfunction (Bank 1 Sensor 2)
# P0142 02 Sensor Circuit Malfunction (Bank I Sensor 3)
# P0143 02 Sensor Circuit Low Voltage (Bank I Sensor 3)
# P0144 02 Sensor Circuit High Voltage (Bank I Sensor 3)
# P0145 02 Sensor Circuit Slow Response (Bank 1 Sensor 3)
# P0146 02 Sensor Circuit No Activity Detected (Bank I Sensor 3)
# P0147 02 Sensor Heater Circuit Malfunction (Bank I Sensor 3)
# P0150 02 Sensor Circuit Malfunction (Bank 2 Sensor I)
# P0151 02 Sensor Circuit Low Voltage (Bank 2 Sensor I)
# P0152 02 Sensor Circuit High Voltage (Bank 2 Sensor 1)
# P0153 02 Sensor Circuit Slow Response (Bank 2 Sensor 1)
# P0154 02 Sensor Circuit No Activity Detected (Bank 2 Sensor 1)
# P0155 02 Sensor Heater Circuit Malfunction (Bank 2 Sensor 1)
# P0156 02 Sensor Circuit Malfunction (Bank 2 Sensor 2)
# P0157 02 Sensor Circuit Low Voltage (Bank 2 Sensor 2)
# P0158 02 Sensor Circuit High Voltage (Bank 2 Sensor 2)
# P0159 02 Sensor Circuit Slow Response (Bank 2 Sensor 2)
# P0160 02 Sensor Circuit No Activity Detected (Bank 2 Sensor 2)
# P0161 02 Sensor Heater Circuit Malfunction (Bank 2 Sensor 2)
# P0162 02 Sensor Circuit Malfunction (Bank 2 Sensor 3)
# P0163 02 Sensor Circuit Low Voltage (Bank 2 Sensor 3)
# P0164 02 Sensor Circuit High Voltage (Bank 2 Sensor 3)
# P0165 02 Sensor Circuit Slow Response (Bank 2 Sensor 3)
# P0166 02 Sensor Circuit No Activity Detected (Bank 2 Sensor 3)
# P0167 02 Sensor Heater Circuit Malfunction (Bank 2 Sensor 3)

vault
06-22-2009, 10:23 PM
Thanks for the code chart jackedupcanyon.
yea, i plan to re scan it. i don't recall when i had the mech scan for the other problem that it was sensor 1 or 2. One of those codes with "low voltage" seems to be familiar when i scanned it the last time.
thanks again for your info!

jackedupcanyon
06-23-2009, 06:34 AM
Thanks for the code chart jackedupcanyon.
yea, i plan to re scan it. i don't recall when i had the mech scan for the other problem that it was sensor 1 or 2. One of those codes with "low voltage" seems to be familiar when i scanned it the last time.
thanks again for your info!

Get that code scanned and go from there. Post back up with the code and the fix or another question. Good luck.

mikemu79
06-23-2009, 01:32 PM
Make sure to fill out your profile to let us know what vehicle you have. As you can see it is quite hard to help since we do not know what you drive. This forum covers 3 diff engines. Welcome aboard though.

filthyfingers
06-24-2009, 06:45 AM
The O2 sensor before the cat is prone to failure. The sensor after the cat rarely fails. How many miles on your Trailvoy? Don't wait too long to get this fixed because your cat can be damaged if too much fuel is passed through it.

vault
06-24-2009, 08:06 AM
Thanks filthyfingers,
I have 230,000 km (143,000 miles) on my trailblazer. I have yet to rescan the vehical (will do in the next few days here). i have a strong feeling its the forward sensor, so thanks for the info that the forward ones tend to fail.

Robert1101
06-24-2009, 08:22 AM
i had take the TB in to have something else scanned and the mech. confirmed that the O2 sensor has a fault and said it is BANK 1. I asked which one that is and he didn't know.

If he did not know which O2 sensor was at fault you need to find another mechanic. Or should I just call him an oil changer?
Just my :m2:

vault
06-24-2009, 10:28 AM
If he did not know which O2 sensor was at fault you need to find another mechanic. Or should I just call him an oil changer?
Just my :m2:

yea i found that kinda funny too that he didn't know. I like to do my own work, but i needed the 4wd system scanned because it is not working, he couldn't find any faults in the 4wd system and confirmed to me that the o2 had a fault.

:offtopic: On that note...i have done alot of research on the 4wd problem...i think i will start with the transfer case switch.
heres the details:
-switch lights blinking
-uncommanded 4wd switching --4 hi, 2hi, 4 lo (when driving and stationary in park)
-switch lights not on at all now. (syetem not functioning at all)

any thoughts?

the roadie
06-24-2009, 12:40 PM
-switch lights blinking
-uncommanded 4wd switching --4 hi, 2hi, 4 lo (when driving and stationary in park)
-switch lights not on at all now. (syetem not functioning at all)

any thoughts?Any more discussion about this we should take it to the proper forum. Anyway, the switch contacts could be oxidized from lack of use if you weren't regularly trying it. Try turning it one end to the other 100 times with the power off, then try again. If not, get an Ebay switch.

vault
06-24-2009, 06:14 PM
thanks roadie, i'll try that with the switch

its_sak
07-01-2009, 03:37 AM
I think bank 1 refers to the sensor before the cat. Im getting the same code again. I got this code about 3 months ago. I replaced the O2 sensor, bank 1 in the front and it didnt go away. I then replaced the spark plugs and the error went away for 3 months. Two weeks ago i replaced the fuel filter and transmission filter. A week later this code came back. Any other suggestions? Its finally starting to bug me.

potomaccad
10-11-2011, 01:05 PM
Hello gents. I'm new here with my 2004 Trailblazer L6 4.2 burgandy color.

Just replaced the 02 sensor and a new alternator. During my work I found this Bluetooth OBD reader that goes with my Android phone. I-phone has the same thing. You can get the bluetooth reader for under $30 bucks and the application for your phone is FREE.

You can read code with descriptions and clear codes as well. It will always be ready and with you.

If you have an I-phone or an Android phone, you can download an app for FREE and then buy a bluetooth code reader that works with your phone. I love it and it works great.

Details:
1. Download an app called TORQUE it's FREE.
2. Buy a Bluetooth Code reader for $26.81 here if you like:
http://www.amazon.com/gp/product/B004KL0I9I

You can also just leave the code reader plugged into your Trailblazer if you want.

That's it! Enjoy!

Roadie, if you see this post and it's in the wrong spot, would you mind moving it or excusing me, as I'm not sure if this is ok to post here or not. I just pulled a P0410 code and while trying to figure out how to fix it I found everybody talking about code readers and this is how I ended up here. Thanks!

the roadie
10-11-2011, 01:55 PM
Well, I don't really need to move your post, but there already is an ongoing discussion about the Torque app. Did you find that in your search?

potomaccad
10-12-2011, 01:00 PM
Found it.

matthewcc17
12-21-2011, 07:33 PM
This is straight from the OBD2 site

A code P0172 may mean that one or more of the following has happened:

The MAF (Mass Air Flow) Sensor is dirty or faulty. Note: The use of "oiled" air filters can cause the MAF to become dirty if the filter is over-oiled. There is also an issue with some vehicles where the MAF sensors leak the silicone potting material used to protect the circuitry.
There could be a vacuum leak.
There could be a fuel pressure or delivery problem

Possible solutions include:

Inspect all vacuum and PCV hoses, replace if necessary
Cleanthe MAF sensor. Consult your service manual for it's location if you need help. I find it's best to take it off and spray it with electronics cleaner or brake cleaner. Make sure you are careful not to damage the MAF sensor, and make sure it's dry before reinstalling
Inspect fuel lines for cracks, leaks, or pinches
Check the fuel pressure at the fuel rail
Check the fuel injectors, they may be dirty. Use fuel injector cleaner or get them professionally cleaned/replaced.
Check for an exhaust leak before the first oxygen sensor (this is unlikely to cause the problem, but it is possible)