Burning hair smell and check engine light [Archive] - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum

: Burning hair smell and check engine light


Mike36
12-05-2009, 12:49 AM
We just bought an 05 Trailblazer, very nice ride. On our way home from dinner tonight we had the heat on, we noticed a smell kind of like burning hair, very strong, then about 5 minutes later the headlights dimmed quick, then the check engine light came on. Would appreciate any ideas or help. Thanks.:worried:

awer25
12-05-2009, 12:51 AM
Does the car work now? Get the engine code read and report back.

Mike36
12-05-2009, 01:04 AM
Runs fine, but I'm calling the dealer in the morning. I'll let you know.

awer25
12-05-2009, 01:10 AM
Runs fine, but I'm calling the dealer in the morning. I'll let you know.

If it's still under a warranty, go for it. If not, don't pay them just to read the code - Autozone, Advance Auto, and O'Reilly's all do it for free.

Trailblaze_2002
12-05-2009, 01:20 AM
:iagree: I would never ever pay a dealer for anything let alone to read a code! :duh: :hopeless :ugh: :hahano:

bucr8zy
12-05-2009, 01:20 AM
Since it occurred when you turned the heater on, I would take a look at the blower resistor pack wiring and connector since these are known to sometimes get hot and melt. Do a search on this site for changing the resistor and you will find some great pictorials. It is under the dash behind the glove box and attached to the blower motor. Black wire and purple wire if I remember correctly. Just a guess, good luck.

Mike36
12-05-2009, 11:02 AM
If it's still under a warranty, go for it. If not, don't pay them just to read the code - Autozone, Advance Auto, and O'Reilly's all do it for free.

It is under warranty, we've only had it 1 day. I hate taking any car to a garage, I was a mechanic for 4 yrs, and have always done my own repairs. But while there is a warranty, they are damn sure gonna fix anything wrong.

the roadie
12-05-2009, 03:06 PM
Make sure to really try out the 4WD system as well, on a used vehicle.

Mike36
12-05-2009, 03:35 PM
Took to dealer and, they put it on the computer and said there is a problem with the air induction pump. Have to drop it off Monday and they are going to fix it. We'll see.:confused:

awer25
12-05-2009, 09:11 PM
...But while there is a warranty, they are damn sure gonna fix anything wrong.

That's the spirit! (and the attitude you need to have to get these dealers to fix issues)

Mike36
12-08-2009, 08:21 PM
Well we just got our "new" 05 TB back from the dealer after a lot of runaround. They replaced a solenoid for the erratic fuel gauge, and the air pump. Then they reset computer and drove it 300 miles. She passed inspection and is running like a champ. So far so good. Now just need some new tires.:thumbsup: