HELP-No power feels like it's all plugged up - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > OEM Issues

OEM Issues Original Equipment Repairs and/or Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 12-25-2012, 03:15 PM
gica gica is offline
Junior Member
 
2004 Chevy TrailBlazer LT
Indigo Blue Metallic 4.2L I6 2WD
Join Date: Dec 2012
Location: Los Angeles, CA
Posts: 2
HELP-No power feels like it's all plugged up

04 trailblazer Low power almost like cat plugged up

--------------------------------------------------------------------------------

2004 Trailblazer V6 2wd LT 57k miles rarely driven, first showed the same problem when pulling a small boat uphill and it only went 30 miles per hour but drove OK straight line.

I was driving up to Lake Tahoe the other week and the car was loaded with family and luggage. Went up OK not great but no real issues. After 5 days of being parked in freezing temps I packed up and was ready to go back and it started to run really sluggish going downhill. I pulled over and took off the air filter which looked really packed up with crap. I stopped by Pep Boys and picked up a new one, but it did not fix the proble. I drove about 100 miles always afraid that this thing will leave me stranded in the middle of nowhere. So it started to really lack power so I stopped at another Pep Boys and read the codes that appeared and found P0495 so high fan. Bought some starting fluid and sprayed in the throttle body and started it a few times and drove all the way to the grapevine exit for a total of 411 miles in total. But that's where I had to end the trip and have somebody pick me up to go over the last 60 miles of up and down hills. There was no way this car would make it up that steep of a hill if it barely reached 35 going stright towards the end. For the most part it did reach 70 miles per hour, so i got lucky.
After I towed it home by renting tow dolly from Uhaul I checked the codes again and found lots of them:
P0495 High Fan
P1133 Control Fuel Air Meter
P0756 Shift Solenoid B Performance ..or stuck
P0526 Fan Speed Sensor
P0128Coolant Temp Below
So I cleared and drove around the block with lots of hesitation when gas is pressed and came back to one code:
P1133 Control Fuel Air meter
Some of these I think are by products of the same problem and don't really matter.
I immediately looked for answers online and found this forum. This almost feels like the cat is plugged up but there's none of the sounds associated with that. I read about the carbon dirt that causes stickyness so I'm trying to get some foam spray to try to clean all that.
So if anybody can set me in a good direction I'd really appreciate it. Help Help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-27-2012, 03:20 AM
bspurloc bspurloc is offline
Member
 
2002 GMC Envoy SLT
Indigo Blue Metallic 4.2L I6 AWD
Join Date: Apr 2009
Location: New England
Posts: 284
really does sound like plugged CAT.
My daughters was doing the same thing with absolutely no codes no noise just running with no power at all.... it got progressively worse.
an exhaust shop can test if a cat is plugged
__________________
Mechanic to my Daughters 02 Envoy SLT
My car 03 Crown Vic Sport
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 04:32 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed