Headlight washers spray when starting - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 General Tech Q&A > General

General If it doesn't fit in any other forum

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 01-22-2013, 10:38 AM
welc427 welc427 is offline
Junior Member
 
2003 GMC Envoy SLT
Pewter Metallic 4.2L I6 AWD
Join Date: Aug 2012
Location: Michigan
Posts: 5
Headlight washers spray when starting

Hello all, First post here, but I've been helped many times by this forum, so thank you for that.
I'm having trouble starting my 2003 GMC Envoy. It will crank four or five times and sometimes start, or I'll try again and it will finally start on the second try, sometimes it will not start at all and I will have to jump it.
I've had the battery tested twice and both times it reads good battery. (Battery is about 4 1/2 years old) After I do get it to start the headlight washers spray one time, the lights are all dim and it takes a few seconds for the message center to come on. On occasion the clock will reset. Throughout the day , it will start, but the headlight washers always spray once.
Some things I have done recently include:
Spark plugs -ac delco
fuel filter
removed and cleaned throtle body
two new spark plug coils
and mechanic has done: balljoints, axle, wheel bearing, tie rod, etc

I'm not very mechanic savy at all.

Has anyone had this problem and does anyone have a clue what could be causing this? Thank you for your help!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-22-2013, 12:35 PM
Machoman Machoman is offline
Junior Member
 
2005 GMC Envoy SLT
Black 4.2L I6 4X4
Join Date: Apr 2011
Location: St. Paul, MN
Posts: 50
This happened to my Envoy when it was cold out. Windshield washer fluid would shoot out on the lights, but car wouldn't start. I should say that I wasn't hitting the button to clean the lights. In the end, it turned out to be a bad battery.
Reply With Quote Quick reply to this message
  #3  
Old 01-29-2013, 01:47 PM
GAZ4x4's Avatar
GAZ4x4 GAZ4x4 is offline
Junior Member
 
2003 GMC Envoy SLE XL
Carbon Black Metallic 4.2L I6 4X4
Join Date: Dec 2007
Location: CA
Posts: 4
It sounds to me like a bad battery, with 4-1/2 years on it I would go with a new one just for a piece of mind. If the battery really is good then I would suspect a bad electrical connection, either the battery terminals or cables.

I had the same problem with the headlight squirters going off when trying to start the engine and it was due to the battery going bad and causing stange electrical issues due to everything being computer controlled!
__________________
2003 GMC Envoy XL
Reply With Quote Quick reply to this message
  #4  
Old 03-08-2013, 10:20 AM
welc427 welc427 is offline
Junior Member
 
2003 GMC Envoy SLT
Pewter Metallic 4.2L I6 AWD
Join Date: Aug 2012
Location: Michigan
Posts: 5
New battery solved the problem. thanks for the replies
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 07:42 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed