Dome Light Help - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2013 Chevrolet Trailblazer > 2013+ Chevrolet Trailblazer Forum

2013+ Chevrolet Trailblazer Forum Discussion on the new upcoming 2013 Chevy Trailblazer

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 03-02-2014, 09:31 AM
cinorx cinorx is offline
Junior Member
 
2002 Chevy TrailBlazer LS
Imperial Blue Metallic 4.2L I6 4X4
Join Date: Feb 2008
Location: Chicago, Il
Posts: 7
Dome Light Help

I recently tried installing led bulbs onto my dome lights on my 02 tb. Right away I noticed that the bulb blew out and ever since neither of the dome lights work, but I can press the reading lights and does turn on. I cant quite seem to find the problem onto why my domes don't work. Any Ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-02-2014, 11:10 AM
Loverotties Loverotties is offline
No longer with us
 
2002 Chevy TrailBlazer LTZ
Majestic Red Metallic 4.2L I6 4X4
Join Date: Apr 2009
Location: N.Central N.J.
Posts: 2,762
Quote:
Originally Posted by cinorx View Post
I recently tried installing led bulbs onto my dome lights on my 02 tb. Right away I noticed that the bulb blew out and ever since neither of the dome lights work, but I can press the reading lights and does turn on. I cant quite seem to find the problem onto why my domes don't work. Any Ideas?
Maybe dual filament,fuse to one of the circuit.
Reply With Quote Quick reply to this message
  #3  
Old 03-02-2014, 11:21 AM
freddyboy61 freddyboy61 is offline
No longer with us
 
2004 GMC Envoy SLE XL
Summit White 4.2L I6 4X4
Join Date: Jul 2008
Location: Long Island, NY
Posts: 1,239
Check fuses #4 & 40 in rear fuse box. Courtesy lights are separate from reading lights, with separate fuses. If the fuses are good, you may have taken out the BCM. LED lights are polarized and should be inserted in the socket only one way.
__________________
[SIZE="2"][I]Freddyboy61[/I][COLOR="Blue"][/COLOR][/SIZE]
[U] [/U]
Reply With Quote Quick reply to this message
 
  #4  
Old 03-02-2014, 03:32 PM
Joel1 Joel1 is offline
Member
 
2005 Isuzu Ascender
Sandstone Metallic 4.2L I6 2WD
Join Date: Jun 2013
Location: southeast
Posts: 313
If an LED is inserted "backwards" it just won't do anything; its a diode. They don't have any resistance on their own. Check if there is a wattage for this LED light (resistor built in to it) or is it a plain old LED. Bulbs have resistance which is what gives their wattage at 12Volts. If the LED had a different resistance (lower or none) it could blow the fuse.
Reply With Quote Quick reply to this message
  #5  
Old 03-03-2014, 08:57 PM
cinorx cinorx is offline
Junior Member
 
2002 Chevy TrailBlazer LS
Imperial Blue Metallic 4.2L I6 4X4
Join Date: Feb 2008
Location: Chicago, Il
Posts: 7
Thanks Guys

Quote:
Originally Posted by freddyboy61 View Post
Check fuses #4 & 40 in rear fuse box. Courtesy lights are separate from reading lights, with separate fuses. If the fuses are good, you may have taken out the BCM. LED lights are polarized and should be inserted in the socket only one way.
Freddy, where is the bcm located at exactly? I will look at the fuses you stated above.... You know ive never had a problem installing leds until I did the domes on the tb.


Quote:
Originally Posted by Joel1 View Post
If an LED is inserted "backwards" it just won't do anything; its a diode. They don't have any resistance on their own. Check if there is a wattage for this LED light (resistor built in to it) or is it a plain old LED. Bulbs have resistance which is what gives their wattage at 12Volts. If the LED had a different resistance (lower or none) it could blow the fuse.
Joel, The bulb probably blew cuz I possibly installed it backwards. I know the bulbs I got are 12v.

But your guy's input will definitely help once I get that chance to look at my tb.
Thanks once again.
Reply With Quote Quick reply to this message
  #6  
Old 03-07-2014, 11:16 AM
stellafin5 stellafin5 is offline
Junior Member
 
2002 GMC Bravada
Liquid Silver Metallic 6.0L LS2 V8 4X4
Join Date: Nov 2013
Location: NJ
Posts: 30
Check your fuse, I have the same issue before some time mine was the fuse issue so I am not sure about it but check your fuse.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live (ex: Philadephia, PA)
Vehicle Year
Choose your year
Or enter your choice here:
Vehicle Color
Choose your factory color (Custom, Not Listed & Two-Tones; Use Text Field Below)
Or enter your choice here:
Vehicle Make
Choose your make
Or enter your choice here:
Vehicle Model
Choose your model
Or enter your choice here:
Vehicle Engine
Choose your engine
Vehicle Drivetrain
Choose your vehicle drivetrain
Security Question
Fill in the blanks: Tra___oy
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 11:10 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed