Headlights Out - Page 2 - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 General Tech Q&A > General

General If it doesn't fit in any other forum

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #11  
Old 01-23-2017, 11:18 PM
Formula1 Formula1 is offline
Junior Member
 
2005 Chevy TrailBlazer LS
Black 4.2L I6 4X4
Join Date: Nov 2016
Location: Roseville
Posts: 6
Quote:
Originally Posted by EnvoyBoy2004 View Post
Check fuses #3 & 6 in the underhood fuse box as well.
That was the first thing I did.....thanks though.

Something tells me this is not going to be something cheap to fix.
But I'm going to look at the bulbs tomorrow night. I will update....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #12  
Old 01-24-2017, 11:21 PM
Formula1 Formula1 is offline
Junior Member
 
2005 Chevy TrailBlazer LS
Black 4.2L I6 4X4
Join Date: Nov 2016
Location: Roseville
Posts: 6
Good news! It was the bulbs!! I don't know why I just replaced them 2 months ago. I think my trailer I was towing had something to do with it. I could not get my running lights to work on my trailer. I am using a 7pin connector with a flat 4 adapter attached. My trailer running lights should have worked but....anyway thanks for all the help. Now I have to figure out why I don't have running lights on my trailer.
Reply With Quote Quick reply to this message
  #13  
Old 03-05-2017, 12:48 PM
Rob616 Rob616 is offline
Junior Member
 
2003 Chevy TrailBlazer LS
Silverstone Metallic 4.2L I6 4X4
Join Date: Feb 2017
Location: Providence rhode island
Posts: 11
Having the same problem in my friends 2004 envoy could it be the same relay?
Reply With Quote Quick reply to this message
 
  #14  
Old 04-10-2017, 11:13 PM
hamblinb hamblinb is offline
Junior Member
 
2004 Chevy TrailBlazer LS
Black 4.2L I6 4X4
Join Date: Apr 2017
Location: Kaukauna, WI
Posts: 1
Quote:
Originally Posted by EnvoyBoy2004 View Post
For a quick confirmation of it is actually bad, take relay from location #45 and install in location #46.
Thanks for saving me a trip to the mechanic. This swap narrowed down the faulty relay for me.
Reply With Quote Quick reply to this message
  #15  
Old 05-19-2017, 12:45 PM
BigBizE BigBizE is offline
Junior Member
 
2003 Chevy TrailBlazer LT EXT
Sandalwood Metallic 5.3L V8 4X4
Join Date: Mar 2010
Location: Fredericksburg, VA
Posts: 14
Had the same issue

I had the same issue last year. It was definitely the relay. Only 2 like it in the fuse box. I first started to test by simply switching the relay to see if the fan clutch relay fixed the headlight issue when changed. The fan clutch did not engage (obviously because the relay was removed) but headlights worked. Bought a new relay and replaced the headlight one and all was resolved. Coincidentally, the first new relay was indeed bad. Returned it to Advance the same day and got a new one. 2nd was fine. No issue since...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live (ex: Philadephia, PA)
Vehicle Year
Choose your year
Or enter your choice here:
Vehicle Color
Choose your factory color (Custom, Not Listed & Two-Tones; Use Text Field Below)
Or enter your choice here:
Vehicle Make
Choose your make
Or enter your choice here:
Vehicle Model
Choose your model
Or enter your choice here:
Vehicle Engine
Choose your engine
Vehicle Drivetrain
Choose your vehicle drivetrain
Security Question
Fill in the blanks: Tra___oy
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 05:14 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed