Need Help In Diagnosing Bad Fan Clutch - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 General Tech Q&A > General

General If it doesn't fit in any other forum

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 03-18-2017, 03:57 PM
Robopredinator Robopredinator is offline
Junior Member
 
2002 GMC Envoy SLE
Sand Beige Metallic 4.2L I6 4X4
Join Date: Mar 2017
Location: Chicago
Posts: 2
Need Help In Diagnosing Bad Fan Clutch

I have this bad squeaking near the front of the car that I thought was a belt or pulley issue. I took off the belt and noticed a bad rotational squeak when I turned the radiator fan. I'm hesitant to replace the fan clutch without fully knowing if the squeak is coming from elsewhere in the assembly. I do get the loud "jet turbine" noise at start up but I haven't read about anyone else noticing a rotational squeak in regards to their bad fan clutch.

Bad fan clutch or water pump? Both?

Thanks in advance.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-18-2017, 11:13 PM
EnvoyBoy2004's Avatar
EnvoyBoy2004 EnvoyBoy2004 is offline
TrailVoy Alumni
 
2004 GMC Envoy SLT
Graphite Metallic 4.2L I6 4X4
Join Date: Sep 2014
Location: NY
Posts: 1,324
I have never heard of the fan clutch showing mechanical noises, I would say it probably is the water pump. That being said, I would suggest changing both because of the work involved in doing either.
Reply With Quote Quick reply to this message
  #3  
Old 03-30-2017, 01:21 PM
joric's Avatar
joric joric is offline
Member
 
2003 Chevy TrailBlazer LT
Black 4.2L I6 4X4
Join Date: Jul 2006
Location: NE New Jersey
Posts: 126

Swap em both out.. Fan clutch sounds like a jet whistling by when you rev the engine if its totally bad.. as a result the shaft on the water pump can go duff or will in the near future.. Autozone etc do a loaner tool fan clutch tool to hold the water pump pulley while you undo the fan's 1-1/2'' nut.

Look on youtube for a how to video.. takes about 2 hrs if you follow.. not that hard.
__________________
Joric

Your tricked out Honda sounds intrestin.. can I buy it..??.. the wife needs a new hairdryer..

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Quick reply to this message
 
  #4  
Old 04-05-2017, 10:59 AM
aschaller2's Avatar
aschaller2 aschaller2 is offline
Junior Member
 
2002 Chevy TrailBlazer LS
Indigo Blue Metallic 4.2L I6 4X4
Join Date: Jul 2015
Location: Lincoln, NE
Posts: 13
Don't want to reiterate what everyone else said but its 100% the water pump. My fan clutch went out awhile ago and i just fixed it last week. Considering how big of a b**** it is to fix it I would also suggest replacing both while you have it all apart. Will save you a ton of stress in the future especially since the fan clutch is a common problem with these vehicles, chances are you will need to replace it sooner or later.
Reply With Quote Quick reply to this message
  #5  
Old 04-05-2017, 07:44 PM
Robopredinator Robopredinator is offline
Junior Member
 
2002 GMC Envoy SLE
Sand Beige Metallic 4.2L I6 4X4
Join Date: Mar 2017
Location: Chicago
Posts: 2
New day, new problems. I replaced the water pump and fan clutch and while I was in there, replaced the camshaft position sensor. The car will not start! I took the battery in to Autozone and they said it was no good after charging for an hour. I put in a new battery and the car still won't turn over.

Envoy is a 2002 year model and all the ignition coils have already been replaced. One thing that I do recall happening during the time the noise came about was the ABS light had came on. I forgot about this and just noticed it today when I tried starting it with the new battery.

Any insight, feedback or help?
Reply With Quote Quick reply to this message
  #6  
Old 04-06-2017, 02:52 PM
treefiddy treefiddy is offline
Junior Member
 
2003 Chevy TrailBlazer LT EXT
Silver Green Metallic 4.2L I6 2WD
Join Date: Sep 2010
Location: AZ
Posts: 7
Quote:
Originally Posted by Robopredinator View Post
I have this bad squeaking near the front of the car that I thought was a belt or pulley issue. I took off the belt and noticed a bad rotational squeak when I turned the radiator fan. I'm hesitant to replace the fan clutch without fully knowing if the squeak is coming from elsewhere in the assembly. I do get the loud "jet turbine" noise at start up but I haven't read about anyone else noticing a rotational squeak in regards to their bad fan clutch.

Bad fan clutch or water pump? Both?

Thanks in advance.
I would say water pump for the squeaking. The bad fan clutch can hurt the water pump too, I think.

Do em both. It's an extra 10 minutes to do both, whichever you are replacing.
Reply With Quote Quick reply to this message
  #7  
Old 05-19-2017, 12:53 PM
BigBizE BigBizE is offline
Junior Member
 
2003 Chevy TrailBlazer LT EXT
Sandalwood Metallic 5.3L V8 4X4
Join Date: Mar 2010
Location: Fredericksburg, VA
Posts: 14
Quote:
Originally Posted by Robopredinator View Post
New day, new problems. I replaced the water pump and fan clutch and while I was in there, replaced the camshaft position sensor. The car will not start! I took the battery in to Autozone and they said it was no good after charging for an hour. I put in a new battery and the car still won't turn over.

Envoy is a 2002 year model and all the ignition coils have already been replaced. One thing that I do recall happening during the time the noise came about was the ABS light had came on. I forgot about this and just noticed it today when I tried starting it with the new battery.

Any insight, feedback or help?
A bad camshaft position sensor can keep the car from starting. Why did you change it? Just curious. I had to replace my water pump this winter. I learned the hard way that you should replace the fan clutch at the same time because I ended up doing it a week later. Didn't think to mess with the camshaft sensor though. Maybe one of those situations where if it wasn't broken, it might've been best to leave it be...
Reply With Quote Quick reply to this message
  #8  
Old 05-22-2017, 02:02 PM
unioncreek unioncreek is offline
Junior Member
 
2006 Chevy TrailBlazer LS
Steel Gray Metallic 4.2L I6 4X4
Join Date: Feb 2017
Location: southeastern WA
Posts: 5
Put the old sensor back in if you still have it and see if it will start. If it doesn't return the new one and get another.

Bob
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live (ex: Philadephia, PA)
Vehicle Year
Choose your year
Or enter your choice here:
Vehicle Color
Choose your factory color (Custom, Not Listed & Two-Tones; Use Text Field Below)
Or enter your choice here:
Vehicle Make
Choose your make
Or enter your choice here:
Vehicle Model
Choose your model
Or enter your choice here:
Vehicle Engine
Choose your engine
Vehicle Drivetrain
Choose your vehicle drivetrain
Security Question
Fill in the blanks: Tra___oy
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 05:12 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed