loud humming noise when accelerating and decellerating - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 General Tech Q&A > General

General If it doesn't fit in any other forum

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 01-11-2013, 07:08 PM
blentz2009 blentz2009 is offline
Junior Member
 
2006 Chevy TrailBlazer LT EXT
Summit White 4.2L I6 2WD
Join Date: Jan 2013
Location: butts county ga
Posts: 4
loud humming noise when accelerating and decellerating

Hi guys I'm new to this site, I have a 2006 Chevy Trailblazer EXT Lt and although i love it, Ive had one problem after the next my current problem just came about a couple of days ago, Ive been trying to figure out whats going on but i need some suggestions.


Problem:

When i crank my trailblazer it sounds normal and it continues to sound normal until i reach (2) in the RPMs' this is where my problem starts. when the RPM gets to (2) it sounds like the RPM is staying in two, I mean its a loud reving/ humming noise and it will continue to sound like this until i decellerate and stop but when i accelerate same noise. the noise sounds like its comming from the area of the throttle body or the resistor which is connected to the throttle body. Since this has occured, I on occasion hear what sounds like a grinding noise in the same area. My gas miliage has not changed and my transmission is fine. My abs, check engine and stabilititrak lights are on but they came on long before this problem first occured. any suggestions?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-20-2013, 09:40 PM
lfb57 lfb57 is offline
Member
 
2007 Chevy TrailBlazer LT
3.73, G80 4.2L I6 2WD
Join Date: Mar 2007
Location: Texas
Posts: 111
Is your TB shifting correctly? What are the rpm's at 60 mph?
Reply With Quote Quick reply to this message
  #3  
Old 01-21-2013, 10:54 AM
blentz2009 blentz2009 is offline
Junior Member
 
2006 Chevy TrailBlazer LT EXT
Summit White 4.2L I6 2WD
Join Date: Jan 2013
Location: butts county ga
Posts: 4
im not sure to be honest, i know there normal ill have to look and let you know. Im thinking it may be my fan clutch now
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 08:38 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed