No 4wd Afwd, help - suggestions? - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > 4x4 Drivetrain

4x4 Drivetrain 4x4 Repairs & Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 01-11-2013, 11:14 PM
cooleydub cooleydub is offline
Junior Member
 
2003 Chevy TrailBlazer LS
Indigo Blue Metallic 4.2L I6 4X4
Join Date: Oct 2011
Location: Shakopee, MN
Posts: 1
Exclamation No 4wd Afwd, help - suggestions?

I have a 2002 Trailblazer 4.2 I6. The 4WD and A4WD are both not engaging. Brought to a mechanic who is my wife's cousin and he said the problem is likely with the front differential and recommended another shop with lower hourly labor costs. He told me the motor that engages the 4WD is working fine. The front axle does engage but both cv shafts do nothing. Also there was a clicking sound from the front passenger side wheel when he spun it on the lift. He also pointed out that the front differential was hot to the touch which scares me . It makes no strange noises while driving and still gets the same MPG as it always has. How dangerous is it to drive this way and does it sound like the differential will need replacement? I thank you for reading and welcome any help or suggestions.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-12-2013, 04:36 PM
freddyboy61 freddyboy61 is offline
No longer with us
 
2004 GMC Envoy SLE XL
Summit White 4.2L I6 4X4
Join Date: Jul 2008
Location: Long Island, NY
Posts: 1,239
Sounds like the front spline disconnect assembly has gone south. This assembly tends to dry out and then wears the bearing. It's probably not a good idea to keep on driving without at least getting a real diagnosis, since some of these parts still run even when not in 4WD mode.
If you want real expert advice, join us at G M T N a t i o n . c o m
__________________
[SIZE="2"][I]Freddyboy61[/I][COLOR="Blue"][/COLOR][/SIZE]
[U] [/U]
Reply With Quote Quick reply to this message
  #3  
Old 01-17-2013, 03:14 PM
NoId's Avatar
NoId NoId is offline
Junior Member
 
2003 Chevy TrailBlazer LS
Medium Sage Green Metallic 4.2L I6 4X4
Join Date: Sep 2011
Location: New Jersey
Posts: 13
When my front differential went the truck locked up in awd and 4wd ,but would drive fine in 2wd however it still made a noise from the front differential located near the front right of the truck. Without having the money to fix it at the time I removed the front drive shaft and kept the truck in 2wd. The front differential will still move because the cv axles are still connected ,but the noise mine was making in 2wd disappeared once the front drive shaft was out.
Reply With Quote Quick reply to this message
  #4  
Old 01-19-2013, 06:40 PM
ellis1905 ellis1905 is offline
Junior Member
 
2005 Chevy TrailBlazer SS (LT)
Silver Mist Metallic 4.2L I6 4X4
Join Date: Jan 2013
Location: Salt Lake City, Utah
Posts: 2
Drivetrain

I have a 2005 Trailblazer and both the ABS, Brake, & 4-wheel drive
service lights came on all at the same time. Had the transfer case serviced and cleaned the speed sensors and no change. Ant ideas???
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 01:44 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed