Strange noise comming from front end - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Brakes, Suspension, Wheels and Tires > OEM Issues

OEM Issues OEM Repairs & Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 12-12-2006, 01:36 PM
02TrailblazerLS's Avatar
02TrailblazerLS 02TrailblazerLS is offline
Member
 
Join Date: Jul 2005
Posts: 123
Strange noise comming from front end

It only does this sometimes...

when I make a hard left at lower speeds and turn the wheel all the way (like the kind of manuver you would make in a crowded parking lot), I notice a rubbing sound comming from the front right wheel. I have rulled out rubbing....so now I can't figure out what it is.

It is very noticable, but only if I am making a quick turn. If I start moving after I turn the wheel, there is no sound. it's odd because it is only on left turns and it is the right wheel.

Is there a way that I can quiet this down without consulting a mechanic? I sure hope it isn't a major suspension problem. A friend of mine's 02 Envoy does the same thing.....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-12-2006, 03:29 PM
chipper chipper is offline
Junior Member
 
2002 Chevy TrailBlazer LT
Forest Green Metallic 4.2L I6 4X4
Join Date: May 2006
Location: Rockland, Maine
Posts: 15
It could be a problem with the sway bar links in the front end, the GM ones are pretty crappy, I got mine replaced with some aftermarket ones recommended by my Mechanic, they are much stronger, but they were about $110 a side instead of the GM $60 per side.

-=Chipper=-
Reply With Quote Quick reply to this message
  #3  
Old 12-12-2006, 06:37 PM
RayVoy's Avatar
RayVoy RayVoy is offline
TrailVoy Guru
 
2009 Chevy Avalanche LTZ
Black 5.3L V8 4X4
Join Date: Jul 2006
Location: Atlantic Canada
Posts: 6,431
Have someone stand by that wheel while you turn the wheels. That will locate the noise. Then we can help to locate the problem.
Reply With Quote Quick reply to this message
  #4  
Old 12-12-2006, 06:43 PM
joe70ss joe70ss is offline
Member
 
2007 Chevy TrailBlazer LT
Graystone Metallic 4.2L I6 4X4
Join Date: Apr 2006
Location: union,nj
Posts: 478
There might be rubber stops on thre frame that have to be greased,were on my 2001 Blazer
Reply With Quote Quick reply to this message
  #5  
Old 12-12-2006, 07:02 PM
wheelieking wheelieking is offline
Member
 
2004 Chevy TrailBlazer LS
Imperial Blue Metallic 4.2L I6 4X4
Join Date: Aug 2006
Location: Austin IN
Posts: 182
I have exactly the same problem. mine seems to be connected to the amount of throttle i give it too. like it could be power steering pump failure but it is only when i turn left. sonds like a rub but nothing is rubing, or maybe vibration.

BTW: mine is an 04 ls with 53k
Reply With Quote Quick reply to this message
  #6  
Old 02-28-2007, 11:26 PM
truex1 truex1 is offline
New Member
 
2003 Chevy TrailBlazer LS
Dark Gray Metallic 4.2L I6 4X4
Join Date: Sep 2006
Location: Charleston, WV
Posts: 8
i am having the same prob. seems like mine only happenswhen i am turning hard left and the suspension has to work (bumps, etc.).

did u ever figure out the problem? i have an '03 tb w/only 40k.
Reply With Quote Quick reply to this message
  #7  
Old 02-28-2007, 11:43 PM
jaylind jaylind is offline
TrailVoy Alumni
 
2007 Chevy TrailBlazer LS
Silverstone Metallic 4.2L I6 2WD
Join Date: Nov 2006
Location: Falcon, Colorado USA
Posts: 1,778
Quote:
Originally Posted by chipper View Post
It could be a problem with the sway bar links in the front end, the GM ones are pretty crappy, I got mine replaced with some aftermarket ones recommended by my Mechanic, they are much stronger, but they were about $110 a side instead of the GM $60 per side.

-=Chipper=-
I think you paid way too much..aftermarket are no more that $20 per side front or back. Upgrade to MOOG and they are maybe around $46 per side...Gm parts where closer to $80 per side.. I change my fronts in Nov and rears 2wks ago.

Do a search on link ends or sway bar

JAy
__________________
www.jaylind.com/trailblazer
Reply With Quote Quick reply to this message
  #8  
Old 03-01-2007, 12:35 AM
pogbobo's Avatar
pogbobo pogbobo is offline
Senior Member
 
2006 Chevy TrailBlazer LS
Dark Gray Metallic 4.2L I6 4X4
Join Date: Feb 2007
Location: VA
Posts: 709
Question

I am new to the forum, I've only had my '06 TB LS for a couple of weeks ... anyway, when I make the turn into my apartment parking lot I hear a rubbing noise also (from the front drivers side tire), but mine is when I'm turning right... Its been driving me crazy and I don't want to take it to the dealer... I've also ruled out rubbing because there is no wear or marking visible.

Thanks in advance guys, this forum has been my number1 source for all my TB needs and I hope in the future I can contribute my experiences. -Matt

[Also, there are no aftermarket parts or upgrades yet, its still all stock]
Reply With Quote Quick reply to this message
  #9  
Old 03-01-2007, 03:18 AM
Gearhead2012's Avatar
Gearhead2012 Gearhead2012 is offline
TrailVoy Alumni
 
2003 Chevy TrailBlazer LS
Sandstone Metallic 4.2L I6 4X4
Join Date: Dec 2006
Location: Chesapeake, VA
Posts: 1,048
Is everyone who is having this problem 4wd? sounds almost like a cv joint, vaguely. Otherwise...I don't have any guesses.
__________________
It's only reckless if you're not in control.
32" Nitto Terra Graplers/2" BDS/K&N CAI/Flowmaster 40 Series/Tuned PCM
Reply With Quote Quick reply to this message
  #10  
Old 03-01-2007, 10:06 AM
truex1 truex1 is offline
New Member
 
2003 Chevy TrailBlazer LS
Dark Gray Metallic 4.2L I6 4X4
Join Date: Sep 2006
Location: Charleston, WV
Posts: 8
mine is 4wd...and i just used it quite extensively due to lots of snow & a ski trip to even more snow.

also, i know the factory sway bar links are crap, but isn't the noise that comes from them more of a "rattle" and not a "clunking & squeaking" sound (yes, there is both)??? i have the latter sounds, and it only happens when i turn hard left AND hit a bump of some sort, or turn into my driveway (quite steep).

this problem is also alleviated when i dont turn the wheel all the way...if i turn it about 1-2 inches shorter, i hear no sounds at all...sounds like a joke i heard once..."hey, doctor, it hurts when i do this...doctor says, 'don't do that.'"
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Front end noise BikertrashNY General 14 04-12-2014 01:54 AM
Front end noise citycrosser OEM Issues 4 11-18-2008 06:09 PM
Bra now for the 06+ LT front end? Spong Exterior 12 11-11-2007 03:21 AM
2005 Trailblazer Rear End Noise - Pinion Bearings? waterskier98 OEM Issues 3 07-23-2006 12:45 AM
Front End Noise While Idling Kahunakai 02-09 Vortec 4.2L I-6 Engine and Drivetrain 6 06-26-2005 04:14 AM


» Sponsors

Advertising Info

All times are GMT -4. The time now is 10:20 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed