AC causes Envoy to Stall - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > OEM Issues

OEM Issues Original Equipment Repairs and/or Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 09-16-2007, 01:35 AM
Mesee3 Mesee3 is offline
Junior Member
 
2002 GMC Envoy SLE
Dark Gray Metallic 4.2L I6 2WD
Join Date: Sep 2007
Location: California, LA
Posts: 3
AC causes Envoy to Stall

I recently replaced my battery. When I started my Envoy the first time with the new battery, a click-click-click (about 15 seconds) noise came from behind the AC controls and now the car imedieatly stalls when I turn on the HAC fan. Envoy runs fine without fan on?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-16-2007, 03:59 PM
markhart1's Avatar
markhart1 markhart1 is offline
Junior Member
 
2005 Chevy TrailBlazer LS
Silverstone Metallic 4.2L I6 4X4
Join Date: Dec 2005
Posts: 42
Hello,
Please update your profile so we know what year, engine etc... you have.
A couple things come to mind. Have you had the alternator checked to make sure it's working OK? Why did you have to replace the battery and if so, is it rated properly for the car?
Reply With Quote Quick reply to this message
  #3  
Old 09-16-2007, 08:16 PM
PROSPHOTO's Avatar
PROSPHOTO PROSPHOTO is offline
TrailVoy Alumni
 
2006 Chevy TrailBlazer LT
Superior Blue Metallic 4.2L I6 4X4
Join Date: Jan 2007
Location: Selden, NY
Posts: 3,497
Please fill out all of your vehicle information in your Profile so that we can keep you informed with the most useful information available

After you do that, follow the procedure outlined in this article for cleaning your throttle body, that should correct your stalling condition
http://forums.trailvoy.com/articles....ticle&artid=91

As for the A/C clicking...did it only happen the first re-start after the battery was replaced? If so, you were probably hearing the mode door actuators calibrating If you hear the clicking all of the time (from the dashboard), you may have a problem with one of your mode door actuators
__________________
-Mike
Car Domain
AKA PROVY Rock On!
Reply With Quote Quick reply to this message
  #4  
Old 09-17-2007, 07:03 PM
rubberman's Avatar
rubberman rubberman is offline
TrailVoy Alumni
 
2004 Chevy TrailBlazer LS EXT
Dark Gray Metallic 4.2L I6 2WD
Join Date: Aug 2007
Location: Evansville, IN
Posts: 1,061
i have something similar on mine that i noticed today. either parked or at a light the engine RPMs will be normal then choke down to 300 rpms like its gonna die then jump back up to normal RPMs. it will continuously do this while the A?C is on. i guess this is service bulletin 04-01-38-019a. i will be taking mine in anyway since they said they would touch up some scratches. i have about a week left on warranty so i hope this covered.
__________________
2004 TB EXT I6 CAI, PCM4Less PCM, Resonator delete, Kuhmo KL51
Reply With Quote Quick reply to this message
  #5  
Old 09-24-2007, 04:45 PM
Mesee3 Mesee3 is offline
Junior Member
 
2002 GMC Envoy SLE
Dark Gray Metallic 4.2L I6 2WD
Join Date: Sep 2007
Location: California, LA
Posts: 3
Updated info

I updated my profile. 02 Envoy SLE 4.2L.

I replaced my battery, because I orginally lost all power to my rear tellgate. After closer examination, I found all the wires in the tellgate were cut at the hindge, I figured the cut wires were grounding out and killed my battery. It took me about 3 month to resolve the loss of rear tellgate power and the battery slowly drained over the three months until it was dead.

I reconnected the wires in the tellgate and replaced the battery and all was good until I turned on my AC Fan. Now Envoy stalls imedieatly.

Also, clicking sound only happend once, when the battery was connected, so It probably was a calibration thing. Thanks
Reply With Quote Quick reply to this message
  #6  
Old 09-25-2007, 04:00 PM
rbarrios's Avatar
rbarrios rbarrios is offline
TrailVoy Guru
 
2003 Chevy TrailBlazer LS
Pewter Metallic 4.2L I6 2WD
Join Date: Sep 2004
Location: west covina
Posts: 5,267
yeah, do the throttle body cleaning- let us know the result.
__________________
2013 Equinox-3.6L DI- Best MPG 35
2010 Traverse-3.6L DI Best MPG 31.3
2003 Trailblazer LS 165,000 miles- Best MPG 24
Reply With Quote Quick reply to this message
  #7  
Old 09-25-2007, 07:23 PM
rubberman's Avatar
rubberman rubberman is offline
TrailVoy Alumni
 
2004 Chevy TrailBlazer LS EXT
Dark Gray Metallic 4.2L I6 2WD
Join Date: Aug 2007
Location: Evansville, IN
Posts: 1,061
yeap, TB needs cleaned. i had mine done at the service department since mine was under warranty or i would of done this myself. Receipt shows 'excessive carbon buildup". maybe by cleaning this, i could get a touch of better MPGs
__________________
2004 TB EXT I6 CAI, PCM4Less PCM, Resonator delete, Kuhmo KL51
Reply With Quote Quick reply to this message
  #8  
Old 09-26-2007, 02:25 PM
icase81 icase81 is offline
Junior Member
 
2005 Chevy TrailBlazer LS
Charcoal Metallic 4.2L I6 4X4
Join Date: Mar 2007
Location: Reading, PA
Posts: 79
Post

I was gonna say, I never had to do it with my TB, but on lots of my older VW's, car choking at idle with A/C on was 99% of the time a dirty throttle body. Clean it up and it should be good to go.
Reply With Quote Quick reply to this message
  #9  
Old 09-27-2007, 12:10 AM
exttb exttb is offline
Member
 
2003 Chevy TrailBlazer LT EXT
Dark Green Metallic 4.2L I6 2WD
Join Date: Oct 2005
Location: Hollywood ,FL
Posts: 124
or disconnect negative terminal and let the vehicle reset for 1 minute....my ac fan resisitor went out when I changed my battery
__________________
2003 TB LT EXT I6 213,000 miles pcmforless tune with efans..Volant cai ...no cat..no name muffler..EFI live 1.2...
Reply With Quote Quick reply to this message
  #10  
Old 09-27-2007, 02:01 PM
carp's Avatar
carp carp is offline
Junior Member
 
2003 Chevy TrailBlazer LT EXT
Black 4.2L I6 2WD
Join Date: Aug 2007
Location: Ft Sill, OK
Posts: 48
I cleaned my TB as per the how-to instructions, but didn't disconect my battery prior to doing it. Noticed a slight improvement. Should I now disconect the battery for a while to get the full benefit? And if so, do you disconect BOTH terminals? For how long? Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OEM Trailblazer, Envoy Electronic Visco Fan Clutches EuroPartsAmeric Basic Vendor GroupBuys 26 01-14-2012 03:54 AM
fan clutch? webjoe98 OEM Issues 7 01-29-2008 06:43 AM
What would you get? ImARockStar TrailBlazer / Envoy Chat 9 03-03-2007 11:21 AM
Another New guy, just picked up my 06 Envoy XL Denali! =) SSL kirkg1 Introductions 6 08-02-2006 02:49 PM
R.I.P. Envoy XUV Envoy Fan Latest GM News 8 02-24-2005 11:19 PM


» Sponsors

Advertising Info

All times are GMT -4. The time now is 04:08 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed