03 Envoy stalls when A/C is turned on - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > OEM Issues

OEM Issues Original Equipment Repairs and/or Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 10-15-2007, 03:58 PM
air4kxc air4kxc is offline
Junior Member
 
Join Date: Oct 2007
Posts: 4
03 Envoy stalls when A/C is turned on

My 03 Envoy stalls when the A/C is turned on. Started happening after replacing the battery. I don't know if there is a connection but seems odd.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-15-2007, 04:36 PM
rbarrios's Avatar
rbarrios rbarrios is offline
TrailVoy Guru
 
2003 Chevy TrailBlazer LS
Pewter Metallic 4.2L I6 2WD
Join Date: Sep 2004
Location: west covina
Posts: 5,267
yes. classic symptom. Most likely the battery was disconnected for more than 25 minutes.
it caused by the computer losing some learned parameters and the throttle body being dirty.
the result is the engine runs fine with no AC. turn on AC and it idles from normal to 300 up to 1000 back to 300 etc... many times it shuts off...
the solution is about $4 bottle of throttle body cleaner and about 1 hr of your time.
theres a HOW TO around here....
__________________
2013 Equinox-3.6L DI- Best MPG 35
2010 Traverse-3.6L DI Best MPG 31.3
2003 Trailblazer LS 165,000 miles- Best MPG 24
Reply With Quote Quick reply to this message
  #3  
Old 10-15-2007, 04:42 PM
rbarrios's Avatar
rbarrios rbarrios is offline
TrailVoy Guru
 
2003 Chevy TrailBlazer LS
Pewter Metallic 4.2L I6 2WD
Join Date: Sep 2004
Location: west covina
Posts: 5,267
heres the how to.....
http://forums.trailvoy.com/articles....ticle&artid=91

ive done this, except I didnt remove it. I simply sprayed and moved the flap to loosen crud. For a more thorough cleaning, follow article.
__________________
2013 Equinox-3.6L DI- Best MPG 35
2010 Traverse-3.6L DI Best MPG 31.3
2003 Trailblazer LS 165,000 miles- Best MPG 24
Reply With Quote Quick reply to this message
  #4  
Old 10-16-2007, 07:10 AM
air4kxc air4kxc is offline
Junior Member
 
Join Date: Oct 2007
Posts: 4
Thanks, It Worked! I removed the Throttle Body, cleaned it and it runs great. You guys are good.
Reply With Quote Quick reply to this message
  #5  
Old 10-16-2007, 12:53 PM
rbarrios's Avatar
rbarrios rbarrios is offline
TrailVoy Guru
 
2003 Chevy TrailBlazer LS
Pewter Metallic 4.2L I6 2WD
Join Date: Sep 2004
Location: west covina
Posts: 5,267
hey. thanks for letting us know so quickly that you got it back to normal
__________________
2013 Equinox-3.6L DI- Best MPG 35
2010 Traverse-3.6L DI Best MPG 31.3
2003 Trailblazer LS 165,000 miles- Best MPG 24
Reply With Quote Quick reply to this message
  #6  
Old 07-12-2014, 02:18 PM
Robthemac Robthemac is offline
Junior Member
 
2002 Chevy TrailBlazer LT EXT
Black 4.2L I6 4X4
Join Date: Dec 2013
Location: Lowell, MA
Posts: 8
Obviously the best solution is to have a nice clean throttle body, but isn't there a way to have the computer relearn the old parameters?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OEM Trailblazer, Envoy Electronic Visco Fan Clutches EuroPartsAmeric Basic Vendor GroupBuys 26 01-14-2012 02:54 AM
Idle RPM surges and the motor stall when A/C is turned on na svt OEM Issues 6 07-07-2008 12:32 PM
03 Envoy SLT A/C help asap rolin51 OEM Issues 6 08-13-2007 01:45 PM
What would you get? ImARockStar TrailBlazer / Envoy Chat 9 03-03-2007 10:21 AM
Is the A/C off when Heat is turned on? mrbflat OEM Issues 8 02-17-2007 10:16 PM


» Sponsors

Advertising Info

All times are GMT -4. The time now is 10:42 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed