Oil Pressure Gauge - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain

02-09 Vortec 4.2L I-6 Engine and Drivetrain Q&A forum for engine and drivetrain repairs/modifications/tuning.

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
 
 
Thread Tools
  #1  
Old 12-18-2005, 08:38 PM
Dirtkicker Dirtkicker is offline
Junior Member
 
2009 GMC Envoy SLE
Steel Gray Metallic 5.3L V8 2WD
Join Date: May 2005
Location: Shaw Air Force Base, SC
Posts: 44
Oil Pressure Gauge

Help....my oil pressure gauge is going bonkers. When I turn off the TB it stays at 75-80, then once started it goes way past 80. The oil was just changed 2 days ago and is fine now. It was acting up before the oil change. Once I remove the fuse to the instrument panel and start it and then put the fuse back in, the oil gauge goes back to 0 while off and to 40 once started. Of course that only lasts for 1-2 starts then it goes bonkers again. Is there an easy fix for this? If so what is it? Thanks.
Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-18-2005, 08:52 PM
dpm6836 dpm6836 is offline
Junior Member
 
2002 Chevy TrailBlazer LS
Black 4.2L I6 4X4
Join Date: Apr 2005
Location: Pennsylvania
Posts: 72
Sounds like it is just the gauge since it shows pressure when the engine is off. However, I'm not a mechanic. Personally, I would have a mechanic check the engine oil pressure just to be sure, when replacing the gauge. They can do that by attaching a gauge to the oil pressure sending unit.
Looks like your military. Don't get taken advantage of. Have it fixed at home or from a trustworthy mechanic.
Quick reply to this message
  #3  
Old 12-19-2005, 05:12 PM
Dirtkicker Dirtkicker is offline
Junior Member
 
2009 GMC Envoy SLE
Steel Gray Metallic 5.3L V8 2WD
Join Date: May 2005
Location: Shaw Air Force Base, SC
Posts: 44
I will probably take it to the dealer, but I was just wondering if it was something I could do at home instead. I thought it might be a little sensor that needs replacing instead of the whole gauge. I'll have to let you all know for future reference.

I am in the United States Air Force, the dealer here is pretty decent most of the time. Thanks for your comments.
Quick reply to this message
  #4  
Old 12-20-2005, 02:58 PM
my-tb's Avatar
my-tb my-tb is offline
Member
 
2007 Chevy TrailBlazer LS
Bordeaux Red Metallic 4.2L I6 2WD
Join Date: Aug 2005
Location: Redford, Mi
Posts: 156
Here is my question. I just had my cluster replaced for the tach doing its clicking thing and since I have had it back the oil pressure is WAY up it was about 40 at idle now at about 60. So what is the pressure suppose to be on these things? Its about 75 when at full throttle where as before it would only get to about 55. Any ideas guys?
__________________
04 LS 2wd, 3.73, G80, 20% tints, K&N, Running Boards
(sold)
07 LS 2wd, 3.42, moonroof, bone stock...for now
Quick reply to this message
  #5  
Old 12-20-2005, 10:13 PM
Dirtkicker Dirtkicker is offline
Junior Member
 
2009 GMC Envoy SLE
Steel Gray Metallic 5.3L V8 2WD
Join Date: May 2005
Location: Shaw Air Force Base, SC
Posts: 44
Mine always idled around 40 and would move up to around 52-53 while driving, that is until recently when it's messed up on me. From the other posts on other threads I read others have said about the same thing. You can always do a search on the main page for oil pressure and there's a post about it.
Quick reply to this message
  #6  
Old 12-21-2005, 11:55 AM
dpm6836 dpm6836 is offline
Junior Member
 
2002 Chevy TrailBlazer LS
Black 4.2L I6 4X4
Join Date: Apr 2005
Location: Pennsylvania
Posts: 72
I don't know if there is any specific number because the pressure will vary due to oil weight, type and amount in the engine. I believe the gauge in the TB are there for a general purpose and not an exact reading. If your reading high I would be concerned though, you don't want too much pressure because you might blow gaskets.
Hopefully, a GM Tech with add to this thread.
Quick reply to this message
  #7  
Old 12-21-2005, 11:57 AM
dpm6836 dpm6836 is offline
Junior Member
 
2002 Chevy TrailBlazer LS
Black 4.2L I6 4X4
Join Date: Apr 2005
Location: Pennsylvania
Posts: 72
yes, pressure will go up with higher rpms.
Quick reply to this message
  #8  
Old 12-21-2005, 12:39 PM
tblazed's Avatar
tblazed tblazed is offline
Basic Vendor- DRL Killer
 
2002 Chevy TrailBlazer LS
Summit White 4.2L I6 2WD
Join Date: Sep 2004
Location: DFW - The Republic of Texas
Posts: 2,212
From the GM technical overview description of the 4.2 I6

"As oil enters the pump, the eccentric design compresses the oil, then releases the oil at a regulated [U]max pressure of 65 psi[/U] at 2,500 rpm, circulating 11
gallons per minute."

It definitely should not be reading 75 psi. Sounds to me like maybe the instrument cluster needs reprogramming, like it is not responding properly to the oil pressure signal.
Quick reply to this message
  #9  
Old 12-23-2005, 11:18 AM
gabe gabe is offline
New Member
 
Join Date: Aug 2005
Location: sf bay area
Posts: 9
my oil gauge reads about 42 lbs. @ idle then it barely moves. it mite go up one or two lines at freeway speeds. the one in my dodge works like an oil gauge should work. lots of movement between idle and freeway speeds. i cann't believe i have 42 lbs. of oil pressure at idle.
__________________
2005 envoy denali other car is a 2003 ram diesel with a few goodies added.
Quick reply to this message
  #10  
Old 12-23-2005, 02:06 PM
my-tb's Avatar
my-tb my-tb is offline
Member
 
2007 Chevy TrailBlazer LS
Bordeaux Red Metallic 4.2L I6 2WD
Join Date: Aug 2005
Location: Redford, Mi
Posts: 156
Thanks tblazed! Its good t o know that you can get answers here. But you would have thought they would have made sure the thing was working right when they put in the new cluser. All I am asking for is some good sense with the techs thats all. Next question? Will that reprogram fix the gas gauge that reads about 5 gallons to low? and my low gas light will not come on for nothing. The gauge was past E and still would not go on. Thanks again all.
__________________
04 LS 2wd, 3.73, G80, 20% tints, K&N, Running Boards
(sold)
07 LS 2wd, 3.42, moonroof, bone stock...for now
Quick reply to this message
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WI Dealer giving me the BS on OCI? Knightslugger General 48 10-10-2009 11:12 AM
Oil Pressure Gauge hustlinuall2 Interior 9 02-04-2008 10:14 AM
Whats your Oil Pressure gauge Say.. njezrider Interior 15 11-30-2007 06:00 PM
4.2L Oil Pressure Gauge Isn't! robdunn1 02-09 Vortec 4.2L I-6 Engine and Drivetrain 12 08-11-2007 05:21 PM
05 TB DOD status? muddy tires 02-09 Vortec 4.2L I-6 Engine and Drivetrain 19 07-28-2006 10:00 PM


» Sponsors

Advertising Info

All times are GMT -4. The time now is 08:41 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed