HVAC Mode Actuator door replacement - Page 3 - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > The 02-09 "How-To" and DIY Section

The 02-09 "How-To" and DIY Section Threads on Do-It-Yourself and How-To goes here.

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #21  
Old 07-23-2008, 05:45 PM
RayVoy's Avatar
RayVoy RayVoy is offline
TrailVoy Guru
 
2009 Chevy Avalanche LTZ
Black 5.3L V8 4X4
Join Date: Jul 2006
Location: Atlantic Canada
Posts: 6,431
Quote:
Originally Posted by ENVOY2003SLE View Post
hi, great forum, thanks for all the great info. i hope this thread is the answer to my problem and i hope others can give me ideas.

2003 sle envoy. i recently (well last few months ) am only able to have A/C or heat come out of the front vents on the 3rd setting on the nob. A/C and heat works but only blows out strong on 4th and 5th setting and NOW today only on the 5th setting. before i had the battery die and had throttle problems and was able to fix it with a good cleaning of it...thanks to the forum. do you think its the " mode door actuator " that needs to be replaced? i too have had the clicking sound but strange as it might be only time i hear it is during the winter months. thanks for any help and great forum with great info.
Hi, welcome to the site.
The mode doors only control the direction of the air flow (floor/vent/dash), have nothing to do with the fan speed.
It sounds like you are having a problem with the fan speed control module. I think it's called a blower motor resistor assembly. Very common problem, it's a $25.00 fix (if u do it yourself) and located under the dash, behind the glove box. Lots of info on here, and some pictures. Try a quick search, the more recent threads are the ones to view.
You may also have a mode door problem, but the speed thing is the resistor assembly.
__________________
Ray
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #22  
Old 07-23-2008, 11:53 PM
ENVOY2003SLE ENVOY2003SLE is offline
Junior Member
 
2003 GMC Envoy SLE
Black 4.2L I6 4X4
Join Date: Apr 2008
Location: Ontario
Posts: 19
thanks for your reply. after posting i did some more reading and there was someone who also had or has the same problem. the vent would or seem to not have any air/heat/ac coming threw when i turned the nob on. setting 1,2,3, now 4 acts like the off position and 5 is the only setting that pushes anything out. i'm hoping that the person who also had the same problem post a reply. do you know of any good places in Canada to buy parts besides places like CrappieTire? i also need to replace the spare tire carrier. seems like this truck needs some upkeep.

thanks
Reply With Quote Quick reply to this message
  #23  
Old 07-24-2008, 11:56 AM
gdewit79's Avatar
gdewit79 gdewit79 is offline
Senior Member
 
2004 Chevy TrailBlazer LT
Light Tarnished Silver 4.2L I6 4X4
Join Date: Apr 2007
Location: Ontario, Canada
Posts: 605
Quote:
Originally Posted by 03Huggy View Post
All the work is done from the drivers side.



Read my initial post again; it was due to the dash vents not working. The actuator door allows air to go to the dash vents and floor vents.
The problem with mine is the dash and defroster vents work, but I have no floor vents.
Reply With Quote Quick reply to this message
  #24  
Old 07-27-2008, 01:37 AM
ENVOY2003SLE ENVOY2003SLE is offline
Junior Member
 
2003 GMC Envoy SLE
Black 4.2L I6 4X4
Join Date: Apr 2008
Location: Ontario
Posts: 19
and yes it was the resistor, thanks for everyones help. great forum !!!
Reply With Quote Quick reply to this message
  #25  
Old 08-04-2008, 11:49 AM
yar02169 yar02169 is offline
Junior Member
 
2002 Olds Bravada
Indigo Blue Metallic 4.2L I6 AWD
Join Date: Jun 2007
Location: Quincy, MA
Posts: 42
Hot & cold at the same time

I've been searching high and low, and I'm hoping the pictures here will help. I get air through the various vents, but on the drivers side it's only warm air while the A/C works fine on the passenger side.
By looking at the directions and pictures, can I assume that the upper actuator is the one that I will need to replace to get cold air out of the driver's side vents?
The pictures do help, if it wasn't for them I wouldn't know what to look for. My Chilton's manual is useless in providing any help on this subject.
Reply With Quote Quick reply to this message
  #26  
Old 08-08-2008, 02:59 PM
blzr0213 blzr0213 is offline
Junior Member
 
Join Date: Jun 2006
Posts: 7
Quote:
Originally Posted by yar02169 View Post
I've been searching high and low, and I'm hoping the pictures here will help. I get air through the various vents, but on the drivers side it's only warm air while the A/C works fine on the passenger side.
By looking at the directions and pictures, can I assume that the upper actuator is the one that I will need to replace to get cold air out of the driver's side vents?
The pictures do help, if it wasn't for them I wouldn't know what to look for. My Chilton's manual is useless in providing any help on this subject.
Same here, drivers side blazing hot, passenger and rear nice and cold. This also happened the same day the battery had to be replaced. Has anyone had this problem and fixed it?
Reply With Quote Quick reply to this message
  #27  
Old 08-08-2008, 05:21 PM
fife2001's Avatar
fife2001 fife2001 is offline
Member
 
2002 GMC Envoy SLT
Magnetic Red Metallic 4.2L I6 4X4
Join Date: Aug 2005
Location: Lincoln, NE
Posts: 303
Quote:
Originally Posted by gdewit79 View Post
The problem with mine is the dash and defroster vents work, but I have no floor vents.
I have the same problem.....I also cannot turn the defroster vents off if I want.

I did replace the mode door actuator and it clicks less but still does not work correctly.

I think the actuator works but the door itself cannot move the whole range for some reason.
Reply With Quote Quick reply to this message
  #28  
Old 08-16-2008, 12:44 AM
quirino18 quirino18 is offline
Junior Member
 
Join Date: Aug 2008
Posts: 34
Quote:
Originally Posted by LeonPhelps View Post
Where is the world do you find a 5.5mm socket ?
use a 7/32 you find wrenches at sears or sockets also
Reply With Quote Quick reply to this message
  #29  
Old 09-07-2008, 06:54 AM
toenizzle toenizzle is offline
New Member
 
Join Date: Sep 2008
Posts: 5
simlar issue with 02 tahoe

I have the same issue with my 2002 tahoe, where the air only blows from the defroster vents and the feet vents. does anyone know if this procedure will work on the 2003 tahoe as well?
Reply With Quote Quick reply to this message
  #30  
Old 09-07-2008, 06:54 AM
toenizzle toenizzle is offline
New Member
 
Join Date: Sep 2008
Posts: 5
Quote:
Originally Posted by toenizzle View Post
I have the same issue with my 2002 tahoe, where the air only blows from the defroster vents and the feet vents. does anyone know if this procedure will work on the 2003 tahoe as well?
oops, i meant 2002 tahoe not 2003
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Envoy HVAC Mode Actuator nixdorf Interior 7 11-24-2013 03:02 PM
HVAC Mode Door potts200 Interior 76 10-21-2013 11:17 PM
HVAC Mode Actuator stanley2 General 16 06-29-2012 04:33 PM
[SOLVED] hvac stuck at hot/ mode door inop MAY03LT General 4 04-27-2009 12:16 AM


» Sponsors

Advertising Info

All times are GMT -4. The time now is 09:35 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed