engine wont start - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > OEM Issues

OEM Issues Original Equipment Repairs and/or Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 05-26-2008, 12:42 PM
JDuB84 JDuB84 is offline
Junior Member
 
2003 Chevy TrailBlazer LS
Dark Gray Metallic 4.2L I6 2WD
Join Date: May 2007
Location: Decatur, IL
Posts: 8
engine wont start

Hey hows it going!? I have an 03 Trailblazer. The engine will crank but wont start. All the fuses are good. The fuel pump wont run when i turn the key on...I checked power to the fuel pump and dont have it there. I got a book on trailblazers and it says to check the fuse and relay (I did and both are good) and if they are good to check the fuel pump relay control circuit from the electrical center to the PCM. My question is how exactly do i check the fuel pump relay circuit from the electrical center to the pcm?? Any help would be great and appreciated!! Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-26-2008, 09:10 PM
Jozuah's Avatar
Jozuah Jozuah is offline
Senior Member
 
2004 Chevy TrailBlazer LT
Summit White 4.2L I6 4X4
Join Date: Sep 2006
Location: Tremonton UT.
Posts: 877
the fuel pump will only run a few seconds after the key is turned on so if you are looking at the plug with a test light then thats prolly why your not seeing power to the pump.
the best way to check fuel pump power at the plug would be to have a "helper" turn the key on while you pin out (test) the plug for power having the helper cycle the key on for 2 seconds off for 2 seconds.

IF then you dont have power to the fuel pump (VERY rare occurance but not impossible) then i would start testing wires from the fuse box to the pump for continuity with a meter.

if they show broken , then repair or replace as necessary.
*DISCLAIMER* i have a migraine i think and if i misunderstood your question or seem all jumbled in my response im sorry in advance.
__________________
there is no replacement for REAL LIFE experience!
2004 Trailblazer resonator removed
PCMFORLESS tuned
Reply With Quote Quick reply to this message
  #3  
Old 05-26-2008, 10:57 PM
wardak33's Avatar
wardak33 wardak33 is offline
TrailVoy Alumni
 
2002 Olds Bravada
Pewter Metallic 4.2L I6 AWD
Join Date: Nov 2007
Location: Schaumburg, IL
Posts: 2,369
couldn't it also be a bad fuel pump? have you changed the fuel filter lately? severely clogged filters can cause pumps to go bad.
__________________
2002 Oldsmobile Bravada: 4.2L I6 w/ G80 Locker, AWD, TBSS springs, HD bilsteins, 6000k HIDs, Mobil1, Iridium Plugs
Reply With Quote Quick reply to this message
  #4  
Old 05-27-2008, 07:12 PM
JDuB84 JDuB84 is offline
Junior Member
 
2003 Chevy TrailBlazer LS
Dark Gray Metallic 4.2L I6 2WD
Join Date: May 2007
Location: Decatur, IL
Posts: 8
yea i had someone helping me and we found no power going to the fuel pump. so ill check the wires for continuity and see what i can find and go from there. thanks for the help and if i have any other questions or problems ill let you know.
Reply With Quote Quick reply to this message
  #5  
Old 05-31-2008, 12:47 AM
tbblue tbblue is offline
Junior Member
 
2007 Chevy TrailBlazer LT
Imperial Blue Metallic 4.2L I6 4X4
Join Date: Apr 2007
Location: mtl canada
Posts: 43
Hi
I had similar problems starting my 07 lt.
It turned out that the crank scensor conector was loose
and the harnes to the pcm was also loose.
TBBLUE
07 lt i6
Reply With Quote Quick reply to this message
  #6  
Old 06-03-2008, 05:32 PM
neelskit's Avatar
neelskit neelskit is offline
Member
 
2002 Chevy TrailBlazer LT EXT
Pewter Metallic 4.2L I6 4X4
Join Date: Jul 2007
Location: Cicero, IN
Posts: 365
Might be a corroded ground?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Normal Engine Noise? 05LT OEM Issues 17 01-28-2013 03:58 PM
03 Trailblazer engine stalling while driving Ms03Trailblazer OEM Issues 20 10-10-2012 07:21 PM
02 Bravada strange engine stall revisited Moebius OEM Issues 22 10-03-2012 12:04 AM
New noise at start up coolcloo1019 OEM Issues 5 05-21-2008 01:40 PM
No Start Condition... Dacomputernerd 02-09 Vortec 4.2L I-6 Engine and Drivetrain 8 10-04-2006 10:01 PM


» Sponsors

Advertising Info

All times are GMT -4. The time now is 11:40 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed