Rear gate Wiper does not work/remote lock don't work - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > General TrailVoy Discussion > Audio and Electronics

Audio and Electronics Discuss car audio, video, navigation, alarms, and other electronics here.

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 06-25-2008, 08:06 PM
bmcgregor3 bmcgregor3 is offline
Junior Member
 
2004 GMC Envoy SLE XL
Medium Red Metallic 4.2L I6 2WD
Join Date: Apr 2008
Location: St. Louis Mo
Posts: 8
Rear gate Wiper does not work/remote lock don't work

I recently installed an AUX GM aux input adapter in our 2004 Envoy XL. Every thing worked fine for about a week then the lock remotes stopped working. I changed the batteries in the remotes and tried reprogramming the remotes and still they did not work. Then I noticed that the rear window wiper was not working and when I hit the auto door locks the rear gate did not lock as well. I checked all fuses and did not find any bad. I do not know how to check the relays. I have since removed the AUX GM and nothing changed so I guess that was not the problem. I pulled the rear gate apart and noted that some of the wires have power.

Does anyone have any ideas. Where can you buy relays or is that likely not the problem.

Thanks,
Bruce
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-25-2008, 09:27 PM
PROSPHOTO's Avatar
PROSPHOTO PROSPHOTO is offline
TrailVoy Alumni
 
2006 Chevy TrailBlazer LT
Superior Blue Metallic 4.2L I6 4X4
Join Date: Jan 2007
Location: Selden, NY
Posts: 3,497
Sounds like a lift gate module failure...but I'm not certain

I'm sure other members that have experienced your concern will chime in
__________________
-Mike
Car Domain
AKA PROVY Rock On!
Reply With Quote Quick reply to this message
  #3  
Old 06-25-2008, 11:21 PM
tblazed's Avatar
tblazed tblazed is offline
Basic Vendor- DRL Killer
 
2002 Chevy TrailBlazer LS
Summit White 4.2L I6 2WD
Join Date: Sep 2004
Location: DFW - The Republic of Texas
Posts: 2,212
Could be one of the wires that passes through the rubber boot at the top of the liftgate. They get bent with every opening and closing. Do the license plate lights work? If a broken (open) ground wire, the lights will be dead too. You should find Orange (x2) 12V Battery voltage, black GND, Light Blue Class 2 serial data, and Brown Left side marker power for the license plate lights.
Reply With Quote Quick reply to this message
  #4  
Old 06-27-2008, 10:52 PM
bmcgregor3 bmcgregor3 is offline
Junior Member
 
2004 GMC Envoy SLE XL
Medium Red Metallic 4.2L I6 2WD
Join Date: Apr 2008
Location: St. Louis Mo
Posts: 8
Angry License Plate Light

Yes the license plate light works. I just can't find a relationship between remotes and rear gate wiper/lock. Also the cabin light do not operate when the door open. They will turn on manually but not with the doors.

Thanks for the help so far!!
Reply With Quote Quick reply to this message
  #5  
Old 06-28-2008, 09:26 AM
PROSPHOTO's Avatar
PROSPHOTO PROSPHOTO is offline
TrailVoy Alumni
 
2006 Chevy TrailBlazer LT
Superior Blue Metallic 4.2L I6 4X4
Join Date: Jan 2007
Location: Selden, NY
Posts: 3,497
The lock operation and keyless entry operation are through the Lift gate module, so is the control for the rear wiper...that's the relationship that ties the two problems together

You may only need the module re-flashed, but you may need the module replaced (which would also require programming)

Programming must be done by the dealer...that may be your best solution at this point
__________________
-Mike
Car Domain
AKA PROVY Rock On!
Reply With Quote Quick reply to this message
  #6  
Old 06-28-2008, 10:22 AM
tblazed's Avatar
tblazed tblazed is offline
Basic Vendor- DRL Killer
 
2002 Chevy TrailBlazer LS
Summit White 4.2L I6 2WD
Join Date: Sep 2004
Location: DFW - The Republic of Texas
Posts: 2,212
Quote:
Originally Posted by bmcgregor3 View Post
Yes the license plate light works. I just can't find a relationship between remotes and rear gate wiper/lock. Also the cabin light do not operate when the door open. They will turn on manually but not with the doors.

Thanks for the help so far!!
As Prosphoto said the liftgate module does several functions. It contains the RF receiver for the key fobs. It communicates with the body control module via the Class 2 serial data bus on the lt blue wire. You could have a broken lt blue wire. Without that module communicating you will get symptoms like you describe. Sometimes the module itself fails but I would sure look at the condition of those wires where they go through the rubber boot first to make sure they are intact, because replacing that module and having the dealer program it can run several hundred $$.
Reply With Quote Quick reply to this message
  #7  
Old 06-30-2008, 09:54 PM
bmcgregor3 bmcgregor3 is offline
Junior Member
 
2004 GMC Envoy SLE XL
Medium Red Metallic 4.2L I6 2WD
Join Date: Apr 2008
Location: St. Louis Mo
Posts: 8
I'll Check the wires

Thanks for all the advice. I will check the wires this weekend.
Reply With Quote Quick reply to this message
  #8  
Old 01-07-2009, 06:03 PM
aucobalt aucobalt is offline
Junior Member
 
2002 Chevy TrailBlazer LTZ
Steel Gray Metallic 4.2L I6 2WD
Join Date: Sep 2007
Location: West Melbourne, FL
Posts: 7
Issue Resolved?

BMC, were you able to resolve this problem??

My '02 TB LTZ is having the same issues (minus the key-fob)
Reply With Quote Quick reply to this message
  #9  
Old 01-31-2009, 02:00 AM
Thatoneguy22 Thatoneguy22 is offline
Junior Member
 
2002 Chevy TrailBlazer LT
Forest Green Metallic 4.2L I6 4X4
Join Date: Jan 2009
Location: Portland, OR
Posts: 1
Same problem

I have the same problem with my 2002 TB and also my dome lights wont go off without pressing the override. First of all, I was wondering if the dome lights are related to the rear body control module or not and how to fix that maybe. And second, what problems would it cause If I were not to replace my module. I understand the keyless entry, rear wipers and defroster won't work, but do you know if anything else would malfunction and possible cause death of some sort? Just wondering.
Reply With Quote Quick reply to this message
  #10  
Old 05-16-2009, 08:22 PM
marczsport's Avatar
marczsport marczsport is offline
Junior Member
 
2006 GMC Envoy SLT XL
Onyx Black 4.2L I6 4X4
Join Date: Nov 2006
Location: Athol, MA
Posts: 29
Same deal!

When I started reading this thread, it sounded like I could have written it! Same exact problems: keyless entry does not work and rear wiper does not work on my 06' Envoy SLT.

This is VERY frustrating because it is an intermittent problem, and of course never happens when I'm at the dealer. The Envoy is still under warrantee, but seeing as "nothing is wrong" when I bring it to the dealer, they don't fix anything!

I'm going to check the wires as described elsewhere in the thread- I"m hoping one is just loose or partially damaged so I can do a quick fix.

FWIW: When the keyless entry does not work, it is impossible to open up either the rear hatch or rear window! Talk about frustrating!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
02 Trailblazer-No rear defrost, No rear wipers, and gate does not lock grave77digger General 20 09-02-2013 10:24 AM
rear wiper? ibbig General 7 11-03-2006 07:49 PM
GM and there crazy wipers itstrick General 33 10-09-2006 01:17 AM
Rear Wiper Not Working? mcarso General 7 08-01-2006 09:08 AM
Rear Wiper kdh General 4 07-05-2006 08:48 AM


» Sponsors

Advertising Info

All times are GMT -4. The time now is 03:26 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed