O2 Sensor Gone Bad - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > Exhaust Mods

Exhaust Mods Performance Exhaust Modifications

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 07-11-2008, 05:16 PM
jojaboy's Avatar
jojaboy jojaboy is offline
Junior Member
 
2004 Chevy TrailBlazer LS
Summit White 4.2L I6 2WD
Join Date: Jun 2007
Location: OBX North Carolina
Posts: 29
O2 Sensor Gone Bad

I keep popping a code on my SES. I checked the code and it is my upstream O2 sensor. After pricing out a new sensor for $50 I have decided to forgo replacing it. Now with fuel prices climbing into the $4 range I think it's time to invest the $50. LOL

Vehicle only has 60k on it. Any thoughts that the sensor may not be bad and that it is just getting false readings from something else (air filter, broken wire, etc...)
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-11-2008, 09:34 PM
PROSPHOTO's Avatar
PROSPHOTO PROSPHOTO is offline
TrailVoy Alumni
 
2006 Chevy TrailBlazer LT
Superior Blue Metallic 4.2L I6 4X4
Join Date: Jan 2007
Location: Selden, NY
Posts: 3,497
There are 8-10 O2 sensor codes per O2 sensor...which code is it?

An O2 sensor code doesn't mean that an O2 sensor is bad
__________________
-Mike
Car Domain
AKA PROVY Rock On!
Reply With Quote Quick reply to this message
  #3  
Old 07-11-2008, 10:24 PM
jojaboy's Avatar
jojaboy jojaboy is offline
Junior Member
 
2004 Chevy TrailBlazer LS
Summit White 4.2L I6 2WD
Join Date: Jun 2007
Location: OBX North Carolina
Posts: 29
I can't remember now. I will have to get it checked again. It's been on for a while. I just remember it was sensor 1 bank 1
Reply With Quote Quick reply to this message
  #4  
Old 07-12-2008, 07:12 PM
jojaboy's Avatar
jojaboy jojaboy is offline
Junior Member
 
2004 Chevy TrailBlazer LS
Summit White 4.2L I6 2WD
Join Date: Jun 2007
Location: OBX North Carolina
Posts: 29
Finally gave in. Relplace upstream sensor and new air filter. Runs like a champ now.
Reply With Quote Quick reply to this message
  #5  
Old 07-12-2008, 08:22 PM
VINROQ's Avatar
VINROQ VINROQ is offline
Junior Member
 
2002 Olds Bravada
Sandstone Metallic 4.2L I6 AWD
Join Date: Oct 2007
Location: Huber Heights
Posts: 15
O2 sensor bliss

For the past 2 mos or so I have experienced bad gas milage, engine spudering and even stalls. I replaced the o2 sensor and at 80k miles, it feels like a born again beast..lol
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Insurance Cost Not Bad on TBSS CodyC6 TrailBlazer SS Chat 10 02-25-2007 10:55 PM
Bad handling in turns tcarricato OEM Issues 6 02-22-2007 04:43 PM
bad to accelerate fast?... rpms? cdmixer General 12 02-08-2007 03:13 PM
Water Pump Going Bad RozmerJJ OEM Issues 14 02-02-2007 07:34 AM
Wiper Motor Went bad GMC will not honor GMPP!! Sultan Exterior 11 11-06-2006 08:59 PM


» Sponsors

Advertising Info

All times are GMT -4. The time now is 07:54 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed