Engine stalls when A/C is turned on. 04' Envoy - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > OEM Issues

OEM Issues Original Equipment Repairs and/or Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 07-19-2008, 05:10 PM
oORipMaOo's Avatar
oORipMaOo oORipMaOo is offline
Junior Member
 
2004 GMC Envoy SLE
Summit White 4.2L I6 AWD
Join Date: Apr 2008
Location: Jersey City, NJ
Posts: 11
Engine stalls when A/C is turned on. 04' Envoy

I just put in a brand new DieHard battery in my 04' Envoy and every since then when I turn on the A/C , my engine stalls or shut off. When A/C is off, engine runs fine. I put gauges on the system to see if it needed freon and freon level is good. Compressor runs perfect when you first start up the engine. After you press the gas, the problem starts. Pretty weird. Can anyone help?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-19-2008, 09:12 PM
rbarrios's Avatar
rbarrios rbarrios is offline
TrailVoy Guru
 
2003 Chevy TrailBlazer LS
Pewter Metallic 4.2L I6 2WD
Join Date: Sep 2004
Location: west covina
Posts: 5,267
this is a very easy fix. it will cost you about $5 and take about 45 min.
the key points here are---- changed the battery, engine stalls with AC ON, engine runs fine with AC off.
You simply have a dirty throttle body..... and with the battery disconnect- theres some learned settings that have been lost.
Buy a can of throttle body cleaner.
now you have 2 options....
you can either do a thougrough cleaning- or you can do a semi clean.
(I have 127,500 miles and all my cleanings have been semi). meaning that I leave the TB on- but spray the cleaner in- and move the plate back and forth to dislodge the accumulated crud. either way- is your choice....
But when you clean it- disconnect the battery for at least 30 min... so that it loses any bad learned settings.
what you want is for it to relearn with a clean TB.
heres the how to
http://forums.trailvoy.com/articles....ticle&artid=91
__________________
2013 Equinox-3.6L DI- Best MPG 35
2010 Traverse-3.6L DI Best MPG 31.3
2003 Trailblazer LS 165,000 miles- Best MPG 24
Reply With Quote Quick reply to this message
  #3  
Old 07-20-2008, 12:05 AM
oORipMaOo's Avatar
oORipMaOo oORipMaOo is offline
Junior Member
 
2004 GMC Envoy SLE
Summit White 4.2L I6 AWD
Join Date: Apr 2008
Location: Jersey City, NJ
Posts: 11
Good looking for replying back to my problem. I will be on it first thing in the morning. I really hope this works. I hate riding with my windows down, especially in the summer.
Reply With Quote Quick reply to this message
  #4  
Old 07-20-2008, 02:02 AM
wardak33's Avatar
wardak33 wardak33 is offline
TrailVoy Alumni
 
2002 Olds Bravada
Pewter Metallic 4.2L I6 AWD
Join Date: Nov 2007
Location: Schaumburg, IL
Posts: 2,369
don't worry. almost 99% of the time, the case is a dirty TB. and whats wrong with the windows down?! feel the breeze man. look good!!
__________________
2002 Oldsmobile Bravada: 4.2L I6 w/ G80 Locker, AWD, TBSS springs, HD bilsteins, 6000k HIDs, Mobil1, Iridium Plugs
Reply With Quote Quick reply to this message
  #5  
Old 07-20-2008, 05:28 PM
oORipMaOo's Avatar
oORipMaOo oORipMaOo is offline
Junior Member
 
2004 GMC Envoy SLE
Summit White 4.2L I6 AWD
Join Date: Apr 2008
Location: Jersey City, NJ
Posts: 11
lol! Well right now I have no choice.
Reply With Quote Quick reply to this message
  #6  
Old 07-21-2008, 01:11 PM
oORipMaOo's Avatar
oORipMaOo oORipMaOo is offline
Junior Member
 
2004 GMC Envoy SLE
Summit White 4.2L I6 AWD
Join Date: Apr 2008
Location: Jersey City, NJ
Posts: 11
So far so good. I dont wanna get my hopes up yet. I'll wait a day. But my throttle body looks brand new now after cleaning it. If the problem starts again I still appreciate the help. Peace out!
Reply With Quote Quick reply to this message
  #7  
Old 07-21-2008, 02:42 PM
rbarrios's Avatar
rbarrios rbarrios is offline
TrailVoy Guru
 
2003 Chevy TrailBlazer LS
Pewter Metallic 4.2L I6 2WD
Join Date: Sep 2004
Location: west covina
Posts: 5,267
keep us updated.
__________________
2013 Equinox-3.6L DI- Best MPG 35
2010 Traverse-3.6L DI Best MPG 31.3
2003 Trailblazer LS 165,000 miles- Best MPG 24
Reply With Quote Quick reply to this message
  #8  
Old 07-23-2008, 12:51 PM
oORipMaOo's Avatar
oORipMaOo oORipMaOo is offline
Junior Member
 
2004 GMC Envoy SLE
Summit White 4.2L I6 AWD
Join Date: Apr 2008
Location: Jersey City, NJ
Posts: 11
thanx alot guys, that was definetly it. its been perfect for the past 2 days. i have 53,000 miles on it. is there anything that i should change or look at?
Reply With Quote Quick reply to this message
  #9  
Old 07-23-2008, 02:38 PM
rbarrios's Avatar
rbarrios rbarrios is offline
TrailVoy Guru
 
2003 Chevy TrailBlazer LS
Pewter Metallic 4.2L I6 2WD
Join Date: Sep 2004
Location: west covina
Posts: 5,267
If I could go back in time--- I would change out the tranny fluid at 50,000.
__________________
2013 Equinox-3.6L DI- Best MPG 35
2010 Traverse-3.6L DI Best MPG 31.3
2003 Trailblazer LS 165,000 miles- Best MPG 24
Reply With Quote Quick reply to this message
  #10  
Old 05-01-2011, 09:27 PM
rockytop rockytop is offline
Junior Member
 
2002 GMC Envoy SLT XL
Summit White 4.2L I6 4X4
Join Date: May 2010
Location: chattanooga tn
Posts: 2
2002 envoy 4.2l i-6 a/c on dies

all ran fine i unhooked the battery when i hooked up wife drove and it would die come to find out it only done it under stress a/c on or sharp turn first just unhooked battery then hooked up drove with a/c off 10 miles to get intake cleaner when got home turned a/c on it worked thought i would clean it any way then unhooked battery waited 10 min hooked battery up and drove this time had a/c on. it was back to not working.guess question when hook up battery should i drive for awile with a/c off then turn it on since it seemed to work the first time or was it just a freak accident i want to fix this my self i have had issues in past and its 300 a pop dont want to pay that.this envoy has had sincer problems 3 times in past got 160.000 miles
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 04:50 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed