Body Control Module - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > OEM Issues

OEM Issues Original Equipment Repairs and/or Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 08-13-2008, 06:29 PM
W3RD W3RD is offline
Junior Member
 
Envoy SLT GMC Envoy SLT
Pewter Metallic 4.2L I6 4X4
Join Date: Jun 2008
Location: vancouver, B.C
Posts: 1
Body Control Module

I have a good idea that my BCM is gone seeing as my memory controls on my 2002 Envoy SLT are basically gone, but my rear window wiper has gone on the fritz. It works fine but its reacts to the bass my subs create, i think its the motor, i disconnected it and it stoped doing it but does anybody have anyother ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-13-2008, 07:02 PM
RayVoy's Avatar
RayVoy RayVoy is offline
TrailVoy Guru
 
2009 Chevy Avalanche LTZ
Black 5.3L V8 4X4
Join Date: Jul 2006
Location: Atlantic Canada
Posts: 6,431
We might need more info.
The radio presets are controlled by the radio computer.
You have the auto HVAC and the mem preset for it are controlled by the HVAC computer.
The power seat memory is controlled by the door computer (I think).
The lock/unlock memory is controlled by the liftgate computer.
These all talk to the BCM, but I don't think the BCM keeps the preset info.
The rear wiper, different problem maybe. Perhaps all problems have something to do with the amp
__________________
Ray
Reply With Quote Quick reply to this message
  #3  
Old 08-13-2008, 07:05 PM
hatchet669's Avatar
hatchet669 hatchet669 is offline
TrailVoy Guru
 
2003 Chevy TrailBlazer LT
Light Pewter Metallic 4.2L I6 4X4
Join Date: Jan 2007
Location: IL
Posts: 6,569
try disconnecting the battery for a half hour... someone had a problem like that and they reset all the computers by disconnecting the battery and all was well... hey its worth a shot and its free..
Reply With Quote Quick reply to this message
  #4  
Old 08-13-2008, 07:08 PM
RayVoy's Avatar
RayVoy RayVoy is offline
TrailVoy Guru
 
2009 Chevy Avalanche LTZ
Black 5.3L V8 4X4
Join Date: Jul 2006
Location: Atlantic Canada
Posts: 6,431
__________________
Ray
Reply With Quote Quick reply to this message
  #5  
Old 08-13-2008, 07:14 PM
91RS 91RS is offline
TrailVoy Alumni
 
2007 Chevy TrailBlazer SS (1SS)
Imperial Blue Metallic 6.0L LS2 V8 2WD
Join Date: May 2008
Location: GA
Posts: 1,852
If it is indeed a module problem, it's the liftgate control module. That module controls the rear wiper and is the reciever for the key fobs so it could affect your memory settings if it doesn't communicate to the truck which fob is being used (driver 1 or 2). You're best bet is to take it to the dealer to get it properly diagnosed, it is nearly impossible to tell you what's wrong without actually seeing what's going on with the truck with a Tech 2. However, I will say it isn't uncommon to have a BCM go bad in these trucks. I had to replace mine because the auto headlights weren't working and it wouldn't turn off the interior lights if the doors were left open, and I also fried the rest of it installing my amp.
Reply With Quote Quick reply to this message
  #6  
Old 06-02-2009, 07:15 PM
CSI CSI is offline
Junior Member
 
Join Date: Jun 2009
Posts: 1
Body control module

I have a 2002 trailblazer and am trying to replace the body control module. The problem is i can not find out where it is located in the trailblazer. Can anyone help me out?
Reply With Quote Quick reply to this message
  #7  
Old 06-02-2009, 08:16 PM
RayVoy's Avatar
RayVoy RayVoy is offline
TrailVoy Guru
 
2009 Chevy Avalanche LTZ
Black 5.3L V8 4X4
Join Date: Jul 2006
Location: Atlantic Canada
Posts: 6,431
It is part of the rear seat fuse panel, hmmm, or is the fuse panel part of the BCM. I suspect they are an integral assembly.
__________________
Ray
Reply With Quote Quick reply to this message
  #8  
Old 02-26-2010, 03:45 PM
iznit's Avatar
iznit iznit is offline
Member
 
2002 Chevy TrailBlazer LS
Midnight Blue Metallic 4.2L I6 2WD
Join Date: Sep 2007
Location: Chula Vista, CA
Posts: 261
I know this is an old thread but I haven't found any with a solution to the problem. When my bass hits hard my rear wiper engages and proceeds to wipe across the window. Depending on how hard the bass is hitting the wiper might wipe about 1/4th of the way if it's not too bad. If it's really hard it will go all the way. It's pretty annoying so I disconnected the rear wiper all together. Anyone have any ideas or solutions besides turning the bass down?

I'm running to 12" Kicker L7's in a custom ported box off of a Kicker XS100 amp.
Reply With Quote Quick reply to this message
  #9  
Old 02-26-2010, 08:08 PM
RayVoy's Avatar
RayVoy RayVoy is offline
TrailVoy Guru
 
2009 Chevy Avalanche LTZ
Black 5.3L V8 4X4
Join Date: Jul 2006
Location: Atlantic Canada
Posts: 6,431
Could be a ground problem, these trucks have a lot of ground points and one or more might be dirty.

But, I'm leaning to a simple induction problem. You might solve the problem by moving the amp/speaker wires.
__________________
Ray
Reply With Quote Quick reply to this message
  #10  
Old 03-12-2014, 09:26 AM
Speedbump Speedbump is offline
Junior Member
 
2004 Trailblazer TrailBlazer LT
Dark Green Metallic 4.2L I6 4X4
Join Date: Mar 2014
Location: Plainfeild,in
Posts: 1
I have 2004 trailblazer that when you take key out the security light and service engine light stays on and the throttllemotor cylcles and kills the batt. Hit the break pedal and the lights go out! Release pedal they come back on! Any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 08:19 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed