code p1481 Cooling Fan Speed Sensor Circuit - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 General Tech Q&A > General

General If it doesn't fit in any other forum

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 06-10-2009, 04:25 PM
a yazan's Avatar
a yazan a yazan is offline
Member
 
2002 Chevy TrailBlazer LT EXT
Black 4.2L I6 4X4
Join Date: Aug 2008
Location: saudi arabia
Posts: 169
code p1481 Cooling Fan Speed Sensor Circuit

previuse topic
i go to dealer to check the dtc

i have report contain this :
Quote:
code p1481 Cooling Fan Speed Sensor Circuit
they make the chek and print for 40$

any help please what couse this error ?
__________________
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-10-2009, 04:28 PM
CoyoteFireGuy's Avatar
CoyoteFireGuy CoyoteFireGuy is offline
Senior Member
 
2004 Chevy TrailBlazer LS
Indigo Blue Metallic 4.2L I6 4X4
Join Date: Feb 2009
Location: Louisville, KY
Posts: 694
Quote:
Originally Posted by a yazan View Post
they make the chek and print for 40$
I am not ragging on you, but you do realise you could buy a code reader and do it your self for twice that right?
__________________

KENTUCKY REP
"I HEAR STUPID PEOPLE"
Reply With Quote Quick reply to this message
  #3  
Old 06-10-2009, 04:42 PM
a yazan's Avatar
a yazan a yazan is offline
Member
 
2002 Chevy TrailBlazer LT EXT
Black 4.2L I6 4X4
Join Date: Aug 2008
Location: saudi arabia
Posts: 169
yes you are right
But it is difficult - or perhaps impossible -- to find the scanner here in sa
The companies did not provide shipping services to sa
__________________
Reply With Quote Quick reply to this message
  #4  
Old 06-10-2009, 10:11 PM
the roadie's Avatar
the roadie the roadie is offline
No longer with us
 
2004 GMC Envoy SLT "Roadiemobile"
Extreme Offroad Pewter 4.2L I6 4X4
Join Date: Apr 2005
Posts: 26,181
The sensor is built into the fan clutch. Many threads here on replacing fan clutches.
Reply With Quote Quick reply to this message
  #5  
Old 06-11-2009, 06:07 AM
a yazan's Avatar
a yazan a yazan is offline
Member
 
2002 Chevy TrailBlazer LT EXT
Black 4.2L I6 4X4
Join Date: Aug 2008
Location: saudi arabia
Posts: 169
Quote:
Originally Posted by the roadie View Post
The sensor is built into the fan clutch. Many threads here on replacing fan clutches.

then u mean i must replace the fan clutch ?
no way to fix this sensor ? like this toipc Wiring problem ?
now it is working but stopping some times , then i disconnect the battery for 20 min the it work !
the dealer say i must replace the thermostat also beacuse the down hose colder than the upper hose
and replace the engine sponsors ( engine chairs )
__________________
Reply With Quote Quick reply to this message
  #6  
Old 06-11-2009, 11:37 AM
the roadie's Avatar
the roadie the roadie is offline
No longer with us
 
2004 GMC Envoy SLT "Roadiemobile"
Extreme Offroad Pewter 4.2L I6 4X4
Join Date: Apr 2005
Posts: 26,181
Quote:
Originally Posted by a yazan View Post
then u mean i must replace the fan clutch ?
Usually, yes. But some members, perhaps one or two over the years that I've been a member, have found problems in the wiring harness. But in almost all cases of problems with 2002-2004 fan clutches, and you have a 2002, the failure rate is very high, I concluded you were in a location with high ambient temperatures and you might as well change it out. At least that is my non-professional opinion.
Quote:
no way to fix this sensor ? like this toipc Wiring problem ?
Perhaps. If you're going to fix it yourself - YOU need to go look at your wiring and come to a conclusion. We're just an Internet forum. We can't see your vehicle. Our advice is free, comes with a lot of experience, but cannot be guaranteed.
Quote:
now it is working but stopping some times , then i disconnect the battery for 20 min the it work !
Well good. That means it's an intermittent problem, the worst kind to solve. Because then you can't be guaranteed to find the problem with a meter. You might find wiring problems with a visual inspection. But maybe not. How muuch time and trouble do you want to go through before just putting a little money into the repair?
Quote:
the dealer say i must replace the thermostat also beacuse the down hose colder than the upper hose
What does your temperature gauge read? Have you ever had a temperature-related code? Your dealer may know best. Our advice cannot always be superior to theirs.
Quote:
and replace the engine sponsors ( engine chairs )
These are usually called the engine mounts. Very rare failure on trailvoys. Does your engine sag or vibrate more than before? You may have to trust your dealer's advice on this. But thanks for the reminder - I may have to go check my own engine mounts for sagging because of the abuse I give it.
Reply With Quote Quick reply to this message
  #7  
Old 06-13-2009, 12:05 PM
a yazan's Avatar
a yazan a yazan is offline
Member
 
2002 Chevy TrailBlazer LT EXT
Black 4.2L I6 4X4
Join Date: Aug 2008
Location: saudi arabia
Posts: 169
thanks roadie , thanks alot
i leave the car
today they call me and told me the upper chair ( mount ) that built in with the engine also broken !
i request a minue of parts , engine mounte , and the upper mount , state , some part in ac mybe clutch or roman ! ,

I have some pictures, and I will post it tonight
They told me today that engine mounts broken from the right, also another part upper the mount .

News is very bad

they said the shaking is large ! , and it tilted more to the point, on the other side
and the engine maybe pushing the hole fan to the radiator and maybe this problem cause fan clutch failure twice in 8 months

thanks very mutch
2 days later i well recive my tb and will see what will happen in the fan clutch
__________________
Reply With Quote Quick reply to this message
  #8  
Old 06-13-2009, 03:25 PM
glfredrick's Avatar
glfredrick glfredrick is offline
TrailVoy Alumni
 
2003 Chevy TrailBlazer LS
Black 4.2L I6 4X4
Join Date: Dec 2005
Location: Louisville, KY
Posts: 1,236
As an aside, our new member, a yazan likely has to deal with a lot of issues that most of us take for granted, translation to and from English for starters.

Welcome, a yazan, and we hope you get everything working without robbing your family of their inheritance!
Reply With Quote Quick reply to this message
  #9  
Old 06-19-2009, 07:48 AM
a yazan's Avatar
a yazan a yazan is offline
Member
 
2002 Chevy TrailBlazer LT EXT
Black 4.2L I6 4X4
Join Date: Aug 2008
Location: saudi arabia
Posts: 169
Quote:
Originally Posted by glfredrick View Post
As an aside, our new member, a yazan likely has to deal with a lot of issues that most of us take for granted, translation to and from English for starters.

Welcome, a yazan, and we hope you get everything working without robbing your family of their inheritance!

Thank you very much
soo many thanks for Good understanding and good reception and welcome
It is nice to find this a welcome here in trailvoy .. also saw the assistance of members in my previous topics
__________________
Reply With Quote Quick reply to this message
  #10  
Old 07-04-2009, 08:46 AM
a yazan's Avatar
a yazan a yazan is offline
Member
 
2002 Chevy TrailBlazer LT EXT
Black 4.2L I6 4X4
Join Date: Aug 2008
Location: saudi arabia
Posts: 169
Problem was resolved
engine mounts has been changed ... So far, the fan clutch not stoping again ,
and after two weeks of the reform did not show any code in the dtc.
engine shaking will stop the work of the fan.

thanks for every man helped me
__________________
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 03:32 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed