Resetting the "service brake system" message - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Brakes, Suspension, Wheels and Tires > Brakes

Brakes Performance Brake Upgrades

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 08-15-2009, 05:08 PM
jMo jMo is offline
Junior Member
 
2003 GMC Envoy SLT
Black 4.2L I6 4X4
Join Date: Aug 2009
Location: KY
Posts: 3
Resetting the "service brake system" message

I got this message about the same time my e-brakes failed. I've replaced front and rear pads and the e-brakes. The warning message (and that irritating dinging noise) is still there.

I've tried pulling off the battery leads...and the radio didn't even lose its presets, much less reset the message. Brake fluid level is good. Everything seems to be working correctly. So...does anyone know how to reset this message?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-28-2009, 11:16 AM
Blazernut's Avatar
Blazernut Blazernut is offline
Western Canada Chapter
 
2003 TrailBlazer and '09 Kadillak Eskalade __
sExY Dark Gray Metalic 4.2L I6 4X4
Join Date: May 2006
Location: Vancouver BC
Posts: 6,409
Welcome to the forum!

If you pull the negative battery cable for 20 minutes minimum and you still have error messages and radio presets then you have more than one problem.
__________________
Bill

Let's get a Meet going!
Reply With Quote Quick reply to this message
  #3  
Old 08-28-2009, 12:40 PM
jMo jMo is offline
Junior Member
 
2003 GMC Envoy SLT
Black 4.2L I6 4X4
Join Date: Aug 2009
Location: KY
Posts: 3
Thanks for the welcome and the response, Blazernut. I can't say for certain that I had the battery lead off for 20 minutes. I'll have another go at that.

There is another factor to weigh in, but as it's been an issue for several months, I didn't think it would be related. I had a bad wheel bearing, and had a shop replace it. When we got it back, the ABS light was on. The shop manager said his mechanic didn't get the sensor out of the old hub, and we'd have to come back in to get a new one.

I'll spare you the rest of the details going back-and-forth with that shop, but regardless...the ABS light was on for a few months, then my current issue started recently, with the red brake light in the display and the "service brake system" message. I assumed these were separate warnings, but perhaps they're related.
Reply With Quote Quick reply to this message
  #4  
Old 08-28-2009, 12:43 PM
the roadie's Avatar
the roadie the roadie is offline
No longer with us
 
2004 GMC Envoy SLT "Roadiemobile"
Extreme Offroad Pewter 4.2L I6 4X4
Join Date: Apr 2005
Posts: 26,181
The only two inputs that cause that message (that I've read about in the shop manual) are the ebrake switch and the fluid level sensor.

You can pull the connector from the master cylinder sensor to see if it's the cause - pulling the connector should mean the same as a full reservoir.

Then pull the connector off the back of the ebrake lever - the wire is a light blue.
Reply With Quote Quick reply to this message
  #5  
Old 08-28-2009, 12:52 PM
cbwilsha cbwilsha is offline
Member
 
2003 GMC Envoy SLT
Pewter Metallic 4.2L I6 2WD
Join Date: Feb 2005
Location: Port Neches, Texas
Posts: 357
You erase ANY message on the DIC by holding down the erase switch on the steering wheel for several seconds while the message is being displayed. You do NOT need to disconnect the battery.

C.B.
Reply With Quote Quick reply to this message
  #6  
Old 08-28-2009, 02:41 PM
jMo jMo is offline
Junior Member
 
2003 GMC Envoy SLT
Black 4.2L I6 4X4
Join Date: Aug 2009
Location: KY
Posts: 3
C. B. - I'll try that reset. Really looking forward to getting rid of all the dinging noise on startup.

Roadie - I tried the switch on the master cylinder, but will try the switch on the e-brake lever. Thanks. BTW, what shop manual do you use?

I didn't think I was going to get a response to this...I really appreciate all the input today!
Reply With Quote Quick reply to this message
  #7  
Old 08-28-2009, 02:52 PM
the roadie's Avatar
the roadie the roadie is offline
No longer with us
 
2004 GMC Envoy SLT "Roadiemobile"
Extreme Offroad Pewter 4.2L I6 4X4
Join Date: Apr 2005
Posts: 26,181
I bought the factory Helm, Inc. manual. Not cheap, but the most complete. Sometimes available on Ebay.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 08:21 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed