StabiliTrak service light - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 General Tech Q&A > General

General If it doesn't fit in any other forum

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 12-24-2009, 10:44 PM
xrayman xrayman is offline
Junior Member
 
2006 Chevy TrailBlazer LS
Cranberry Red Metallic 4.2L I6 4X4
Join Date: Feb 2007
Location: USA
Posts: 28
StabiliTrak service light

Hello everyone, I have a 2006 TB LS very recently my StabiliTrack Service light and StabilTrak indicator light have been coming on intermittently. However, the StabiliTrak system seems to be working, as in my area there has been a lot of snow and ice and when I am driving I can feel the system engaging, it even engaged once when while both the lights were on. Any thoughts as to what is wrong and how much will it cost to fix.
Thanks.
Xrayman
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-24-2009, 11:25 PM
niteshftGetaway's Avatar
niteshftGetaway niteshftGetaway is offline
Junior Member
 
2006 GMC Envoy SLE
Liquid Silver Metallic 4.2L I6 4X4
Join Date: Jan 2008
Location: Lewisburg, PA
Posts: 84
I've had the same thing for like the last 2 years...no garage knows what it is really a lot of them can't even duplicate it, but I think you can go without fixing it because like you said everything stabilitrak wise does still work.
__________________
The ONe and OnLY
Reply With Quote Quick reply to this message
  #3  
Old 12-25-2009, 01:07 AM
Teacher's Avatar
Teacher Teacher is offline
Member
 
2008 GMC Envoy SLT
Liquid Silver Metallic 4.2L I6 4X4
Join Date: Feb 2008
Location: Denver, CO
Posts: 413
If you have OnStar push the button when the Service Stabilitrak light is on have them run a diagnostic. When mine was on the service adviser told me that all they could do is re-flash the PCM. When I had OnStar do a diag they said it was the steering wheel position sensor. Amazing how they got it but not my dealer.
__________________
South Chapter
Colorado Rep
Reply With Quote Quick reply to this message
  #4  
Old 12-25-2009, 01:22 AM
xrayman xrayman is offline
Junior Member
 
2006 Chevy TrailBlazer LS
Cranberry Red Metallic 4.2L I6 4X4
Join Date: Feb 2007
Location: USA
Posts: 28
Quote:
Originally Posted by niteshftGetaway View Post
I've had the same thing for like the last 2 years...no garage knows what it is really a lot of them can't even duplicate it, but I think you can go without fixing it because like you said everything stabilitrak wise does still work.
Thanks for the reponse, the weird thing is that the system seems to be working. When I get a chance I plan on taking it to the stealer to see what they have to say.
Reply With Quote Quick reply to this message
  #5  
Old 12-25-2009, 01:27 AM
xrayman xrayman is offline
Junior Member
 
2006 Chevy TrailBlazer LS
Cranberry Red Metallic 4.2L I6 4X4
Join Date: Feb 2007
Location: USA
Posts: 28
Quote:
Originally Posted by Teacher View Post
If you have OnStar push the button when the Service Stabilitrak light is on have them run a diagnostic. When mine was on the service adviser told me that all they could do is re-flash the PCM. When I had OnStar do a diag they said it was the steering wheel position sensor. Amazing how they got it but not my dealer.
I don't have OnStar active, but that's cool that it has the ability to do diagnostic testing. Here's something interesting, this morning I had the truck running in the drive way to warm it up. When I got inside the lights were on, about two minutes into my drive I drove over a patch of Ice and the stability light started to flash and I could feel it engaging.
Reply With Quote Quick reply to this message
  #6  
Old 12-25-2009, 08:33 AM
07BlazerMan's Avatar
07BlazerMan 07BlazerMan is offline
TrailVoy Alumni
 
2007 Chevy TrailBlazer LS
Bordeaux Red Metallic 4.2L I6 2WD
Join Date: Jan 2009
Location: Warrenville, Illinois
Posts: 1,422
Quote:
Originally Posted by xrayman View Post
Hello everyone, I have a 2006 TB LS very recently my StabiliTrack Service light and StabilTrak indicator light have been coming on intermittently. However, the StabiliTrak system seems to be working, as in my area there has been a lot of snow and ice and when I am driving I can feel the system engaging, it even engaged once when while both the lights were on. Any thoughts as to what is wrong and how much will it cost to fix.
Thanks.
Xrayman
Mine happened to be the steering wheel sensor which I guess is a common failure. The dealer wasn't able to diagnose it until I brought it to them with the light illuminated. Every other time it would reset when I shut the truck off and on. Next time it comes on drive immediately to the dealer and leave it running and let them scan it.
__________________
Pcmforless tune, Supermodulation ported throttlebody, Amsoil EAA 204 air filter, Walker Quietflow catback, Denso iridium plugs, Supersparkz, Katskin leather seats, 18" polished rims, wood dash kit, cabin filter mod.
Reply With Quote Quick reply to this message
  #7  
Old 12-25-2009, 08:36 AM
07BlazerMan's Avatar
07BlazerMan 07BlazerMan is offline
TrailVoy Alumni
 
2007 Chevy TrailBlazer LS
Bordeaux Red Metallic 4.2L I6 2WD
Join Date: Jan 2009
Location: Warrenville, Illinois
Posts: 1,422
Quote:
Originally Posted by xrayman View Post
I don't have OnStar active, but that's cool that it has the ability to do diagnostic testing. Here's something interesting, this morning I had the truck running in the drive way to warm it up. When I got inside the lights were on, about two minutes into my drive I drove over a patch of Ice and the stability light started to flash and I could feel it engaging.
Mine did the same exact thing. It is still working what was setting it off was the steering wheel sensor giving a false reading that the steering wheel was turned all the way to the left or right but I was driving straight.
__________________
Pcmforless tune, Supermodulation ported throttlebody, Amsoil EAA 204 air filter, Walker Quietflow catback, Denso iridium plugs, Supersparkz, Katskin leather seats, 18" polished rims, wood dash kit, cabin filter mod.
Reply With Quote Quick reply to this message
  #8  
Old 12-25-2009, 04:27 PM
appstategrl appstategrl is offline
TrailVoy Alumni
 
2006 Chevy TrailBlazer LS
SnowWhite 4.2L I6 4X4
Join Date: Sep 2007
Location: wherever
Posts: 3,420
Mine did this a few weeks ago... brake control module. They got one in and were in the middle of reprograming my bcm for it when it shut down completely. Had to reorder the part and redo it all over again. Now a couple of weeks later the light is back on. It's not so much a big deal but when that light comes on it throws a code. They should be able to read the code with no problem. I'm not sure why they are telling you otherwise. The only kinda weird things I can think of are faults in wiring or such that would have to be duplicated, not a computer known error. Take it by an auto store and have the codes read on it... then search on here for what it could be and take it back to them with the codes wrote out and what they are for... that always helps when you know the problem.
Reply With Quote Quick reply to this message
  #9  
Old 01-02-2010, 01:35 PM
petey's Avatar
petey petey is offline
Member
 
2006 Chevy TrailBlazer LT
Superior Blue Metallic 4.2L I6 4X4
Join Date: Oct 2007
Location: Rhode Island
Posts: 200
My 06 did the same thing last year, 2 days after it went off warranty. Dealer said they couldn't do anything unless the light was on. 1 week later it did it again and I called OnStar. They would only give me the deff. of the code but not the number. I argued with them for 10 min for the code and told them my dealer needed the number and they still would not give it to me. They said that the dealer could call them to get the number.


The next day I took it to my dealer and got it back that afternoon all fixed. I talked to the tech and he said that my steering wheel position sensor was faulty and that he had to reprogram the computer a few times (TSB) before he could diagnose the problem. He also said that the code is stored in the computer so the light does not have to be on (FYI). I have a feeling that this problem is a faulty program and not so much the sensor itself.
__________________
other cars
1997 Saturn SL2 165000 miles
2003 TrailBlazer EXT V8 60000miles (gone)
Reply With Quote Quick reply to this message
  #10  
Old 01-11-2010, 01:46 PM
toeskis toeskis is offline
Junior Member
 
2006 Chevy TrailBlazer LS
Black 4.2L I6 4X4
Join Date: Nov 2009
Location: Fayetteville, NY
Posts: 7
Traction Control

I'm having the same issue with my Traction Control/ Stabilitrak going off, but my truck is stalling as this happens. Occassionally, all will be well, tc/s-trak engages, and all is well, but sometimes, predominantly when I'm turning the wheel, my truck will stall when tc/s-trak engages. Anybody else run across this?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 02:47 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed