Rear Climate Control Problem - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 General Tech Q&A > General

General If it doesn't fit in any other forum

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 01-21-2010, 10:03 AM
PittsburghBoy79 PittsburghBoy79 is offline
Junior Member
 
2004 Chevy TrailBlazer LT EXT
Liquid Silver Metallic 4.2L I6 4X4
Join Date: Jan 2010
Location: Pittsburgh, PA
Posts: 5
Rear Climate Control Problem

Hello all. This is my first post. I recently bought a 2004 Trailblazer LT. My rear climate controls do not seem to be working. When i press any button, whether it be fan, mode, or temp it only blinks at me and does not allow me to change anything. My manual says something about the "R" button has to be turned ON. I have no idea what this is. Can anyone help me out. It would be greatly appreciated! Thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-21-2010, 10:42 AM
PittsburghBoy79 PittsburghBoy79 is offline
Junior Member
 
2004 Chevy TrailBlazer LT EXT
Liquid Silver Metallic 4.2L I6 4X4
Join Date: Jan 2010
Location: Pittsburgh, PA
Posts: 5
WOW I feel like an idiot works now thanks a million!!!
Reply With Quote Quick reply to this message
  #3  
Old 01-21-2010, 10:45 AM
PittsburghBoy79 PittsburghBoy79 is offline
Junior Member
 
2004 Chevy TrailBlazer LT EXT
Liquid Silver Metallic 4.2L I6 4X4
Join Date: Jan 2010
Location: Pittsburgh, PA
Posts: 5
Also, the air that comes from the ceiling isn't that hot for the second row but it is in the third row. Any similar issues?
Reply With Quote Quick reply to this message
  #4  
Old 01-21-2010, 10:58 AM
PittsburghBoy79 PittsburghBoy79 is offline
Junior Member
 
2004 Chevy TrailBlazer LT EXT
Liquid Silver Metallic 4.2L I6 4X4
Join Date: Jan 2010
Location: Pittsburgh, PA
Posts: 5
I'll have to see. I did read a couple of the same things on the threads. Lucky You!! It's 25 Degrees up here LOL
Reply With Quote Quick reply to this message
  #5  
Old 01-21-2010, 11:02 AM
PittsburghBoy79 PittsburghBoy79 is offline
Junior Member
 
2004 Chevy TrailBlazer LT EXT
Liquid Silver Metallic 4.2L I6 4X4
Join Date: Jan 2010
Location: Pittsburgh, PA
Posts: 5
Thanks again for your help!
Reply With Quote Quick reply to this message
  #6  
Old 02-04-2010, 12:48 PM
jlarson jlarson is offline
Junior Member
 
2003 GMC Envoy SLT XL
Black 4.2L I6 4X4
Join Date: Aug 2009
Location: Eagle River, AK
Posts: 1
Rear heat stays cold

My rear fan works fine and the air control switches from ceiling to floor just fine. The rear air never gets warm. Any Ideas?
Reply With Quote Quick reply to this message
  #7  
Old 02-04-2010, 01:34 PM
the roadie's Avatar
the roadie the roadie is offline
No longer with us
 
2004 GMC Envoy SLT "Roadiemobile"
Extreme Offroad Pewter 4.2L I6 4X4
Join Date: Apr 2005
Posts: 26,181
Welcome! If you get good engine coolant flow to the rear heater core, it sounds like a rear temp actuator. Run a search, but it's easy to see in my drawing here.

It may also be clogged coolant flow. Feel the hoses if you can when you get the rear HVAC system cover off.

Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 05:36 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed