4 Wheel drive won't engage - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > Transmission Mods

Transmission Mods Performance Transmission Modifications

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 01-12-2011, 05:11 PM
llparker01 llparker01 is offline
Junior Member
 
2005 GMC Envoy SLT XL
Black 5.3L V8 4X4
Join Date: Apr 2010
Location: Greensboro,nc
Posts: 5
4 Wheel drive won't engage

I have a 2005 Envoy XL Slt 5.3L..I notice that when I switch to A4WD or 4Hi the light stays on steady but I realize its actually in 4Lo. I have seem some suggestions about pulling a fuse or tccm and re install it. can anyone else give me some suggestions before I take it to a dealership. this couldn't happen at a worse time I could really use it for this atlanta snow/icey roads.
even though its stays in 4Lo no matter what I select 4Hi or A4WD its better than nothing but, I could really use 4Hi/A4WD.

Thanks for any suggestions

spelling error-I meant engage
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-12-2011, 05:15 PM
mika's Avatar
mika mika is offline
Member
 
2002 Chevy TrailBlazer LT EXT
Sand Beige Metallic 4.2L I6 4X4
Join Date: Sep 2010
Location: montreal
Posts: 288
Are you in 4lo all the time or can you get it to 2hi? If 2hi and your only other option is 4lo it could just be your selector switch.
Reply With Quote Quick reply to this message
  #3  
Old 01-12-2011, 05:23 PM
darknight's Avatar
darknight darknight is offline
Member
 
2005 Chevy TrailBlazer LS
Black Granite Metallic 4.2L I6 4X4
Join Date: Oct 2009
Location: hampton va
Posts: 199
it maybe the motor to some one will chime in soon that can give you more help ROADIE lol have you taken it in to be seen yet or do you plan to do it ur self
__________________

definity MT's MarkMC 2.5 susp. custom lift Light bar JL audio Equipment 6k hids custom bumpers to come
Reply With Quote Quick reply to this message
  #4  
Old 01-12-2011, 06:02 PM
llparker01 llparker01 is offline
Junior Member
 
2005 GMC Envoy SLT XL
Black 5.3L V8 4X4
Join Date: Apr 2010
Location: Greensboro,nc
Posts: 5
4 wheel drive won't engage

Quote:
Originally Posted by mika View Post
Are you in 4lo all the time or can you get it to 2hi? If 2hi and your only other option is 4lo it could just be your selector switch.
2hi works fine but if I select a4wd or 4hi whatever I select lights steady but I can feel its actually driving in 4lo because I can only drive at a slow speed unless I switch back to 2hi
Reply With Quote Quick reply to this message
  #5  
Old 01-12-2011, 06:05 PM
llparker01 llparker01 is offline
Junior Member
 
2005 GMC Envoy SLT XL
Black 5.3L V8 4X4
Join Date: Apr 2010
Location: Greensboro,nc
Posts: 5
4 wheel drive won't engage

Quote:
Originally Posted by darknight View Post
it maybe the motor to some one will chime in soon that can give you more help ROADIE lol have you taken it in to be seen yet or do you plan to do it ur self
thanks for the response..I'm actually from Hampton VA and worked at Langely until I moved. anyways 2hi works fine but if I select a4wd or 4hi the selection I choose lights up like everything is normal but I can only drive at a slow speed(tells me I'm in 4Lo) unless I switch it back to 2hi then everythings normal.
Reply With Quote Quick reply to this message
  #6  
Old 01-12-2011, 09:15 PM
the roadie's Avatar
the roadie the roadie is offline
No longer with us
 
2004 GMC Envoy SLT "Roadiemobile"
Extreme Offroad Pewter 4.2L I6 4X4
Join Date: Apr 2005
Posts: 26,181
First time I've heard of this exact issue. Unless you're an advanced DIY mechanic with access to the schematics and good electrical skills, I would take it to the dealer to diagnose. It may be the TCCM or the encoder motor or some odd internal breakdown in the transfer case. Sorry I can't be of more help.

To confirm you're in 4LO, the RPMs for any given road speed would be 2.7 times as much in 4LO than 2HI. Can you do the experiment to go 10 MPH and 20 MPH and write down your RPMS in 4th gear. Only do this on a slippery surface because you can't use 4HO or 4LO on pavement.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 03:02 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed