Turning off Stabilitrak - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 General Tech Q&A > General

General If it doesn't fit in any other forum

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 01-21-2011, 11:44 PM
DGenerate23's Avatar
DGenerate23 DGenerate23 is offline
Junior Member
 
2006 Chevy TrailBlazer LT
Black 4.2L I6 4X4
Join Date: Jan 2011
Location: Warsaw IN
Posts: 18
Turning off Stabilitrak

I have searched all over this forum and can't find an answer. I have tried everything the maual tells me to do to turn my stabilitrak off Parked and moving. i even held the button in for my entire lunch one day which is 30 minutes and cannot get it to shut off. can someone give me a step by step instruction ob how it should be done i know it works cause im always getting the little message in my D.I.C that stabilitrak is active. someone please help me
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-21-2011, 11:56 PM
RedEnvoyDenali's Avatar
RedEnvoyDenali RedEnvoyDenali is offline
Senior Member
 
2006 GMC Envoy Denali
Magnetic Red Metallic 5.3L V8 4X4
Join Date: Mar 2008
Location: Saskatoon Saskatchewan
Posts: 861
Quote:
Originally Posted by DGenerate23 View Post
I have searched all over this forum and can't find an answer. I have tried everything the maual tells me to do to turn my stabilitrak off Parked and moving. i even held the button in for my entire lunch one day which is 30 minutes and cannot get it to shut off. can someone give me a step by step instruction ob how it should be done i know it works cause im always getting the little message in my D.I.C that stabilitrak is active. someone please help me
All I do for mine is simply push and release the button under your thumb on the left side of the gear shift lever. The cluster light then comes on telling me the Stabiltrak is OFF.

Don't know if there is any other way to disconnect.
Reply With Quote Quick reply to this message
  #3  
Old 01-22-2011, 12:02 AM
DGenerate23's Avatar
DGenerate23 DGenerate23 is offline
Junior Member
 
2006 Chevy TrailBlazer LT
Black 4.2L I6 4X4
Join Date: Jan 2011
Location: Warsaw IN
Posts: 18
I guess ill have to try again as soon as i get it back from the shop early next week
Reply With Quote Quick reply to this message
  #4  
Old 01-22-2011, 09:23 AM
Wex Wex is offline
Senior Member
 
2006 Chevy TrailBlazer LS
Steel Gray Metallic 4.2L I6 4X4
Join Date: Sep 2009
Location: San Antonio, TX
Posts: 541
Mine I think I push the button, the traction control off icon comes on. Then hold the button for about three seconds and then the stabiltrak shuts off.
__________________
2006 TB-LS 4x4. 4.2, 85K
Reply With Quote Quick reply to this message
  #5  
Old 01-24-2011, 09:01 AM
fletch09's Avatar
fletch09 fletch09 is offline
TrailVoy Alumni
 
2009 Chevy TrailBlazer LT
Summit White 4.2L I6 4X4
Join Date: Mar 2009
Location: IL
Posts: 1,349
Quote:
Originally Posted by Wex View Post
Mine I think I push the button, the traction control off icon comes on. Then hold the button for about three seconds and then the stabiltrak shuts off.


IIRC some one else could not get theirs to turn off. turned out to be a loose wire under the shift boot. check that also.
Reply With Quote Quick reply to this message
  #6  
Old 01-24-2011, 09:12 AM
Wex Wex is offline
Senior Member
 
2006 Chevy TrailBlazer LS
Steel Gray Metallic 4.2L I6 4X4
Join Date: Sep 2009
Location: San Antonio, TX
Posts: 541
I tried mine yesterday. One push made icon come on solid. This I assume is traction control disabled.

Or hold down button for several seconds and made an icon flash. This I assume is stabilitrak off. I did not have to go through the second step like I previously mentioned. I think that second step how I read it in the user manual tho.

I believe it is the same icon behavior when you goto into 4Lo. 4Lo should disable stabilitrak as well.
__________________
2006 TB-LS 4x4. 4.2, 85K
Reply With Quote Quick reply to this message
  #7  
Old 01-24-2011, 09:22 AM
fletch09's Avatar
fletch09 fletch09 is offline
TrailVoy Alumni
 
2009 Chevy TrailBlazer LT
Summit White 4.2L I6 4X4
Join Date: Mar 2009
Location: IL
Posts: 1,349
if you have it , the D.I.C. should tell you that the traction control is off, and that the stabilitrac is off. it does on my 09. maybe not on the 06.
Reply With Quote Quick reply to this message
  #8  
Old 01-24-2011, 08:05 PM
DGenerate23's Avatar
DGenerate23 DGenerate23 is offline
Junior Member
 
2006 Chevy TrailBlazer LT
Black 4.2L I6 4X4
Join Date: Jan 2011
Location: Warsaw IN
Posts: 18
i have the D.I.C. and no matter how long i hold the button with my TB in park or neutrel i can not get the TC or Stabilitrak to shut off i think when i get it back from the body shop on wed im going to tear into the shift boot and see about that loose wire
Reply With Quote Quick reply to this message
  #9  
Old 01-24-2011, 08:50 PM
fletch09's Avatar
fletch09 fletch09 is offline
TrailVoy Alumni
 
2009 Chevy TrailBlazer LT
Summit White 4.2L I6 4X4
Join Date: Mar 2009
Location: IL
Posts: 1,349
Quote:
Originally Posted by DGenerate23 View Post
i have the D.I.C. and no matter how long i hold the button with my TB in park or neutrel i can not get the TC or Stabilitrak to shut off i think when i get it back from the body shop on wed im going to tear into the shift boot and see about that loose wire
i am able to turn those off in any gear. def. look for a loose or disconnected wire. if you cant find anything, talk to a dealer, if out of warranty, may be covered since it's a safety issue and part of drive train
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 08:08 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed