Help, wierd little issues(Vibration, bad mpg) - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > Engine Tunes/Mods

Engine Tunes/Mods Performance Engine Tuning/Engine Modifications

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 02-23-2011, 09:51 PM
slmdls1 slmdls1 is offline
Junior Member
 
2004 GMC Envoy SLT
Liquid Silver Metallic 4.2L I6 2WD
Join Date: Feb 2010
Location: Tallahassee, Florida
Posts: 41
Help, wierd little issues(Vibration, bad mpg)

(please bear with me, not sure if this should be in the OEM forum or what)

(This is on an 04 SLT, 2wd, Auto, 4.2 I6)

Ok...i've been around here lurking for a while, reading here and there so im aware of some of the issues with these vehicles. I was told it got a new battery and new plugs not long before we bought it. I cleaned the TB a while back and no issues around that time...or maybe i just didn't notice this.
  • Mine has this weird vibration. very small, yet its gotten more annoying at stop lights, i know other cars can hear this thing vibrating. it never occurs at highway speeds, only at very low speeds and when it is still. It doesn't vibrate in Neutral, only in a gear...so it can be replicated. At first thought i thought my fan blades were hitting the plastic shroud it was so loud/hard. I also thought that it was so bad my knock sensors were picking it up, but no SES light. I did have it at my buddy's shop for oil change Sunday, and we had a scanner on it to monitor a few things. My knock sensor 2 was staying out of range but we couldn't replicate the vibration this day.... weird. The required range was .8-1.0 volts and this thing was anywhere from 1.2-1.9 while the other was within range. could this be a bad motor mount and can they go bad without a lot of visual damage? we looked and only 1 was cracked in a few places, but they weren't bad from what we could tell, although when we loaded the motor with the brake on, it did move more than we'd like.

  • It has been hard to start lately(sometimes taking 4, 2-3 second turns, of the key). This meaning not the starter as it turns over fine. With the previous owner saying he replaced the plugs, my thoughts turn to fuel problem with no SES light...no misfire codes so not bad injectors. Any info on the fuel pressure regulator, or did someone recently call it something else on here...are they a common issue? i should be replacing the plugs soon since they are cheap and easy fix.

These issues listed above have been around for a little while...yesterday i came to a stoplight and held the brake (in drive) when the vibration became the worst....held it and on popped the SES light(i believe it had about 1/8h tank of gas). p0442 was the code pulled today as i needed to get fuel, but i hadnt touched my fuel cap in 9 days so its not the cap. My buddy cleared the light off, i filled up gas, drove about 15-20 miles to get my daughter and then home. i know sometimes thats not enough miles on it to set off the light again, so it may come on again tomorrow.

could the vibration be a bad fuel pressure issue or evap leak? (both causing bad mpg - im getting about 12mpg/city with a light foot)

the hard start issue makes me think theres not enough fuel pressure built up when it sits a while and thats what makes it hard to start initially...

and for giggles heres a cell pic...

__________________
http://i83.photobucket.com/albums/j301/slmdls1/Signatures/IMAG0116-2.jpg
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-24-2011, 09:50 PM
slmdls1 slmdls1 is offline
Junior Member
 
2004 GMC Envoy SLT
Liquid Silver Metallic 4.2L I6 2WD
Join Date: Feb 2010
Location: Tallahassee, Florida
Posts: 41
(bump)

well, i found where my vibration was coming from. Bad tensioner pulley.
__________________
http://i83.photobucket.com/albums/j301/slmdls1/Signatures/IMAG0116-2.jpg
Reply With Quote Quick reply to this message
  #3  
Old 02-28-2011, 09:50 AM
slmdls1 slmdls1 is offline
Junior Member
 
2004 GMC Envoy SLT
Liquid Silver Metallic 4.2L I6 2WD
Join Date: Feb 2010
Location: Tallahassee, Florida
Posts: 41
Quote:
Originally Posted by slmdls1 View Post
(bump)

well, i found where my vibration was coming from. Bad tensioner pulley.
well, that was partially it....i picked up 2mpg by replacing my tensioner pulley...same tank of gas, same route, same weather conditions....12mpg first half of the tank, 13.9-14.2mpg on the second half....still have a slight vibration though.

Does the waterpump on these go bad and cause a vibration, without showing other signs of going bad like overheating or leaky seal?

where is the best place to check fuel pressure....schrader valve? didnt see it but only looked around briefly as it was getting dark...

gonna clean the tb again and leave the battery unhooked for 45 mins when i change the plugs here pretty soon(AC Delco's).

am i talkin to myself here?
__________________
http://i83.photobucket.com/albums/j301/slmdls1/Signatures/IMAG0116-2.jpg
Reply With Quote Quick reply to this message
  #4  
Old 02-28-2011, 10:53 AM
Nexus1155 Nexus1155 is offline
Member
 
2005 GMC Envoy SLE XUV
Liquid Silver Metallic 4.2L I6 AWD
Join Date: Jul 2008
Location: Boston
Posts: 419
Quote:
Does the waterpump on these go bad and cause a vibration, without showing other signs of going bad like overheating or leaky seal?
YES. Usually replacing water pump and fan clutch at same time is a good idea if you have $$$.

How bad off was tensioner pulley?
Reply With Quote Quick reply to this message
  #5  
Old 02-28-2011, 12:50 PM
slmdls1 slmdls1 is offline
Junior Member
 
2004 GMC Envoy SLT
Liquid Silver Metallic 4.2L I6 2WD
Join Date: Feb 2010
Location: Tallahassee, Florida
Posts: 41
Quote:
Originally Posted by Nexus1155 View Post
YES. Usually replacing water pump and fan clutch at same time is a good idea if you have $$$.

How bad off was tensioner pulley?
it was pulled all the way down. the best description i can give you was when we took the old one off, it was mounted parallel to the ground like "_"...when we mounted the new one, it was angled up like "/" with a lot more tension on it. Hope that makes sense. It was the "high pressure spring" inside the tensioner that had given out and had let tension off the belt.

any recommendations on testing to see if the water pump is bad? like i said, no leaks and it doesn't run hot...I'd like to at least be pretty sure that's what it is before i throw big money at it. The tensioner and plugs weren't all that much and i did/will do that myself, but im not fooling with a water pump or fan clutch.
__________________
http://i83.photobucket.com/albums/j301/slmdls1/Signatures/IMAG0116-2.jpg
Reply With Quote Quick reply to this message
  #6  
Old 02-28-2011, 01:28 PM
bromanjr's Avatar
bromanjr bromanjr is offline
Senior Member
 
2004 GMC Envoy SLT XUV
Indigo Blue Metallic 5.3L V8 2WD
Join Date: Sep 2010
Location: Howell, MI
Posts: 691
Quote:
Originally Posted by slmdls1 View Post
well, that was partially it....i picked up 2mpg by replacing my tensioner pulley...same tank of gas, same route, same weather conditions....12mpg first half of the tank, 13.9-14.2mpg on the second half....still have a slight vibration though.

Does the waterpump on these go bad and cause a vibration, without showing other signs of going bad like overheating or leaky seal?

where is the best place to check fuel pressure....schrader valve? didnt see it but only looked around briefly as it was getting dark...

gonna clean the tb again and leave the battery unhooked for 45 mins when i change the plugs here pretty soon(AC Delco's).

am i talkin to myself here?
Schraeder valve for fuel pressure test is at the front of the fuel tank next to the filter. (yes, under the truck)

Don't forget to check the fuel pressure regulator diaphragm for leaking by taking the vacuum hose off of it to check. Like all other regulators, NO fuel should be there in any form.
__________________
182,000 and counting. Superchips 2914 Tune, NAV upgrade.
Reply With Quote Quick reply to this message
  #7  
Old 02-28-2011, 01:39 PM
slmdls1 slmdls1 is offline
Junior Member
 
2004 GMC Envoy SLT
Liquid Silver Metallic 4.2L I6 2WD
Join Date: Feb 2010
Location: Tallahassee, Florida
Posts: 41
Quote:
Originally Posted by bromanjr View Post
Schraeder valve for fuel pressure test is at the front of the fuel tank next to the filter. (yes, under the truck)

Don't forget to check the fuel pressure regulator diaphragm for leaking by taking the vacuum hose off of it to check. Like all other regulators, NO fuel should be there in any form.

is there a good engine schematic online somewhere for the top end of these motors? I'd like to take a look so I'm familiar with where some of this stuff is...like that FPR/diaphragm.
__________________
http://i83.photobucket.com/albums/j301/slmdls1/Signatures/IMAG0116-2.jpg
Reply With Quote Quick reply to this message
  #8  
Old 02-28-2011, 01:51 PM
bromanjr's Avatar
bromanjr bromanjr is offline
Senior Member
 
2004 GMC Envoy SLT XUV
Indigo Blue Metallic 5.3L V8 2WD
Join Date: Sep 2010
Location: Howell, MI
Posts: 691
Quote:
Originally Posted by slmdls1 View Post
is there a good engine schematic online somewhere for the top end of these motors? I'd like to take a look so I'm familiar with where some of this stuff is...like that FPR/diaphragm.
I don't have access to one right now, the FPR is always on the fuel rail which is above the injectors. On the I6 IIRC it is on the driver side near cylinder 2 or 3
__________________
182,000 and counting. Superchips 2914 Tune, NAV upgrade.
Reply With Quote Quick reply to this message
  #9  
Old 03-02-2011, 11:03 AM
Nexus1155 Nexus1155 is offline
Member
 
2005 GMC Envoy SLE XUV
Liquid Silver Metallic 4.2L I6 AWD
Join Date: Jul 2008
Location: Boston
Posts: 419
Quote:
any recommendations on testing to see if the water pump is bad?
The way I did it was grab a fin on the fan clutch and wiggle it toward the front and back of the engine. Usually if you can see the waterpump pulley shimmying with the fan clutch. Thats no good.
Reply With Quote Quick reply to this message
  #10  
Old 03-02-2011, 11:33 AM
the roadie's Avatar
the roadie the roadie is offline
No longer with us
 
2004 GMC Envoy SLT "Roadiemobile"
Extreme Offroad Pewter 4.2L I6 4X4
Join Date: Apr 2005
Posts: 26,181
We constantly refer to the exploded parts diagrams at www.compnine.com to find stuff.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 06:47 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed