2004 Envoy - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 General Tech Q&A > General

General If it doesn't fit in any other forum

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 05-22-2011, 02:59 PM
kevinrwarren kevinrwarren is offline
Junior Member
 
2004 GMC Envoy SLE
Summit White 4.2L I6 AWD
Join Date: May 2011
Location: Lynchburg TN
Posts: 3
2004 Envoy

I wasn't sure what forum to put this in so here is my queston. My check engine light has been on and I got a pint off from my local parts place of what it could possibly be and have replaced everything on the list except the thing dealing with a vacuum leak can anyone tell me how to fix this myself thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-22-2011, 03:23 PM
freddyboy61 freddyboy61 is offline
No longer with us
 
2004 GMC Envoy SLE XL
Summit White 4.2L I6 4X4
Join Date: Jul 2008
Location: Long Island, NY
Posts: 1,240
Welcome to the site, but please be a little more careful in your typing. I had to read your post several times to realize the "pint off" actually meant "print out".
In order for anyone to help you with your problem, you need to provide more information such as the trouble code that the parts store read from your vehicle and any symptoms you are experiencing.
__________________
[SIZE="2"][I]Freddyboy61[/I][COLOR="Blue"][/COLOR][/SIZE]
[U] [/U]
Reply With Quote Quick reply to this message
  #3  
Old 05-22-2011, 03:52 PM
kevinrwarren kevinrwarren is offline
Junior Member
 
2004 GMC Envoy SLE
Summit White 4.2L I6 AWD
Join Date: May 2011
Location: Lynchburg TN
Posts: 3
Thanks for the spell check the codes are PO106 , PO410 if Im looking at the print off correctly
Reply With Quote Quick reply to this message
  #4  
Old 05-22-2011, 06:30 PM
the roadie's Avatar
the roadie the roadie is offline
No longer with us
 
2004 GMC Envoy SLT "Roadiemobile"
Extreme Offroad Pewter 4.2L I6 4X4
Join Date: Apr 2005
Posts: 26,181
Lots of discussion here on those two codes. Run a search, and spell them with a P and a Zero then the number instead of P and O, and you'll find a lot to read.

And what precisely did you replace? If you didn't troubleshoot the Secondary Air Injection system properly, you might have replaced a $250 air pump when it might have been a $50 O2 sensor or $25 relay.
Reply With Quote Quick reply to this message
  #5  
Old 05-22-2011, 09:40 PM
kevinrwarren kevinrwarren is offline
Junior Member
 
2004 GMC Envoy SLE
Summit White 4.2L I6 AWD
Join Date: May 2011
Location: Lynchburg TN
Posts: 3
2004 Envoy

I replaced the map sensor , variable time cam sensor , thermostat , air filter ,and i had the Secondary Air Injection system checked and and someone told me that it could be a vacuum leak under the dash
Reply With Quote Quick reply to this message
  #6  
Old 05-22-2011, 10:05 PM
the roadie's Avatar
the roadie the roadie is offline
No longer with us
 
2004 GMC Envoy SLT "Roadiemobile"
Extreme Offroad Pewter 4.2L I6 4X4
Join Date: Apr 2005
Posts: 26,181
There is nothing under our dash that requires vacuum. Whoever guessed that should be disregarded as not knowing enough about our platform.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 07:38 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed