Reduced Engine Power Light/Loss of Power - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > OEM Issues

OEM Issues Original Equipment Repairs and/or Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 06-05-2011, 12:31 PM
trailblaze04 trailblaze04 is offline
Junior Member
 
2004 Chevy TrailBlazer LS
Midnight Blue Metallic 4.2L I6 2WD
Join Date: Aug 2010
Location: USA
Posts: 6
Reduced Engine Power Light/Loss of Power

I have an 04 Trailblazer 2WD and recently it has lost power twice while driving. The first time it happened the Reduced Engine Power light came on but the second time it didn't. I have noticed on both occasions I had just started it up and not driven a mile when it happened. I turned the engine off and restarted it and it was back to normal.

I went to get it checked out but they said they couldn't fix it and gave me a code. They said someone more qualified should look at it so now I'm trying to figure out what to do. The code is P1680.

Has anyone else dealt with this problem?

Also, I have noticed that when I start it up after sitting awhile I have to let it sit a few minutes because if I drive it right after starting the engine it will rev up when I pull out of the drive.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-05-2011, 12:42 PM
truefire98's Avatar
truefire98 truefire98 is offline
Member
 
1999 GMC sierra ls 1500
Majestic Red Metallic 5.3L V8 2WD
Join Date: Feb 2007
Location: RIVERVIEW, FL.
Posts: 111
normally its related to the t/b and the accelerator pedal because the system is drive by wire, and there is no throttle cable, so ether the pedal is bad or the t/b is bad, and even sometimes the computer needs a reflash to update the problem. best bet is to take it to a dealer to see what is going on.
Reply With Quote Quick reply to this message
  #3  
Old 06-05-2011, 01:07 PM
the roadie's Avatar
the roadie the roadie is offline
No longer with us
 
2004 GMC Envoy SLT "Roadiemobile"
Extreme Offroad Pewter 4.2L I6 4X4
Join Date: Apr 2005
Posts: 26,181
Many discussions here mention that code.
Reply With Quote Quick reply to this message
  #4  
Old 06-05-2011, 01:08 PM
christo829's Avatar
christo829 christo829 is offline
TrailVoy Alumni
 
2004 Chevy TrailBlazer LT
Silverstone Metallic 4.2L I6 4X4
Join Date: Mar 2009
Location: Fairfax, VA
Posts: 1,298
Take a look at these two threads:

http://forums.trailvoy.com/showthrea...ighlight=p1680

http://forums.trailvoy.com/showthrea...ighlight=P1680

In that second thread, there's a resistance value listed for the APP. If you're
handy with a multimeter, you could check that. If it's bad, replace it. If
it's good, then could be solvable with a PCM reflash/update. Or...maybe a good excuse
to get a PCMforless tune...

Some members have found a throttle body clean to help as well:

http://forums.trailvoy.com/showthrea...ody+cle aning

Good Luck!

Chris
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 01:44 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed