Fuel filter/code 1221 - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > OEM Issues

OEM Issues Original Equipment Repairs and/or Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 01-01-2013, 10:17 PM
stocktsi stocktsi is offline
Junior Member
 
2002 GMC Envoy SLT
Midnight Blue Metallic 4.2L I6 2WD
Join Date: Dec 2009
Location: CA
Posts: 2
Fuel filter/code 1221

Tis afternoon I replaced the fuel filter on my 2002 GMC Envoy. Also changed rear shocks and washed engine with water sprayer.

When I went to drive it, the Service Engine light and Reduced Engine Power lights were on, and the Envoy only crawls and does seem to want to shift out of 1st gear.

Checked code and it shows 1221. Reset the hoses to the new fuel filter to make sure everything in place and they look good. Tried resetting code and it comes back.

Tried disconnecting battery for about 10 min and same result after reconnected. Currently trying disconnect for an hour or so to make sure everything is cleared.

Any ideas what might gave happened? Was running fine before the maintenance work today. Could the fuel filter change have caused an issue? Or the engine wash?

Thanks in advance for your help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-01-2013, 11:58 PM
stocktsi stocktsi is offline
Junior Member
 
2002 GMC Envoy SLT
Midnight Blue Metallic 4.2L I6 2WD
Join Date: Dec 2009
Location: CA
Posts: 2
One other piece of information: the traction control is turned off and I can't turn it back on. Originally had a traction control error code, but that has gone away since then.
Reply With Quote Quick reply to this message
  #3  
Old 01-02-2013, 09:24 AM
Ray Dockrey's Avatar
Ray Dockrey Ray Dockrey is offline
TrailVoy Alumni
 
2009 Chrysler PT Cruiser
Inferno Red Other 2WD
Join Date: Aug 2008
Location: Mustang, OK
Posts: 1,088
The key here is washed engine with water sprayer. I would say you either got water in a sensor or knocked the wiring loose. If you would have done a search on that code you would have realized that it has nothing to do with the fuel filter.

http://forums.trailvoy.com/showthread.php?t=70907
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 09:59 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed