2004 Trailblazer engine swap HELP! - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > TrailVoy Chapters > West

West
AZ, CA, HI, NV, UT View Chapter  |  Join Chapter

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 06-21-2017, 03:06 AM
Kris04TB Kris04TB is offline
Junior Member
 
2004 Chevy TrailBlazer LT
Forest Green Metallic 4.2L I6 2WD
Join Date: Jun 2017
Location: Fresno, CA
Posts: 4
2004 Trailblazer engine swap HELP!

I have a 2004 Trailblazer 4.2l I6. 2WD. LT(if it matters) I've had the TB for about 4 years now. I love it. But recently it started to knock and just progressed at a very fast rate. It's now making all kinds of squelling noises and just a loud knock that hits harder when I left off the gas. I've decided to sell my 05 R6 to pay for a swap in my TB. My TB has 147k miles. Regular maintenance. But after it started knocking I checked the oil and it was a couple quarts low. No signs of ANY leaking anywhere. Im wondering what would be the best way to go about it? What motors are a direct fit to my 04 TB? I should get about $3k fire my bike including extra stuff, would that be enough? I'm mechanically inclined and have changed the water pump, fan clutch, alternator, serpentine belt twice, oil changes, brakes, tire rotations, air filter changes, throttle body cleaning, spark plug changes (AC Delco), replaced 2 ignition coils, ect. Please help if you have ANY input for me.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-04-2017, 07:13 PM
01TheDude 01TheDude is offline
Junior Member
 
2004 Chevy TrailBlazer LT
Midnight Blue Metallic 4.2L I6 2WD
Join Date: Jun 2017
Location: Phoenix, AZ
Posts: 7
Interesting that you mentioned the low oil but no signs of leaking. I have the same truck and have to feed it oil quite often. It must be burning up somewhere. It's not on the engine, not in my coolant (though that is the snap answer given my mechanics too often-- that you have a blown head gasket).

The knocking could be from the low oil. Fill it up and see if that noise abates. These trucks can run on practically no oil (as I found out without realizing I was doing it). But they sure prefer having a nice supply.

But good luck with your engine swap out-- I would check the site, most likely someone has done it before.
Reply With Quote Quick reply to this message
  #3  
Old 07-06-2017, 04:36 PM
Horsehaulin Horsehaulin is offline
Junior Member
 
2006 GMC Envoy Denali XL
Bordeaux Red Metallic 5.3L V8 4X4
Join Date: Jan 2016
Location: Fort Wayne, IN
Posts: 24
42. I6 and a 5.3 V-8 as a standard engine and a 6.0 in the SS models. Any one of them should go into the engine bay with minor modifications if installing a 5.3 or 6.0. The 6.0 will require a trans swap also as it is a little more stout than the other two engines.

To do a straight rebuild should be cheaper and efficient, but make sure you have someone program the ecm afterwards to shut off the DoD/AFM. This is the function that actually burns our motors up, if that is shut off, you should get many more miles from your TB.

Good luck!
Reply With Quote Quick reply to this message
 
  #4  
Old 01-20-2018, 08:46 PM
Kris04TB Kris04TB is offline
Junior Member
 
2004 Chevy TrailBlazer LT
Forest Green Metallic 4.2L I6 2WD
Join Date: Jun 2017
Location: Fresno, CA
Posts: 4
I did the full swap. Straight across with an 02 4wheel drive. Everything went fairly smooth mechanically. But Im having some major issues. I'm going to list them and if anyone has any advice please help. First and most important. It won't start. Nothing. All dash lights active but won't crank. The fuel pump engages, the throttle body makes a noise and the computer makes a low pitch hum. Looked at the starter and compared the wiring with a video I seen to verify it, it was correct. But it's not engaging at all. Also when attempting to put it in neutral and applying the brake it won't shift. But my linkage to the tranny is unhooked because it's like a half inch off of where it would line up. But when going to pull the motor I had to shift it into neutral manually because I had to roll it backwards to fit the cherry picker. I obviously unhooked the linkage when I went to manually put it in neutral and not it's not lining up right but I was just just trying to hear the motor run. Lol I still had the headlights and grill all undone but I was losing daylight. Any information is needed. I'm completely lost and very frustrated. Don't even know where to begin.
Reply With Quote Quick reply to this message
  #5  
Old 01-21-2018, 10:14 AM
NJTB04 NJTB04 is offline
Member
 
2004 Chevy TrailBlazer LS
Pewter Metallic 4.2L I6 4X4
Join Date: Aug 2012
Location: Edison, NJ
Posts: 230
When you unhooked the trans linkage, it may have moved from park to drive or another gear so you could move it. Make sure the linkage and the switch are correctly aligned and in park.
Reply With Quote Quick reply to this message
  #6  
Old 01-21-2018, 11:55 AM
Kris04TB Kris04TB is offline
Junior Member
 
2004 Chevy TrailBlazer LT
Forest Green Metallic 4.2L I6 2WD
Join Date: Jun 2017
Location: Fresno, CA
Posts: 4
The shifter up front is in park but unmovable. Can't move the linkage but I can shift the trans on the side of it. I went back and forth on the shifting but can't figure out why it won't line up.
Reply With Quote Quick reply to this message
  #7  
Old 01-28-2018, 01:38 PM
Kris04TB Kris04TB is offline
Junior Member
 
2004 Chevy TrailBlazer LT
Forest Green Metallic 4.2L I6 2WD
Join Date: Jun 2017
Location: Fresno, CA
Posts: 4
Ok so swap is complete. Truck is running great. So I went yesterday and plugged in the battery. Turned the key and the only response I got was a check engine light. Key got stuck. Then unstuck as I unplugged and re plugged in the battery. While I was connecting the battery from the driver side tire next to the fuse block I hit the black ground on the inner wall nearest me and it sparked. So I stopped and tightened it up. No idea why it was loose. But it was just backed out enough to not connect right. Then I had full dash lights. No crank. And key was releasing every time. So I tried to shift. It was stuck. No brake click. Nothing. So I jumped under to the tranny and checked the Park neutral switch power plug was and it was undone. It was one big plug coming from wires but after messing with that for a while realizing you have to slide the side bracket back and putting it on and sliding it back completed the plugin. While I was down there I addressed the issue of the shifter linkage not lining up and found out the lever was flipped backwards because my brother in law unbolted it from the shaft where the park neutral switch slides through and I guess we put it on directly backwards because it came off the linkage when it hung. Fixed all that. So then I got into the TB and put the key in. All lights. And the brake released the shifter and I slid through the gears. Everything good. Put it in park and realized I didn't even try to start it so I tried and BOOM she came alive!! Everything working great. Ran it through. Did fluids. Trans, power steering, dexcool. Just wanted to update so it wasn't left hanging. Thank you all for you help!
Reply With Quote Quick reply to this message
  #8  
Old 01-29-2018, 07:08 AM
NJTB04 NJTB04 is offline
Member
 
2004 Chevy TrailBlazer LS
Pewter Metallic 4.2L I6 4X4
Join Date: Aug 2012
Location: Edison, NJ
Posts: 230
Thanks for the update, glad it worked out for you.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live (ex: Philadephia, PA)
Vehicle Year
Choose your year
Or enter your choice here:
Vehicle Color
Choose your factory color (Custom, Not Listed & Two-Tones; Use Text Field Below)
Or enter your choice here:
Vehicle Make
Choose your make
Or enter your choice here:
Vehicle Model
Choose your model
Or enter your choice here:
Vehicle Engine
Choose your engine
Vehicle Drivetrain
Choose your vehicle drivetrain
Security Question
Fill in the blanks: Tra___oy
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 09:01 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed