Envoy AC clutch engages with fan switch - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 General Tech Q&A > General

General If it doesn't fit in any other forum

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 07-16-2019, 06:15 PM
Sabre48 Sabre48 is offline
Junior Member
 
2007 GMC Envoy SLT
Graystone Metallic 4.2L I6 4X4
Join Date: May 2017
Location: Charlestown, RI
Posts: 5
Envoy AC clutch engages with fan switch

2007 Envoy AC clutch engages and AC works well but it comes on when you turn on the fan (to any speed). The AC on/off switch lights when pressed but doesnít do anything. AC blows cold and the compressor cycles as it should. So anytime the fan is on, the compressor is engaged and I canít turn it on or off with the AC dash switch. Any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-16-2019, 07:51 PM
EnvoyBoy2004's Avatar
EnvoyBoy2004 EnvoyBoy2004 is offline
New Member
 
2004 GMC Envoy SLT
Graphite Metallic 4.2L I6 4X4
Join Date: Sep 2014
Location: NY
Posts: 2,068
Do you have the Auto or Manual (sliders) HVAC system?
Reply With Quote Quick reply to this message
  #3  
Old 07-16-2019, 08:36 PM
Sabre48 Sabre48 is offline
Junior Member
 
2007 GMC Envoy SLT
Graystone Metallic 4.2L I6 4X4
Join Date: May 2017
Location: Charlestown, RI
Posts: 5
Manual slide
Reply With Quote Quick reply to this message
 
  #4  
Old 07-16-2019, 09:00 PM
EnvoyBoy2004's Avatar
EnvoyBoy2004 EnvoyBoy2004 is offline
New Member
 
2004 GMC Envoy SLT
Graphite Metallic 4.2L I6 4X4
Join Date: Sep 2014
Location: NY
Posts: 2,068
This is only an educated guess, I would have to suspect the control panel itself. If it were the compressor relay, the blower switch would not affect it. You might want to go to a salvage yard and see if you can pick one up there.
Reply With Quote Quick reply to this message
  #5  
Old 07-16-2019, 09:38 PM
Sabre48 Sabre48 is offline
Junior Member
 
2007 GMC Envoy SLT
Graystone Metallic 4.2L I6 4X4
Join Date: May 2017
Location: Charlestown, RI
Posts: 5
Control panel being where the switch is?
Reply With Quote Quick reply to this message
  #6  
Old 07-16-2019, 11:02 PM
EnvoyBoy2004's Avatar
EnvoyBoy2004 EnvoyBoy2004 is offline
New Member
 
2004 GMC Envoy SLT
Graphite Metallic 4.2L I6 4X4
Join Date: Sep 2014
Location: NY
Posts: 2,068
Yes, the panel with the sliders.
Reply With Quote Quick reply to this message
  #7  
Old 07-17-2019, 08:00 PM
Sabre48 Sabre48 is offline
Junior Member
 
2007 GMC Envoy SLT
Graystone Metallic 4.2L I6 4X4
Join Date: May 2017
Location: Charlestown, RI
Posts: 5
Solved

I tried disconnecting the battery for a few minutes. Itís now working the way it should! Got to love such an easy fix. Thanks for your help in any event.
Reply With Quote Quick reply to this message
  #8  
Old 07-18-2019, 10:21 AM
EnvoyBoy2004's Avatar
EnvoyBoy2004 EnvoyBoy2004 is offline
New Member
 
2004 GMC Envoy SLT
Graphite Metallic 4.2L I6 4X4
Join Date: Sep 2014
Location: NY
Posts: 2,068
That's a new on me. That usually will only cause the system to recalibrate the actuators. Glad it is fixed.
Reply With Quote Quick reply to this message
  #9  
Old 07-19-2019, 08:12 AM
vipergg's Avatar
vipergg vipergg is offline
Senior Member
 
2008 Isuzu Ascender
Midnight Metallic 4.2L I6 2WD
Join Date: Mar 2007
Location: Rochester,NY
Posts: 970
Yeah it weird the way that works . I was having all kinds of issues with the stupid TPMS system and as last resort I pulled the fuses to the BCM for 3 minutes and reinserted and never had another issue . I LOVE COMPUTERS !!!
__________________
2008 Isuzu Ascender 140000 miles
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2014 Dodge Grand Caravan 90000 miles
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 06:46 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright © 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed