2004 Envoy 4.2 Lack of power while warming up and.. - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > Engine Tunes/Mods

Engine Tunes/Mods Performance Engine Tuning/Engine Modifications

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 06-22-2019, 01:38 PM
Rocket Dawg Rocket Dawg is offline
Junior Member
 
2004 GMC Envoy SLT
Dark Green Metallic 4.2L I6 4X4
Join Date: Jun 2016
Location: Grand Rapids Mi
Posts: 13
2004 Envoy 4.2 Lack of power while warming up and..

And sometimes it stalls at idle. No "check engine light" so far. You tubed a dirty throttle body cleaning video and that will be performed.
This Envoy stays at our cabin most of the time and has 128k on the ticker.
Any common problems that we should look into? Recent new parts-battery-water pump- air filter etc..thats about it. I have no idea what the previous history is on this as we bought it with 117K on it 3 to 4 years ago. It has been running great until last week. thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-30-2019, 09:40 AM
Rocket Dawg Rocket Dawg is offline
Junior Member
 
2004 GMC Envoy SLT
Dark Green Metallic 4.2L I6 4X4
Join Date: Jun 2016
Location: Grand Rapids Mi
Posts: 13
I must have put this in the wrong area.
Reply With Quote Quick reply to this message
  #3  
Old 07-13-2019, 01:56 PM
Rocket Dawg Rocket Dawg is offline
Junior Member
 
2004 GMC Envoy SLT
Dark Green Metallic 4.2L I6 4X4
Join Date: Jun 2016
Location: Grand Rapids Mi
Posts: 13
cleaned the throttle body and it still hesitates while warming up. We put fresh gas in and still the same issue. new plugs later today. Anybody ever have anything like this??
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 10:36 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed