P0521 cured - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 5.3L V8 Engine and Drivetrain > OEM Issues

OEM Issues Original Equipment Repairs and/or Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 06-11-2019, 08:34 AM
Pat80flh Pat80flh is offline
Junior Member
 
Join Date: Apr 2019
Posts: 4
P0521 cured

I replaced my cam and lifters, deleted AFM, had the ECM reflashed, and replaced the oil pump with a Melling. Got it all together ran great, no noise, solid and immediate oil pressure. BUT, during the first 1000 miles, I was getting an intermittent P0521, oil pressure out of range. There was no rhyme or reason, it happened once within 30 feet of leaving driveway on a cold start, other times 100 miles into a long drive. Gauge always showed good oil pressure for what it's worth(nothing). No noise, crankcase full, no other symptoms of low oil pressure.

It worried me, an oil pressure problem is not something I'll ignore. I racked my brain, trying to come up with a plan to diagnose it that did not include pulling the oil pan/diff again. The randomness of the failure is what puzzled me, not your usual low pressure at idle problem, it almost always occurred at speed. I finally decided to dump the conventional oil early and put some synthetic in there, something I planned to do after the first 1000 miles. So off to the zone I went. When I purchased the rig, there was a nice new Fram filter in the front seat which I happily used, my parts bill was getting out of control. But as I looked through the catalog, I saw the Delco filter listing contained a note ,PF46E contains a built in check valve. I opened up a Delco filter box, looks like a regular oil filter. I opened a Fram and an STP filter, both had a large rubber flap that looks like it was designed for anti-drainback. I bought the Delco anyway and guess what, problem solved. The girl behind the counter was trying to talk me out of the Delco filter because there was a special on oil/filter combos and the Delco was twice the price.

You can't put a price on peace of mind.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-11-2019, 11:36 AM
mddombrowski mddombrowski is offline
Member
 
2006 Chevy TrailBlazer LT EXT
Summit White 4.2L I6 4X4
Join Date: Jan 2017
Location: Charlotte, NC
Posts: 195
When all else fails... go to the OEM. I use Fram because I like the grippy stuff they coat the filter with, but I only use their premium filter, not the standard orange one.
Reply With Quote Quick reply to this message
  #3  
Old 06-12-2019, 07:20 PM
suzieq suzieq is offline
Junior Member
 
Join Date: Aug 2018
Posts: 6
Stay with OEM delco filter, never had anything but problems with fram filters.
Reply With Quote Quick reply to this message
 
  #4  
Old 06-14-2019, 09:12 AM
TB-Al's Avatar
TB-Al TB-Al is offline
New Member
 
2007 Chevy TrailBlazer LS
Graystone Metallic 4.2L I6 2WD
Join Date: Nov 2017
Location: Pleasure Island, Al.
Posts: 338
Bob is the oil guy is the best place to get oil and filter answers. https://www.bobistheoilguy.com/ Years ago he had a test of many different oil filters. Used them a while and then cut them apart to see how they were made and how they performed. Fram was the absolute worse. Fram oil filters are also known to come apart under pressure. Cheap filter material and cheap cardboard where others use metal. I've used Wix for many years but would not have a problem with OEM. GM does know what they are doing most of the time.
__________________
"It is useless to do with more what can be done with less." William of Occam
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 04:54 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed