08 TBSS won't start - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2006 - 2009 TrailBlazer SS Tech > 06-09 SS Engine and Drivetrain > Engine Tunes/Mods

Engine Tunes/Mods Engine tuning and/or modifications

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 02-06-2019, 07:02 PM
LoloMike LoloMike is offline
Junior Member
 
2007 Chevy TrailBlazer LT
Graystone Metallic 4.2L I6 4X4
Join Date: Apr 2016
Location: Lolo, MT
Posts: 6
08 TBSS won't start

Recently had remote start installed and worked fine for a couple of months. The remote start still works great but now when I try to start it with the key, all the dash lights come on but nothing else happens. If I play around with it, sometimes it will start but most times I have to push the button on the remote start to get it started. Could it be something in the remote start package causing this? I had no problems prior to installing the remote start.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-13-2019, 07:37 PM
LoloMike LoloMike is offline
Junior Member
 
2007 Chevy TrailBlazer LT
Graystone Metallic 4.2L I6 4X4
Join Date: Apr 2016
Location: Lolo, MT
Posts: 6
Any ideas?

Must be a one of a kind problem?
Reply With Quote Quick reply to this message
  #3  
Old 02-14-2019, 08:41 AM
TB-Al's Avatar
TB-Al TB-Al is offline
Member
 
2007 Chevy TrailBlazer LS
Graystone Metallic 4.2L I6 2WD
Join Date: Nov 2017
Location: Pleasure Island, Al.
Posts: 301
Easiest way to find the problem will be to start by removing the changes you made. At this point all we can say is something has failed.
__________________
"It is useless to do with more what can be done with less." William of Occam
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live (ex: Philadephia, PA)
Vehicle Year
Choose your year
Or enter your choice here:
Vehicle Color
Choose your factory color (Custom, Not Listed & Two-Tones; Use Text Field Below)
Or enter your choice here:
Vehicle Make
Choose your make
Or enter your choice here:
Vehicle Model
Choose your model
Or enter your choice here:
Vehicle Engine
Choose your engine
Vehicle Drivetrain
Choose your vehicle drivetrain
Security Question
Fill in the blanks: Tra___oy
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] bulldog remote start help ytri2008ss The 06-09 SS "How-To" and DIY Section 2 01-18-2013 12:13 PM
Trailblazer SS Won't start, changed Ignition Switch thelife General 12 12-19-2012 12:59 AM
Need Help Diagnosing a No Crank, No Start Condition nnolte General 2 12-01-2012 08:28 AM
06' TBSS wont start onevette80 OEM Issues 6 10-27-2008 10:54 AM
Remote Start in TBSS CrazySS1109 Audio and Electronics 22 04-11-2007 10:54 AM


» Sponsors

Advertising Info

All times are GMT -4. The time now is 05:39 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed