04 Rack and Pinion problem - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > The 02-09 "How-To" and DIY Section

The 02-09 "How-To" and DIY Section Threads on Do-It-Yourself and How-To goes here.

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 12-01-2019, 03:36 PM
V-8 Owner2 V-8 Owner2 is offline
New Member
 
Join Date: Dec 2019
Posts: 1
04 Rack and Pinion problem----solved

04 5.3L Envoy...Been trying to replace the rack and pinion. On my 3rd 1 so its looking like the rack isnt the problem, all 3 have the same setup. I did find out there were different part numbers for the v-8 and the 6 cyl even though holding them side by side I cant see any difference . Also the part number for the v-8 is no longer available so Im having to get these from junkyards.
The problem Im having is once the rack is in place the distance between the steering shaft and the racks shaft is about 2.5"....while the coupler that bolts them together is about 5". There is no way to install it. The only thing I can come up with is the steering shaft must have dropped down some but I cant find any info on how to get it back up if thats the case. It certainly wont move by hand or light tapping, twisting or turning. Any ideas what I need to do??
Attached Images
 
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 05:44 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed