Envoy 4WD Not Working - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 5.3L V8 Engine and Drivetrain > 4x4 Drivetrain

4x4 Drivetrain 4x4 Repairs & Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 01-14-2019, 01:55 PM
Navnik531 Navnik531 is offline
Junior Member
 
2003 GMC Envoy SLT XL
Summit White 4.2L I6 4X4
Join Date: Mar 2016
Location: Duluth, MN
Posts: 4
Envoy 4WD Not Working

Hey Everyone,

So on Friday I got around to replacing the starter on my 03 Envoy XL. It went about as smooth as could be expected and all seemed to work fine after it was installed. On Saturday I had to run a few errands and noticed there was no light illuminated on the 4wd selector switch. I did a bit of reading on the forums to try and get an idea of what may have caused this so I started with an easy one.

I removed Fuse #8 for about 30 seconds with the ignition off, put the fuse back in after 30 seconds and still no light on the selector switch when the ignitions is turned on. And I do mean there is no light at all, even when turning the ignition to on it doesn’t even blink on and off.

Now with the ignition on, I rotated the selector switch from 2HI to AWD and could hear a distinct whirring / whining. When it was rotated from AWD to 4HI it also makes a whining sound. After it was in 4HI (still no light on the selector switch) I crawled under the vehicle and tried to rotate the Forward driveshaft, but it did not turn at all. I had the front of the vehicle jacked up at this point also, and when I rotated the wheels they rotated fairly freely. I then got back in the vehicle, switched the selector switch back to 2HI (I could hear the whining and whirring) got under the vehicle again and I could rotate the forward driveshaft freely. I checked the wheels again and they rotated freely, but the seemed to be a lot easier to turn now in 2HI than when I had it in 4HI. Now it did not happen every time, but I did sit there and rotate the selector switch back and forth quite a few times from 2HI to 4LO, and sometimes the Service 4WD lamp would illuminate. It would sometimes turn on after 4 or 5 full rotations, but sometimes I did 20+ rotations and it never came on. It would always go away though when the ignition was turned off, and did not turn back on when the ignition was turned on again.

At this point I am not sure what I should be looking at / replacing. Did this possibly have something to do with replacing my starter? I have seen many things on the forum from the 4WD Actuator, to the Encoder motor, to the TCCM to the Selector Switch as being bad, but I am just unsure where I should look at this point with my particular issue. Any help would be immensely appreciated, and if I need more information on something please let me know. Thank you all again!

Nick
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live (ex: Philadephia, PA)
Vehicle Year
Choose your year
Or enter your choice here:
Vehicle Color
Choose your factory color (Custom, Not Listed & Two-Tones; Use Text Field Below)
Or enter your choice here:
Vehicle Make
Choose your make
Or enter your choice here:
Vehicle Model
Choose your model
Or enter your choice here:
Vehicle Engine
Choose your engine
Vehicle Drivetrain
Choose your vehicle drivetrain
Security Question
Fill in the blanks: Tra___oy
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 09:08 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed