Low oil pressure / stop engine warning - Page 3 - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 5.3L V8 Engine and Drivetrain > Engine Tunes/Mods

Engine Tunes/Mods Performance Engine Tuning/Engine Modifications

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #21  
Old 08-13-2018, 06:48 AM
princej99 princej99 is offline
New Member
 
2008 GMC Envoy SLE
Bordeaux Red Metallic 4.2L I6 4X4
Join Date: Jan 2018
Location: ont
Posts: 533
has this issue been identified?

as it only appears to be a problem with the 5.3 V*

what is the latest on this?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #22  
Old 08-13-2018, 08:25 AM
Jdanyel73 Jdanyel73 is offline
Junior Member
 
Join Date: Aug 2018
Posts: 2
It happened late last night. Has not been looked at yet. But it is the 5.3 engine
Reply With Quote Quick reply to this message
  #23  
Old 12-21-2018, 08:08 PM
HeartOfDorkness HeartOfDorkness is offline
Junior Member
 
Join Date: Oct 2018
Posts: 1
Jdanyel73, what was the result of that?
Reply With Quote Quick reply to this message
 
  #24  
Old 02-24-2019, 10:39 PM
MMAFighter941 MMAFighter941 is offline
Junior Member
 
Join Date: Jul 2018
Posts: 1
I had this when I got my Envoy 5.3l 2 weeks ago. I just replaced the oil pressure sensor and took out the filter under the sensor when I did an oil change. Haven't had the message return yet and it has been a week.
Reply With Quote Quick reply to this message
  #25  
Old 02-27-2019, 08:48 PM
astroracer astroracer is offline
Junior Member
 
2008 GMC Envoy Denali
Carbon Black Metallic 5.3L V8 4X4
Join Date: Aug 2018
Location: Mid-Michigan
Posts: 75
There is a screen under the oil pressure sender that needs to be changed as well as the sender. Just went thru this with my '08. Scared the **** out of me to tell the truth! Replaced both parts, did an oil change and all is right with the world.
Mark
Reply With Quote Quick reply to this message
  #26  
Old 04-20-2019, 11:43 AM
blaqyukon's Avatar
blaqyukon blaqyukon is offline
Junior Member
 
2007 GMC Envoy Denali
Summit White 5.3L V8 4X4
Join Date: May 2017
Location: new york
Posts: 3
Low oil pressure @ cold starts

Zippy i have the same problem when my Vortec is cold the pressure drops until
I am warmed up @ 200 on the temp gauge, then the lol is fine.. so my first attack is the oil sender unit and here goes something I donít see people say they
Do when changing the oil pressure switch is the filter underneath the oil switch,
Itís a real a %^&* to get to but when you see how thin the screen is on this small filter you can see why maybe the oil is dropping, but if i had time iíd Put a pressure gauge in 2 areas to see. If the pressure is really dropping. Some type tap some place near the oil pump or down the line before it gets to the top of the block. Well Iíve been real busy working hard but one side wants to jump in
And do it the other side is saying hell no, no matter how those guys make to that job is, when i stand in front my truck is does not look like that, i wonder how the dealer suckers do it.. no disrespect to the good dealer machanicís..
But i am going to do the job soon..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 02:44 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright © 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed