05 envoy denali no crank no start - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 General Tech Q&A > General

General If it doesn't fit in any other forum

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 11-07-2018, 05:13 PM
Denali411 Denali411 is offline
Junior Member
 
2005 GMC Envoy Denali
Black Granite Metallic 5.3L V8 4X4
Join Date: Oct 2015
Location: Jersey City,NJ
Posts: 12
05 envoy denali no crank no start

Hello guys I'm having and issue with my 05 envoy denali. When I try to start it up I usually have to leave it in the on postion for a few min then it would start up. Now when I try to start it up..... Nothing. I change the ignition switch the small box under the steering colum... Same issue.... All the lights come on.... Everything works... Just when I try to start nothing everything cuts off then when I release everything lights up and working again. And idea on what's going on... Thanks in advance
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-10-2018, 03:27 PM
06denaliman 06denaliman is offline
Junior Member
 
2006 GMC TrailBlazer LS
Cranberry Red Metallic 5.3L V8 4X4
Join Date: Mar 2018
Location: Mount Airy
Posts: 86
Have you tried hitting the starter and see if it starts if it does its most likely your cause. Had same issue on my 06 denali. Replaced ignition switch no change then replaced starter and all fixed. Tested it the same way i just told you. If yours is a 5.3 plan for an afternoon of curse words changing the starter. Altho its really not a terrible task it is a pain. Took me 4 hours start to finish doing it in my gravel driveway on jack stands with hand tools.


Sent from my iPhone using Tapatalk
Reply With Quote Quick reply to this message
  #3  
Old 11-10-2018, 05:30 PM
Denali411 Denali411 is offline
Junior Member
 
2005 GMC Envoy Denali
Black Granite Metallic 5.3L V8 4X4
Join Date: Oct 2015
Location: Jersey City,NJ
Posts: 12
Thanks for the help... I'll give it a try and let you know how it goes
Reply With Quote Quick reply to this message
 
  #4  
Old 11-10-2018, 06:41 PM
06denaliman 06denaliman is offline
Junior Member
 
2006 GMC TrailBlazer LS
Cranberry Red Metallic 5.3L V8 4X4
Join Date: Mar 2018
Location: Mount Airy
Posts: 86
Quote:
Originally Posted by Denali411 View Post
Thanks for the help... I'll give it a try and let you know how it goes


No problem def let us know the outcome


Sent from my iPhone using Tapatalk
Reply With Quote Quick reply to this message
  #5  
Old 06-06-2019, 08:44 AM
Denali411 Denali411 is offline
Junior Member
 
2005 GMC Envoy Denali
Black Granite Metallic 5.3L V8 4X4
Join Date: Oct 2015
Location: Jersey City,NJ
Posts: 12
Been awhile since I posted but I got the starter replaced but now I'm having another issue. When I try to start the vehicle it cranks up idle rough then after 5 secs it would turn off. I would have to wait 5 mins to restart. I restarted again this time I gave it gas. It ran but when i left off the gas it would turn off. Any idea on what could be going on...Thanks in advance any help would be appreciated.
Reply With Quote Quick reply to this message
  #6  
Old 06-07-2019, 10:30 AM
mddombrowski mddombrowski is offline
Member
 
2006 Chevy TrailBlazer LT EXT
Summit White 4.2L I6 4X4
Join Date: Jan 2017
Location: Charlotte, NC
Posts: 188
Sounds like air/fuel imbalance. When it does run, is the MIL illuminated? Scanned for codes?
Reply With Quote Quick reply to this message
  #7  
Old 06-07-2019, 09:07 PM
Denali411 Denali411 is offline
Junior Member
 
2005 GMC Envoy Denali
Black Granite Metallic 5.3L V8 4X4
Join Date: Oct 2015
Location: Jersey City,NJ
Posts: 12
Havent gotten codes pull yet will try first thing tomorrow morning. The Mil? I'm sorry new to this...
Reply With Quote Quick reply to this message
  #8  
Old 06-07-2019, 09:22 PM
mddombrowski mddombrowski is offline
Member
 
2006 Chevy TrailBlazer LT EXT
Summit White 4.2L I6 4X4
Join Date: Jan 2017
Location: Charlotte, NC
Posts: 188
No worries. MIL = Malfunction Indicator Lamp aka Check Engine Light


Sent from my iPhone using Tapatalk
Reply With Quote Quick reply to this message
  #9  
Old 06-07-2019, 09:26 PM
Denali411 Denali411 is offline
Junior Member
 
2005 GMC Envoy Denali
Black Granite Metallic 5.3L V8 4X4
Join Date: Oct 2015
Location: Jersey City,NJ
Posts: 12
Yes its on... it wasn't on prior to the starter installation..just had the starter installed now I'm having this issue...
Reply With Quote Quick reply to this message
  #10  
Old 06-14-2019, 03:17 PM
Denali411 Denali411 is offline
Junior Member
 
2005 GMC Envoy Denali
Black Granite Metallic 5.3L V8 4X4
Join Date: Oct 2015
Location: Jersey City,NJ
Posts: 12
Finally got the car to a shop for diagnostic and was told the computer is no good and needs to be replaced. Wanted to know is this something expensive and worth fixing....thanks in advance
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live (ex: Philadephia, PA)
Vehicle Year
Choose your year
Or enter your choice here:
Vehicle Color
Choose your factory color (Custom, Not Listed & Two-Tones; Use Text Field Below)
Or enter your choice here:
Vehicle Make
Choose your make
Or enter your choice here:
Vehicle Model
Choose your model
Or enter your choice here:
Vehicle Engine
Choose your engine
Vehicle Drivetrain
Choose your vehicle drivetrain
Security Question
Fill in the blanks: Tra___oy
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 10:20 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed