fan clutch follow up - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 General Tech Q&A > General

General If it doesn't fit in any other forum

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 05-09-2019, 10:12 PM
jroden jroden is offline
Junior Member
 
Join Date: Dec 2018
Posts: 39
fan clutch follow up

I did my fan clutch and water pump a month ago, but I notice that on startup and for the first minute of driving, the clutch seems to stay locked.

Is this normal or do i need to do some sort of re-learning procedure?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-11-2019, 08:39 PM
josuec82 josuec82 is offline
Junior Member
 
Join Date: Apr 2019
Posts: 4
its normal for the first minute or two after start up
Reply With Quote Quick reply to this message
  #3  
Old 06-12-2019, 08:18 AM
mddombrowski mddombrowski is offline
Member
 
2006 Chevy TrailBlazer LT EXT
Summit White 4.2L I6 4X4
Join Date: Jan 2017
Location: Charlotte, NC
Posts: 195
This is expected behavior. GM issued a TSB for this exact concern. Search for TSB 06-06-02-003, Rev A issued Feb 14, 2006. I'd upload, but apparently there's a 250kb max for PDF attachments?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fan clutch 101 GMT 360 OEM Issues 371 09-22-2018 09:53 PM
More fan clutch woes dbtrailblazer OEM Issues 2 06-09-2014 11:15 PM
Bad water pump, fan clutch, or both :/ northfacetb123 OEM Issues 9 08-15-2011 03:17 PM
I have a clicking noise...is it my fan clutch? wallofamps OEM Issues 7 05-16-2010 04:01 AM
Fan Clutch 4.2 Question markhart1 OEM Issues 9 12-01-2008 08:10 PM


» Sponsors

Advertising Info

All times are GMT -4. The time now is 12:23 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed