Where is my engine oil going? - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > OEM Issues

OEM Issues Original Equipment Repairs and/or Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 05-15-2019, 05:33 PM
philsla philsla is offline
Junior Member
 
2002 GMC Envoy SLE
Cranberry Red Metallic 4.2L I6 2WD
Join Date: Jul 2013
Location: Lafayette, LA
Posts: 6
Where is my engine oil going?

Been using Mobil 1 synthetic oil in a 2003 4.2 engine with just over 200k miles. It has started consuming lots of oil. There is no leak so I can only assume it is being burned even though no smoke shows and it runs like a top. Any suggestions?

Thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-15-2019, 05:44 PM
setauketjeff's Avatar
setauketjeff setauketjeff is offline
Junior Member
 
2007 Chevy TrailBlazer LT
Silverstone Metallic 4.2L I6 4X4
Join Date: Oct 2008
Location: Long Island NY
Posts: 19
Quote:
Originally Posted by philsla View Post
Been using Mobil 1 synthetic oil in a 2003 4.2 engine with just over 200k miles. It has started consuming lots of oil. There is no leak so I can only assume it is being burned even though no smoke shows and it runs like a top. Any suggestions?

Thanks!
Sometimes it's not obvious when the smoke is coming out. Like when you accelerate to get onto a highway, you're looking ahead and to the lane next to you (left). Not behind in your rear view passenger side where the blue smoke would be. Also if you haven't, try the synthetic or mixed synthetic for older engines. They're designed to burn less (may be a higher viscosity for less leakage past rings).
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live (ex: Philadephia, PA)
Vehicle Year
Choose your year
Or enter your choice here:
Vehicle Color
Choose your factory color (Custom, Not Listed & Two-Tones; Use Text Field Below)
Or enter your choice here:
Vehicle Make
Choose your make
Or enter your choice here:
Vehicle Model
Choose your model
Or enter your choice here:
Vehicle Engine
Choose your engine
Vehicle Drivetrain
Choose your vehicle drivetrain
Security Question
Fill in the blanks: Tra___oy
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Front lower engine oil leak? bspurloc Engine Tunes/Mods 3 05-01-2019 07:35 PM
Using Oil - No Smoke mtnlovrs OEM Issues 24 12-29-2016 10:16 AM
Low Oil Pressure when engine is hot and at idle david stlouis Engine Tunes/Mods 8 10-07-2014 09:37 PM
Engine Running awful ChevyTb2003 General 40 11-17-2009 12:24 PM
oil pressure low check gauges blown engine sanulav OEM Issues 6 01-22-2009 12:05 PM


» Sponsors

Advertising Info

All times are GMT -4. The time now is 03:48 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed