Engine stall - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > OEM Issues

OEM Issues Original Equipment Repairs and/or Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 05-17-2019, 09:51 PM
dyrvulf1 dyrvulf1 is offline
Junior Member
 
Join Date: May 2019
Posts: 1
Engine stall

I just had a Jasper rebuild installed in my 2008 TB. When I got it back I had to replace the throttlebody as computer indicated it was bad. That fixed 95% of the issue. It will now stall out when I stop after it warms up unless I keep a little pressure on the accelerator to keep rpms up. All warning lights (reduced power, check engine and even a traction warning) that were on when I first started it after engine install are off and no lights warn of anything when it stalls. Has new cam sensor, crank sensor, cam solenoid.... any ideas on what to check next?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-18-2019, 07:58 AM
NJTB04 NJTB04 is offline
Member
 
2004 Chevy TrailBlazer LS
Pewter Metallic 4.2L I6 4X4
Join Date: Aug 2012
Location: Edison, NJ
Posts: 263
Try disconnecting the battery for 30 min. The computer will re-learn the idle.
When you replaced the throttle body, it 'remembered' the old settings.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live (ex: Philadephia, PA)
Vehicle Year
Choose your year
Or enter your choice here:
Vehicle Color
Choose your factory color (Custom, Not Listed & Two-Tones; Use Text Field Below)
Or enter your choice here:
Vehicle Make
Choose your make
Or enter your choice here:
Vehicle Model
Choose your model
Or enter your choice here:
Vehicle Engine
Choose your engine
Vehicle Drivetrain
Choose your vehicle drivetrain
Security Question
Fill in the blanks: Tra___oy
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Low idling speed when engine is warm, stall problems (not solved) Fritzell The 02-09 "How-To" and DIY Section 6 03-23-2015 03:39 PM
How To Seafoam Your Engine The RIGHT Way!!! Daddy Mitzo General 8 08-03-2011 04:01 PM
Erratic idle engine trys to stall gusroy Engine Tunes/Mods 5 05-26-2011 10:34 PM
Used engine installed after dealership cannot find water leak! myaerocars OEM Issues 19 06-28-2009 06:11 PM
Engine stall um_fan 02-09 Vortec 4.2L I-6 Engine and Drivetrain 9 11-09-2005 07:19 PM


» Sponsors

Advertising Info

All times are GMT -4. The time now is 03:52 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed