03 trailblazer - front cv axles do not engage - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > 4x4 Drivetrain

4x4 Drivetrain 4x4 Repairs & Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 07-14-2019, 04:39 PM
FrontierGander FrontierGander is offline
Junior Member
 
Join Date: Jul 2019
Posts: 2
03 trailblazer - front cv axles do not engage

Just picked this up yesterday and found out why it was sold.

03 trailblazer, 110k miles, no check engine lights or service lights on, 4x4 engages, even the front diff is spinning when i check it through the fill hole, as is the drive shaft from the transfer case. Both front axles will not move and are making a light grinding sound.

I put it in AWD - 4H - 4L, same issue no matter what. Those axles will not spin. Put it in neutral, they spin fine, as soon as you go into gear, they are frozen. And its just the cv axles.

Any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-14-2019, 05:16 PM
EnvoyBoy2004's Avatar
EnvoyBoy2004 EnvoyBoy2004 is offline
New Member
 
2004 GMC Envoy SLT
Graphite Metallic 4.2L I6 4X4
Join Date: Sep 2014
Location: NY
Posts: 2,072
Not sure what you mean "they are frozen"

Usually when the front drive does not work, but there is no Service 4WD light on, most likely is that the front disconnect is not working. If it's actuator was not working, the 4WD selector switch light would be blinking in 4H or 4L.
Reply With Quote Quick reply to this message
  #3  
Old 07-14-2019, 08:44 PM
FrontierGander FrontierGander is offline
Junior Member
 
Join Date: Jul 2019
Posts: 2
yes thats what we are thinking as well. I want to unplug it tomorrow and see if that grinding goes away. Probably a weak front disconnect actuator thats not fully engaging and just grinding a little gearing when I try it.

No blinking when its in 4h-4l, awd, nothing like that.

while i am at it, whats the most reliable brand/part store to buy replacements? Don't tell me autozone, i dont even buy air fresheners from that crap hole.
Reply With Quote Quick reply to this message
 
  #4  
Old 07-14-2019, 09:22 PM
EnvoyBoy2004's Avatar
EnvoyBoy2004 EnvoyBoy2004 is offline
New Member
 
2004 GMC Envoy SLT
Graphite Metallic 4.2L I6 4X4
Join Date: Sep 2014
Location: NY
Posts: 2,072
I doubt its the actuator, more likely the disconnect is breaking apart. They are notorious for going dry.

I usually by on-line, look at Rock Auto or GM Parts Direct.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 09:40 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed