Whistling noise when accelerator applied - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > Air Induction

Air Induction Performance Air Intake/Air Induction Modifications

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 01-16-2009, 06:15 PM
jlook95 jlook95 is offline
Junior Member
 
2004 Chevy TrailBlazer LT
Two-tone 4.2L I6 4X4
Join Date: Mar 2007
Location: Champaign, IL
Posts: 18
Whistling noise when accelerator applied

I have a 2004 Blazer with Vortec 4.3 I6. ~73K miles.

When I push down on the gas pedal in drive, a whistling noise ramps up like a tea kettle. About half way to the next gear, it dies off and starts again shortly in the next gear. It is very loud when the engine is cold, but quiets down slightly after the engine reaches normal operating temperatures.

Doesn't seem to be intake or injection because the engine accelerates just fine, idles and runs. Plenty of power and no noticeable decline in gas mileage.

I'm worried this is an EGR valve or something that isn't monitored because there is also no Check Engine light.

Thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-31-2011, 12:33 AM
TrailblazerLT03 TrailblazerLT03 is offline
Junior Member
 
2003 Chevy TrailBlazer LT
Pewter Metallic 4.2L I6 4X4
Join Date: Dec 2010
Location: Gig Harbor, Washington
Posts: 39
I have the exact same noise in my '03 TB, w/ I-6 with 103K. It whistles when I start driving in the morning and gets louder when I accelerate and decreases when I decelerate. After 2 miles it goes away. Could it by related to the fan clutch? I'll be interested in hearing from others with this symptom and of course any ideas or suggestions. Thanks. P.S. Sorry I don't have the answer.
Reply With Quote Quick reply to this message
  #3  
Old 07-20-2011, 06:25 PM
my-tb's Avatar
my-tb my-tb is offline
Member
 
2007 Chevy TrailBlazer LS
Bordeaux Red Metallic 4.2L I6 2WD
Join Date: Aug 2005
Location: Redford, Mi
Posts: 156
Mine does almost the same thing. When I hit the gas it will make the noise about halfway through the gear and then let off. Never does it ideling, rarely on decel, almost alway accel, sometimes crusing. I am going to try and take the thing in cause it is annoying. I'll update if they find something.

-Bryan
__________________
04 LS 2wd, 3.73, G80, 20% tints, K&N, Running Boards
(sold)
07 LS 2wd, 3.42, moonroof, bone stock...for now
Reply With Quote Quick reply to this message
 
  #4  
Old 07-24-2011, 05:31 PM
ryoung139 ryoung139 is offline
Junior Member
 
2005 Chevy TrailBlazer LS
Midnight Blue Metallic 4.2L I6 4X4
Join Date: Jun 2011
Location: Massena, NY
Posts: 20
Got the same noise took it to a mechanic and they said they have no clue what it is but it doesnt seem like anything is wrong
__________________
MarkMc 2.5" lift, PCMforless tune,K&N cai, Demolded, Debadged,Removed roof rack, Chrome billet grille, Vent visors
Reply With Quote Quick reply to this message
  #5  
Old 07-24-2011, 05:38 PM
SparkyJJO SparkyJJO is offline
TrailVoy Alumni
 
2002 Chevy TrailBlazer LS
Forest Green Metallic 4.2L I6 4X4
Join Date: Feb 2010
Location: Columbus, Ohio
Posts: 1,433
Usually, whistling in sync with engine RPM is a sign of a vacuum leak from a cracked or loose hose. I'd check all the vacuum hoses. Particularly rubber elbows as those tend to go bad sooner than the rest of the lines, and odds would be that it would be a smaller hose since one of those leaking wouldn't impact the performance much but would whistle pretty good. A larger leak will make the engine run funny.

Or, maybe someone installed a turbocharger while you were sleeping
Reply With Quote Quick reply to this message
  #6  
Old 02-20-2012, 04:53 PM
GhostWar's Avatar
GhostWar GhostWar is offline
Member
 
2005 Chevy TrailBlazer LS EXT
Summit White 4.2L I6 2WD
Join Date: Oct 2011
Location: Ventura,CA
Posts: 112
its a turbo! lol jk

mine has a whine noise when i gun the accelerator. reminds me of transformers
__________________
All LED White interior lighting, 100w hi beam, hella 50w white low beam.
Reply With Quote Quick reply to this message
  #7  
Old 03-06-2012, 05:13 PM
Dadavemyster Dadavemyster is offline
Junior Member
 
2002 Chevy TrailBlazer LT
Sandstone Metallic 4.2L I6 4X4
Join Date: Mar 2012
Location: Boston MA
Posts: 2
I've heard of a few cases of the transmission/differential fluid needing to be topped off or get clean flush to clear up a high pitched noise resembling a supercharger almost.. something worth checking anyway!
Reply With Quote Quick reply to this message
  #8  
Old 03-08-2012, 12:46 PM
BoilerRacingCo's Avatar
BoilerRacingCo BoilerRacingCo is offline
Junior Member
 
2003 Chevy TrailBlazer LT
Black 4.2L I6 4X4
Join Date: Aug 2007
Location: Lafayette, IN
Posts: 21
High RPM whistle

Mine has a whistle at high RPM as well. Will check vacuum hoses and re-post if I find anything.
Reply With Quote Quick reply to this message
  #9  
Old 03-15-2012, 04:40 PM
tincup33's Avatar
tincup33 tincup33 is offline
Junior Member
 
2008 Chevy TrailBlazer LS
Black 4.2L I6 4X4
Join Date: Dec 2011
Location: PDX
Posts: 6
I had a whistling sound until I had my rezzy removed. It almost sounded like it was coming from the engine bay and it happened every time I hard accelerated. Not sure if it's the same thing but it was worth the mention.
Reply With Quote Quick reply to this message
  #10  
Old 05-21-2012, 03:59 PM
GhostWar's Avatar
GhostWar GhostWar is offline
Member
 
2005 Chevy TrailBlazer LS EXT
Summit White 4.2L I6 2WD
Join Date: Oct 2011
Location: Ventura,CA
Posts: 112
if u go in reverse its super loud and sounds so awesome !
__________________
All LED White interior lighting, 100w hi beam, hella 50w white low beam.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
acceleration noise, egr valve, whistle, whistle noise, whistling

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 01:13 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed