Trailblazer Cruise control - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2013 Chevrolet Trailblazer > 2013+ Chevrolet Trailblazer Forum

2013+ Chevrolet Trailblazer Forum Discussion on the new upcoming 2013 Chevy Trailblazer

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 09-05-2019, 06:19 AM
CoolCell67 CoolCell67 is offline
New Member
 
Join Date: Aug 2019
Posts: 7
Trailblazer Cruise control

Thanks to this forum help I got my 05 Trailblazer ext ls running.

My cruise control is not work all my fuses are OK.

Were should I start to find the issue is there a common part or issue with cruise control on the 05 Trailblazer ext LS with 4.2L l6?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-05-2019, 08:51 AM
TB-Al's Avatar
TB-Al TB-Al is offline
New Member
 
2007 Chevy TrailBlazer LS
Graystone Metallic 4.2L I6 2WD
Join Date: Nov 2017
Location: Pleasure Island, Al.
Posts: 329
First easy check, are your brake lights on? Now that the easy test says nothing wrong there I would suspect the switch on the stalk. That was what was wrong with mine when I bought it. But you could get lucky and it is just a connector issue.
__________________
"It is useless to do with more what can be done with less." William of Occam
Reply With Quote Quick reply to this message
  #3  
Old 09-05-2019, 10:00 AM
EnvoyBoy2004's Avatar
EnvoyBoy2004 EnvoyBoy2004 is offline
New Member
 
2004 GMC Envoy SLT
Graphite Metallic 4.2L I6 4X4
Join Date: Sep 2014
Location: NY
Posts: 2,068
Also, if your Check Engine light is on the cruise control will not engage.
Reply With Quote Quick reply to this message
 
  #4  
Old 09-06-2019, 03:08 AM
CoolCell67 CoolCell67 is offline
New Member
 
Join Date: Aug 2019
Posts: 7
Had time to check today

1.) No light indicating the cruse is on
2.) Fuses OK
3. Brake light not stuck on

Could this be the the switch?

On the 05 trailblazer cruise is on the blinker switch with the front wind shield wipers and brights and dims.

The old style cruise not on the steering wheel were you press the end button to set cruise speed.

The wipers, bright/dim and blinkers work OK.

No engine light or error codes.
Reply With Quote Quick reply to this message
  #5  
Old 09-06-2019, 11:31 PM
TJBaker TJBaker is offline
New Member
 
2002 Chevy TrailBlazer LT
Summit White 4.2L I6 4X4
Join Date: Dec 2010
Location: Alcoa, TN
Posts: 27
The "brake light switch" is actually 3 separate switches in the one housing. The set of contacts for the actual brake lights don't interact with the contacts that disengage the cruise control. So even if your brake LIGHTS work normally the contacts that release the cruise control could be faulty.
Reply With Quote Quick reply to this message
  #6  
Old 09-11-2019, 07:38 PM
jacord2095's Avatar
jacord2095 jacord2095 is offline
New Member
 
2002 Chevy TrailBlazer LTZ
Black 4.2L I6 4X4
Join Date: Mar 2018
Location: spokane,wa
Posts: 2
I have 02 t/b let model my cruise was not working also found that when the stereo system was put in the wire that goes to the cruise control was cut near the steering column.. replaced wire works great, that was a tough one to find the problem after changing cruise switch checking fuses multiple times.
Reply With Quote Quick reply to this message
  #7  
Old 09-11-2019, 08:08 PM
2005AscenderXUV 2005AscenderXUV is offline
New Member
 
2005 Isuzu Ascender
Onyx Black 4.2L I6 2WD
Join Date: Sep 2015
Location: Shorewood, IL
Posts: 13
Quote:
Originally Posted by EnvoyBoy2004 View Post
Also, if your Check Engine light is on the cruise control will not engage.
Even if the light isn't on, an impending code can have the same effect.
Reply With Quote Quick reply to this message
  #8  
Old 09-11-2019, 09:14 PM
SR3000's Avatar
SR3000 SR3000 is offline
New Member
 
Join Date: Jan 2019
Posts: 2
Wheel sensors

Mine started having problems right after replacing a rotor. Never had any trouble before that. It's not completely dead but it turns itself off shortly after engaging the CC. I didn't want to go through the work of removing it and returning it so I just lived with it.
Reply With Quote Quick reply to this message
  #9  
Old 09-11-2019, 09:57 PM
andersonjos andersonjos is offline
New Member
 
2003 Chevy TrailBlazer LT EXT
Summit White 4.2L I6 2WD
Join Date: Apr 2016
Location: SantaRosa, TX
Posts: 1
I second the damaged / missing wire. I bought a 2003 trailblazer about 6 years ago, and the cruise never worked on it. I replaced the brake switch, the turn signal stalk, and was considering replacing the cruise control module.

Ended up finding a wiring diagram online, tested for voltage at the brake switch, and found a cut wire up under the dash.

Interestingly enough, I suspect it was also cut during a stereo install.
Reply With Quote Quick reply to this message
  #10  
Old 09-11-2019, 10:51 PM
wingerjw wingerjw is offline
New Member
 
2005 Chevy TrailBlazer LS EXT
Superior Blue Metallic 4.2L I6 2WD
Join Date: May 2010
Location: Alexandria, VA
Posts: 1
I have the 2005 EXT as well. Mine was the switch on Transmission. $40 part. Easy to get too. I think it is on the top of the transmission on the passenger side Been a few years since the replacement and still going
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 02:06 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed