Front 2 speakers only have high pitch and no bass, rear 2 speakers have no sound - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > General TrailVoy Discussion > Audio and Electronics

Audio and Electronics Discuss car audio, video, navigation, alarms, and other electronics here.

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 07-08-2018, 08:59 PM
westripple westripple is offline
Junior Member
 
2006 Chevy TrailBlazer LS
Dark Gray Metallic 4.2L I6 4X4
Join Date: Jul 2018
Location: Glenview, IL
Posts: 2
Exclamation Front 2 speakers only have high pitch and no bass, rear 2 speakers have no sound

I just bought a 2006 TB LS. The front 2 speakers do have sound, but it sounds like a phone playing music. There is no bass and just isn't what the speakers are supposed to sound like. I used to drive a 2005 TB LS so I know what they should sound like. The back 2 have no sound at all. The tweeters work in the front driver side but again have no real power in their sound and I can barley hear them. I've read as much as I can and some people have the EXACT same issue, as it seems to be fairly common. Someone wrote they replaced the radio and nothing was fixed. Another person said they replaced speakers and nothing was fixed. That makes me think the amp is bad. However, I don't want to order one and replace it and assume that is it. Any thoughts?

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-09-2018, 08:47 AM
princej99 princej99 is offline
Member
 
2008 GMC Envoy SLE
Bordeaux Red Metallic 4.2L I6 4X4
Join Date: Jan 2018
Location: ont
Posts: 367
Quote:
Originally Posted by westripple View Post
I just bought a 2006 TB LS. The front 2 speakers do have sound, but it sounds like a phone playing music. There is no bass and just isn't what the speakers are supposed to sound like. I used to drive a 2005 TB LS so I know what they should sound like. The back 2 have no sound at all. The tweeters work in the front driver side but again have no real power in their sound and I can barley hear them. I've read as much as I can and some people have the EXACT same issue, as it seems to be fairly common. Someone wrote they replaced the radio and nothing was fixed. Another person said they replaced speakers and nothing was fixed. That makes me think the amp is bad. However, I don't want to order one and replace it and assume that is it. Any thoughts?

Thanks
hi and welcome.

its the speakers themselves. its a known problem.

easy enough to replace. although be careful removing the door panels.
Reply With Quote Quick reply to this message
  #3  
Old 07-09-2018, 11:20 AM
TB-Al's Avatar
TB-Al TB-Al is offline
Member
 
2007 Chevy TrailBlazer LS
Graystone Metallic 4.2L I6 2WD
Join Date: Nov 2017
Location: Pleasure Island, Al.
Posts: 177
Replacing all 4 speakers was one of the first things I did when I bought my 2007 last fall. No sound from either rear. The right side was weak and the left side was tweeter only.

If you still doubt us that the speakers are the issue then buy 2 new inexpensive speakers for the rear. When that fixes the issue then buy the other 2. Or, if you are an audiophile and can't stand the thought of wasting $25 on a pair of cheap speakers, buy an expensive pair and hope that ISN'T the issue and you would have had to buy an expensive radio anyway. But those expensive speakers aren't going to sound much better than the cheap ones with the factory radio if the speakers are the issue.
__________________
"It is useless to do with more what can be done with less." William of Occam
Reply With Quote Quick reply to this message
 
  #4  
Old 07-09-2018, 05:09 PM
westripple westripple is offline
Junior Member
 
2006 Chevy TrailBlazer LS
Dark Gray Metallic 4.2L I6 4X4
Join Date: Jul 2018
Location: Glenview, IL
Posts: 2
Thanks guys. I hope you're right. I'm glad I asked before I assumed AMP.
Reply With Quote Quick reply to this message
  #5  
Old 07-12-2018, 09:13 AM
regionvoices regionvoices is offline
Junior Member
 
Envoy GMC Envoy SLE
Indigo Blue Metallic 4.2L I6 4X4
Join Date: Nov 2013
Location: Indiana
Posts: 9
Front speakers

Just changed all four of mine in a 2003 Envoy. The front ones have a independent tweeter and a driver. The driver is probably blown. I needed adapters to upgrade to 6.5s The front drivers are soldered on so pay attention to the polarity The tweeter is connected to the driver already So, if you get a coaxial speaker you'll have a 3 way in front. The rear one probably got wet That's what happened to mine Good luck
Reply With Quote Quick reply to this message
  #6  
Old 07-20-2018, 07:31 AM
rcott01's Avatar
rcott01 rcott01 is offline
Junior Member
 
2004 GMC Envoy SLT XL
Black 4.2L I6 4X4
Join Date: Feb 2016
Location: Eaton, OH
Posts: 9
I just had the same issue you do with my Saab 9 7X. I tried all the speakers put a new ground behind the radio and even checked the rear controls, but mine ended up being the amp in the rear of the truck. I bought an amp for mine at a Pick-n-Pull yard, it was under $15 and works great, plus it had a 30 day warranty
Reply With Quote Quick reply to this message
  #7  
Old 07-20-2018, 01:37 PM
STOVEBOLT STOVEBOLT is offline
Junior Member
 
2004 GMC Envoy SLT
Graphite Metallic 4.2L I6 4X4
Join Date: Nov 2017
Location: Indiana
Posts: 6
Quote:
Originally Posted by rcott01 View Post
I just had the same issue you do with my Saab 9 7X. I tried all the speakers put a new ground behind the radio and even checked the rear controls, but mine ended up being the amp in the rear of the truck. I bought an amp for mine at a Pick-n-Pull yard, it was under $15 and works great, plus it had a 30 day warranty
Did the sound come and go on both sides? That is the problem I have and I have replaced the HU and all four door speakers, to no avail. I have the Bose system. Most people that have said replacing speakers fixed their problem did not have the Bose system. I have thought for a while that it must be the stock amp but cannot confirm this.
Reply With Quote Quick reply to this message
  #8  
Old 07-20-2018, 04:42 PM
princej99 princej99 is offline
Member
 
2008 GMC Envoy SLE
Bordeaux Red Metallic 4.2L I6 4X4
Join Date: Jan 2018
Location: ont
Posts: 367
Quote:
Originally Posted by STOVEBOLT View Post
Did the sound come and go on both sides? That is the problem I have and I have replaced the HU and all four door speakers, to no avail. I have the Bose system. Most people that have said replacing speakers fixed their problem did not have the Bose system. I have thought for a while that it must be the stock amp but cannot confirm this.
the problem of the original poster was not with the Bose system.

your intermittent issue. is most likely the amp, I believe its located in the rear cargo area. check all wiring.
Reply With Quote Quick reply to this message
  #9  
Old 07-23-2018, 09:15 AM
STOVEBOLT STOVEBOLT is offline
Junior Member
 
2004 GMC Envoy SLT
Graphite Metallic 4.2L I6 4X4
Join Date: Nov 2017
Location: Indiana
Posts: 6
Quote:
Originally Posted by princej99 View Post
the problem of the original poster was not with the Bose system.

your intermittent issue. is most likely the amp, I believe its located in the rear cargo area. check all wiring.
Is there a way to test the amp?
Reply With Quote Quick reply to this message
  #10  
Old 07-23-2018, 01:22 PM
princej99 princej99 is offline
Member
 
2008 GMC Envoy SLE
Bordeaux Red Metallic 4.2L I6 4X4
Join Date: Jan 2018
Location: ont
Posts: 367
Quote:
Originally Posted by STOVEBOLT View Post
Is there a way to test the amp?
there should be some good info in this thread, including a wiring schematic.

hope it helps.

https://forums.trailvoy.com/showthread.php?t=61308
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live (ex: Philadephia, PA)
Vehicle Year
Choose your year
Or enter your choice here:
Vehicle Color
Choose your factory color (Custom, Not Listed & Two-Tones; Use Text Field Below)
Or enter your choice here:
Vehicle Make
Choose your make
Or enter your choice here:
Vehicle Model
Choose your model
Or enter your choice here:
Vehicle Engine
Choose your engine
Vehicle Drivetrain
Choose your vehicle drivetrain
Security Question
Fill in the blanks: Tra___oy
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 02:46 AM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed