2006 Envoy - 4wd not working - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum



Welcome Enthusiast! If you already own a Chevy TrailBlazer or GMC Envoy or perhaps thinking of purchasing such a vehicle, then you have come to the best TrailBlazer and Envoy site on the net! Rainier, Bravada, Ascender, and 9-7x owners welcome too!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to search and post topics, communicate privately with other members, respond to polls, upload content, and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Join Today!
Go Back   Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum > 2002 - 2009 TrailBlazer/Envoy Tech > 02-09 Vortec 4.2L I-6 Engine and Drivetrain > 4x4 Drivetrain

4x4 Drivetrain 4x4 Repairs & Problems

TrailVoy.com is the premier GMC Envoy Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools
  #1  
Old 09-05-2019, 10:46 AM
mossyoakglock mossyoakglock is offline
New Member
 
2006 GMC Envoy SLE
Light Pewter Metallic 4.2L I6 4X4
Join Date: Sep 2009
Location: Nashville, TN
Posts: 39
2006 Envoy - 4wd not working

My sister's 4wd does not work and we're not sure how long it hasn't worked.

We were at our lease and needed 4wd but it wouldn't engage. Got to looking at the 4wd disconnect and it was completely shot (seal was gone and was in pretty bad shape overall). Got that replaced along with the front diff actuator. I can hear an actuator engage as well.

We have also replaced the switch and replaced all fluids (inexpensive and cheap insurance) but it still does not work.

I found a step-by-step troubleshooting guide but haven't had a chance to try it out.

Any other common issues to look at? I haven't checked out the shift motor/actuator on the t-case yet though.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-08-2019, 09:45 PM
mossyoakglock mossyoakglock is offline
New Member
 
2006 GMC Envoy SLE
Light Pewter Metallic 4.2L I6 4X4
Join Date: Sep 2009
Location: Nashville, TN
Posts: 39
Nothing?

No suggestions or thoughts?
Reply With Quote Quick reply to this message
  #3  
Old 09-08-2019, 11:11 PM
EnvoyBoy2004's Avatar
EnvoyBoy2004 EnvoyBoy2004 is offline
New Member
 
2004 GMC Envoy SLT
Graphite Metallic 4.2L I6 4X4
Join Date: Sep 2014
Location: NY
Posts: 2,074
When you move the 4WD selector from 2WD to 4HI (or back), do you hear two distinct motor sounds? One should be from the disconnect actuator and the other from the encoder on the Transfer case.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum forums, you must first register.

Please enter your desired user name, your email address and other required details in the form below.
(Only letters, numbers, dashes and underscores are permitted for user names)
The user name that you choose is permanent and can never be changed.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Sponsors

Advertising Info

All times are GMT -4. The time now is 08:28 PM.


Chevy TrailBlazer and GMC Envoy Enthusiasts - Copyright 2004 - 2009 All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
RSS Feed